• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

check engine light not working after cluster swap.


haizrail

New Member
Joined
Aug 12, 2016
Messages
82
Reaction score
0
Points
0
Location
stoneville north Carolina
Vehicle Year
1996
Make / Model
ford
Transmission
Automatic
Figured I'd post the photos from the sellers listing before I went to sleep. and I can take a photo of the cluster that came out of the truck as well, Also the cluster I bought originally that I thought was defective I still have. the seller didn't want it back I believe it's the same model as the one I put in the truck. so that should help trace things.

Image to cluster that's in truck






tomorrow I'll take photos of the two I have laying around. the old one that came out of the truck and the one I thought was broke.
 


Rock Auto 5% Discount Code: F9A1A579ACFAD1: October 1st, 2021

Mark_88

New Member
Joined
Aug 11, 2007
Messages
18,550
Reaction score
228
Points
0
Age
65
Location
Ontario, Canada
Vehicle Year
2007
Make / Model
Dordge
Engine Size
3.3 Fuel Injected
Transmission
Automatic
My credo
Love Thy Neighbor
I had another look at the PDFs and they appear to be identical in that the MIL on both is located on pin 9 as RonD indicated...can't really see why that wouldn't work unless...it is using one of the screws to ground part of the circuit and you happened to test this without fastening it into the dash...

From what I understand though...the PCM provides the ground when needed so that shouldn't be the issue.
 

haizrail

New Member
Joined
Aug 12, 2016
Messages
82
Reaction score
0
Points
0
Location
stoneville north Carolina
Vehicle Year
1996
Make / Model
ford
Transmission
Automatic
Here Are the Images of the cluster that came out of the truck where the cel works with.








 
Last edited:

haizrail

New Member
Joined
Aug 12, 2016
Messages
82
Reaction score
0
Points
0
Location
stoneville north Carolina
Vehicle Year
1996
Make / Model
ford
Transmission
Automatic
Ok and here are the photos of the first cluster I bought thinking it was faulty. This cluster has the same layout as the one that's in the truck.























In the last few photos I tried tracing the cel light back to it starting location. I also, did this for the old cluster without tach in the previous photos. and it looks like the light on the cluster without tach it on the small white clip and the cluster with tach is on the black clip.
 

tomw

Well-Known Member
U.S. Military - Veteran
Joined
Aug 15, 2007
Messages
1,601
Reaction score
40
Points
48
Location
toenails of foothills NW of Atlanta
Vehicle Year
1985
Make / Model
ford
Engine Type
2.3 (4 Cylinder)
Engine Size
lima bean
Transmission
Manual
2WD / 4WD
2WD
My credo
vertical and above ground
In one of the first pics of the 'green' cluster, the CK ENGINE light was connected via a resistor to a trace that lead to pin '2' (second from left) at the bottom center of the picture.
Given you will use the same connectors, in the same position, you have a cluster that will not work. Pin '2' on the other clusters, original, and the follow-on, both have pin '2' of the center bottom connector floating in the breeze. It is not connected, and will never work.
I suggest you find a 3rd cluster(4th?) that matches your year and model.

The fuzzy pictures are too fuzzy for my old eyes, and I skipped even looking at them.
tom
 

haizrail

New Member
Joined
Aug 12, 2016
Messages
82
Reaction score
0
Points
0
Location
stoneville north Carolina
Vehicle Year
1996
Make / Model
ford
Transmission
Automatic
hey guys I've got my dash broke down and tom is right the cel is in pin 2 now how can I take this wire out and put in in the back clip were it needs to be.
 

Mark_88

New Member
Joined
Aug 11, 2007
Messages
18,550
Reaction score
228
Points
0
Age
65
Location
Ontario, Canada
Vehicle Year
2007
Make / Model
Dordge
Engine Size
3.3 Fuel Injected
Transmission
Automatic
My credo
Love Thy Neighbor
I'm glad tom could figure it out because every time I looked at more than two images on your PB account my computer would hang up and I had to keep closing the tab and relaunch it...

My 96 had a tach but it also had a manual transmission so I know they are out there...maybe look for another gauge pod that has both the automatic shift indicators and a tachometer...might save you more in the long run if you are not comfortable rewiring the ones you have...
 

haizrail

New Member
Joined
Aug 12, 2016
Messages
82
Reaction score
0
Points
0
Location
stoneville north Carolina
Vehicle Year
1996
Make / Model
ford
Transmission
Automatic
Well I done what you told me to do and that was trace the cel to it's origin, on the cluster with tach, and to be honest I think there is no pin in the back clip the runs to the cel, so this makes me believe that all I need to do is take the cel wire out of pin 2 and put it in pin 9 on the black clip, but I cant get the pin out and I don't want to brake it. do you know of any tool that can do this.
 

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
20,155
Reaction score
3,963
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Google: repinning ford connectors

There are a few different types, find the type you have.

Usually just a small tip screw driver or even paper clip can be inserted to release the tabs on the pin
 

Mark_88

New Member
Joined
Aug 11, 2007
Messages
18,550
Reaction score
228
Points
0
Age
65
Location
Ontario, Canada
Vehicle Year
2007
Make / Model
Dordge
Engine Size
3.3 Fuel Injected
Transmission
Automatic
My credo
Love Thy Neighbor

haizrail

New Member
Joined
Aug 12, 2016
Messages
82
Reaction score
0
Points
0
Location
stoneville north Carolina
Vehicle Year
1996
Make / Model
ford
Transmission
Automatic
Ok I had to put the truck back together because it was coming up a storm. However, I was able to take some photos of the white clip and the black clip. I went to the parts store two of them in fact and oreillys first and they said I needed a pin extractor, which I knew, but the guy there had to look it up in the book instead of the computer and here is the part number he came up with

oreilly auto parts
85360 - CTI

Napa Auto parts

Narrow blade .50
725168

wide blade .09
725169

I don't know if any of theses parts numbers will lead me to the right tool. that's also why I'm uploading some more photos as well. Also, I'm going to be uploading photos of the black clip so that we can verify pin 9.


















I hope this can lead to something.
 

haizrail

New Member
Joined
Aug 12, 2016
Messages
82
Reaction score
0
Points
0
Location
stoneville north Carolina
Vehicle Year
1996
Make / Model
ford
Transmission
Automatic
Okay, guys My research seems to be yielding results in theory anyway. I just came across this photo on google images, and it a great reference to the pin layouts

Now if this is correct then pin 9 on c2 is empty. So this should mean that all I need to do is take the pin out of pin 2 on c3 and put in pin 9 on c2.

Now just to figure out what kind of pin extractor I need because the last thing I want to do is brake the pin or harness in anyway.

 
Last edited:

haizrail

New Member
Joined
Aug 12, 2016
Messages
82
Reaction score
0
Points
0
Location
stoneville north Carolina
Vehicle Year
1996
Make / Model
ford
Transmission
Automatic
Well I'm still having trouble finding a pin extractor, until I find the correct one this job is at a stand still.
 

haizrail

New Member
Joined
Aug 12, 2016
Messages
82
Reaction score
0
Points
0
Location
stoneville north Carolina
Vehicle Year
1996
Make / Model
ford
Transmission
Automatic
Hello guys and Gals, I just ordered the pin extractor I need for this job.

It's an

Dorman 85360 Tech Term Extractor

and here is a link to were someone can buy it. The reason I'm posting this information is in case someone needs to do this on their ranger in the future.

https://autoplicity.com/2542256-dorman-85360-tech-term-extractor

Pleased be avised that there is a ad you need to skip in order to get the the autoplicity web link I posted. that is annoying I know.
 
Last edited:

Mark_88

New Member
Joined
Aug 11, 2007
Messages
18,550
Reaction score
228
Points
0
Age
65
Location
Ontario, Canada
Vehicle Year
2007
Make / Model
Dordge
Engine Size
3.3 Fuel Injected
Transmission
Automatic
My credo
Love Thy Neighbor
hope that works for you...my internet was disrupted by a careless tech so I've been out for a day or so...
 


Top