Started pinging


lvwill

Member
Joined
Sep 15, 2013
Messages
210
Reaction score
3
Points
18
Location
Las Vegas Nv.
Vehicle Year
1992
Make / Model
ford
Engine Size
2.9
Transmission
Automatic
Not sure what's going on with this. Replaced the dizzy a couple years ago due to a bad bearing. Don't drive the truck awhole lot maybe 4000 miles a year. All of a sudden it goes from running great to seriously pinging at any throttle position. No cell or any other problems. Was going to check timing, unplugged spout connecter and it was to hot to do anything else and basically forgot about it. Been driving it around for a week here and there with spout out and it seems to be fine but guttless. Plugged it back in and it started to ping again.
Anyone have any idea what I should be looking for?
This basically started overnight.

Thanks in advance for any help
William
 


Rock Auto 5% Discount Code: 57CD9601BD5AB4 Expires: July 1, 2019

RonD

Well-known member
Joined
Jun 2, 2012
Messages
12,782
Reaction score
154
Points
63
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
The SPOUT is the same as the Vacuum Advance was on a distributor, it was/is used to ****** or advance spark based on engine Load.

So yes gutless without spark advance under load, RPM advance is still working, TFI module does that on its own, so engine can run just not as well.
Computer has engine load data so sends out ****** and advance info to TFI module on that SPOUT wire

So did you check the base spark timing?
10-12 BTDC is popular choice for the 2.9l
This needs to be done first


Started overnight.
What about gasoline last added to the tank, all gasoline has water in it, and that water settles to the bottom of the gas tank when vehicle sits.
If last gasoline added had a bit more water than "normal", then you get a lean mix and pinging
HEET or Octane Boost is ethanol, ethanol can bond with water, gasoline can't, so it can help get rid of any water in the tank without the pinging
 
Last edited:

lvwill

Member
Joined
Sep 15, 2013
Messages
210
Reaction score
3
Points
18
Location
Las Vegas Nv.
Vehicle Year
1992
Make / Model
ford
Engine Size
2.9
Transmission
Automatic
I did set timing at 12 btdc when I put in the new distributor. I will check it out either tonight or in the morning. Not sure how it could have changed on it's own though. I've been putting premium in it ever since this happened. Forgot about the spout until this morning when I found it on the work bench.
I know this sounds stupid but at the moment the truck is my DD. I only drive it 22 miles a day but i need it until y b2 is done.
 

RonD

Well-known member
Joined
Jun 2, 2012
Messages
12,782
Reaction score
154
Points
63
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Distributor could have shifted, or sensor inside did, even TFI module could have an issue.
Looking at base timing would be where to start, just to take that off the table.

Then we can start GUESSING about other reasons for the pinging :)
 
Last edited:


Top