• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Rough 2.9l

PublicPlatypus

New Member
Joined
May 20, 2022
Messages
3
Reaction score
0
Points
1
Location
95540
Vehicle Year
1990
Make / Model
Ford Ranger
Engine Type
2.9 V6
Transmission
Manual
2WD / 4WD
4WD
I picked up a 1990 XLT with 4x4 that had been sitting outside for about 4 years not running. Gone through and replaced gas, fuel pump, filter, oil, plugs, injectors, IAC and MAP.... Still idling at around 1200 and kind of bogs a bit on 1st gear and barely gets enough power in 4th and 5th.. Not sure where to go from here and I really need to pass smog here in CA 🙄
Screenshot_20220411-172938_Gallery.jpg
 


Cees Klumper

Active Member
Joined
Nov 4, 2019
Messages
149
Reaction score
99
Points
28
Location
Marina del Rey, CA
Vehicle Year
1990
Make / Model
Bronco II XLT
Transmission
Automatic
Not sure but 1990 CA compliant don't have a MAP sensor, instead they have MAF.
Check routing and integrity of your vacuum lines.
Also perform the correct idle setting procedure (many mistake the set screw on the butterfly valve for an idle set, but that is all done by the IAC).
Are you sure about the quality of your new injectors? Not all are that good (lots of info here on that).
Fuel pressure ok? Can beasure easily at schrader valve.
Ignition timing set good (with spout connector removed)?
Any fault codes?
Best of luck!
 

PublicPlatypus

New Member
Joined
May 20, 2022
Messages
3
Reaction score
0
Points
1
Location
95540
Vehicle Year
1990
Make / Model
Ford Ranger
Engine Type
2.9 V6
Transmission
Manual
2WD / 4WD
4WD
Not sure but 1990 CA compliant don't have a MAP sensor, instead they have MAF.
Check routing and integrity of your vacuum lines.
Also perform the correct idle setting procedure (many mistake the set screw on the butterfly valve for an idle set, but that is all done by the IAC).
Are you sure about the quality of your new injectors? Not all are that good (lots of info here on that).
Fuel pressure ok? Can beasure easily at schrader valve.
Ignition timing set good (with spout connector removed)?
Any fault codes?
Best of luck!
No fault codes. No I'm not postitive about my injectors and have not tested fuel pressure since replacing them. I am planning on resetting idle next I suppose it's a good baseline. Is there a forum for setting ignition timing?
 

Sponsored Ad


Sponsored Ad

Top