• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Check engine light came on, code P1443


thebigyellowtruck

New Member
Joined
Jul 7, 2009
Messages
130
Reaction score
0
Points
0
Location
New Boston, MI
Vehicle Year
1997
Make / Model
Ford
Engine Size
2.3L 4 cylinder
Transmission
Automatic
I have a 1997 ranger with a 2.3 engine. just recently the check engine light came on. i checked the code with my girlfriends dads code reader and it came back P1443. I looked the code up online and it said that the code was "Evaporative Emission Control System Control Valve" it also said that in order to fix this problem i would need a canister purge solenoid. Is this factual information that i found? if so can anyone tell me where the canister purge solenoide is so that i can replace it? thanks in advance for the help.
 


Rock Auto 5% Discount Code: DE2235E7692E8C: July 5th, 2021

srteach

New Member
Joined
Aug 11, 2007
Messages
977
Reaction score
8
Points
0
Vehicle Year
1999, 2001
Make / Model
Ranger, F350
Engine Size
4.0L, 7.3 Diesel
Transmission
Manual
Factual? I don't know. The canister purge solenoid is in line to the purge canister.

On a 2.3, follow the hose that comes from the intake of the engine along the left fender well to a black plastic box near the front of the left side frame. The solenoid is inline with that hose, and should be mounted to the inside of the left fender. If I still had my 96, I could give a picture.

BTW, this valve only opens at high RPMs.
 

97ranger xlt

Member
Joined
Sep 11, 2007
Messages
259
Reaction score
5
Points
18
Location
Mass.
Vehicle Year
2002
Make / Model
Ford
Engine Size
4.0
Transmission
Automatic
I have a 1997 ranger with a 2.3 engine. just recently the check engine light came on. i checked the code with my girlfriends dads code reader and it came back P1443. I looked the code up online and it said that the code was "Evaporative Emission Control System Control Valve" it also said that in order to fix this problem i would need a canister purge solenoid. Is this factual information that i found? if so can anyone tell me where the canister purge solenoide is so that i can replace it? thanks in advance for the help.

you can try to clean the valve with carb cleaner. if that doesn't work replace. it. it is cheaper than the solenoid so do that first and see if it gets rid of the CEL.

in my case, i had to replace both, but i could only find the solenoid at the dealership.:annoyed:

also the code could be caused by a non/loose sealing gas cap so check that too.
 
Last edited:

SMTGREG

New Member
Joined
Aug 24, 2009
Messages
229
Reaction score
2
Points
0
Vehicle Year
1965
Make / Model
MGB
Engine Size
2.3 Lima
Transmission
Manual
DTC P1443: VISUAL CHECK OF EVAPORATIVE EMISSION SYSTEM

Continuous Memory Diagnostic Trouble Code (DTC) P1443 indicates an Evaporative emission control system or evaporative canister purge valve (mechanical) malfunction.

Possible causes:

Damaged EVAP canister.

Pinched, plugged, blocked, cracked, cut or disconnected fuel vapor tubes/hoses between the fuel tank, EVAP canister, EVAP canister purge valve, purge flow (PF) sensor, and the engine intake manifold.

Damaged EVAP canister purge valve.

Damaged PF sensor.

EVAP CANISTER PURGE, or PF circuit shorted to VPWR.
 

thebigyellowtruck

New Member
Joined
Jul 7, 2009
Messages
130
Reaction score
0
Points
0
Location
New Boston, MI
Vehicle Year
1997
Make / Model
Ford
Engine Size
2.3L 4 cylinder
Transmission
Automatic
thanks guys, i found it and it seems that the guy that had the truck before me rigged up the hose from the intake to the canister. there is a steel tube shoved in the hose in between, there are no clamps so perhaps it is leaking from there. i will check the other areas you told me. thanks a lot. i will let everyone know how it goes.
 

thebigyellowtruck

New Member
Joined
Jul 7, 2009
Messages
130
Reaction score
0
Points
0
Location
New Boston, MI
Vehicle Year
1997
Make / Model
Ford
Engine Size
2.3L 4 cylinder
Transmission
Automatic
i didnt replace the valve, but i put small clamps on a hose that i noticed was loose that was going to the valve. hopefully that will fix the problem. the check engine light is off, but i havent driven the truck yet.
 

stegomon

Active Member
V8 Engine Swap
Joined
Aug 9, 2007
Messages
2,155
Reaction score
14
Points
38
Age
36
Location
auburn/minot maine
Vehicle Year
1987/1990
Make / Model
fords and only
Transmission
Manual
how about the 3.0s?
 

rbrennec

New Member
Joined
Mar 8, 2011
Messages
10
Reaction score
0
Points
0
Vehicle Year
1996
Make / Model
Ford Ranger
Transmission
Manual
My light came on just the other day. Took it to Auto Zone for a free diag, came of P1443. Found this on another site.

Less than two months ago, I purchased a used 1997 Ford Ranger XLT, Regular Cab (2.3 L I-4, 5 spd.). Shortly after the purchase, the check engine light came. I had the code read at a local auto parts store, and the code P1443 was returned. The description for the code was “Evaporative Emission Control System Control Valve”. Initially, I didn’t do anything to fix the problem. The light ended up clearing itself a couple of days after it first came on. However, the light only stayed off for a few driving cycles before it came back on (and stayed on). I had the code read again, and again I got the P1443 code.
I did some research on the web and found that the problem could be the Canister Purge Assembly. This assembly connects the intake manifold to the charcoal canister and the assembly is made up of hoses, a valve and a sensor. On my 1997 Ranger, it is located near the front of the engine compartment on the driver’s side (the canister is right behind the driver’s side headlight). Apparently, if there are any cracks in the hoses, or if the valve or the sensor wears out, this will cause the check engine light to come on, and return the P1443 code. After looking around on the web for a couple of days, I was lucky enough to find a few part numbers for the canister purge solenoid/flow sensor assemblies:

F57Z-9C987-AB Canister Purge Solenoid/Flow Sensor
Assembly - 2.3L

F57Z-9C987-CA Canister Purge Solenoid/Flow Sensor
Assembly - 3.0L

F57Z-9C87-BA Canister Purge Solenoid/Flow Sensor
Assembly - 4.0L

After trying to get the part at a few different auto parts stores, I made a trip to the dealer to order the part. It ended up costing about $65 (although, I have heard it can cost $80 - $100 depending on the exact part number that you need). It only took 5 or 10 minutes to install the part, and it was fairly simple. Initially, I started the truck and the check engine light was still on. However, the light cleared itself after a few driving cycles and it has stayed off ever since (it has been about 5 weeks and 1500 miles).

Hopefully this helps someone who had the same problems that I did. From my experience, and from what I have found in my research, if you get the P1443 code on a late 90’s Ranger, this is the way to fix it. Hopefully you will be able to use the part numbers above to order your parts (I am not sure where on the web I originally got the part numbers from, but I did use them to order the part that I needed). I believe this is a part that you can only get at a dealer, so you may not even want to waste time trying to order it from the auto parts stores. I would rate this as a fairly easy thing to replace as long as you have some knowledge about working on cars and trucks. However, if you don’t feel comfortable doing it yourself, you may want to ask for help from a friend who is knowledgeable before you spend the money to have someone else do it.
 

rbrennec

New Member
Joined
Mar 8, 2011
Messages
10
Reaction score
0
Points
0
Vehicle Year
1996
Make / Model
Ford Ranger
Transmission
Manual
P1443

I have a '96 with the P1443 error. I don't see it behind the driver's side headlight. Is that where it is on the '96 also?
 

killj0y

New Member
Supporting Member
Joined
Mar 12, 2011
Messages
1,531
Reaction score
11
Points
0
Location
Edinburg, TX
Vehicle Year
1996
Make / Model
Ford
Engine Size
2.3l 4 Banger
Transmission
Manual
My credo
Fix it till its broke!
I had this exact same problem about 2 months ago and in just putting in a new air filter and cleaning the MAF as part of regular maintenance it cleared the code instantly lol. Seems dumb but have you checked that? I think i might have also just pushed in any vacuum lines i could see.
 

thomas swingruber

New Member
Joined
Sep 20, 2012
Messages
1
Reaction score
0
Points
0
Vehicle Year
1996
Make / Model
ford
Transmission
Manual
HI
I have written a detailed manual to trouble shoot the P1443 problem.
With lots of pictures.
I just got pissed trying to find good data.

Don't use a search engine! Just enter the address in the address bar www.tomshints.com
If you find it helpful send me an email at the address on the web page.
Enjoy
Tom
 
Last edited:

bustedknuckle

New Member
Joined
Sep 19, 2009
Messages
8
Reaction score
0
Points
0
Location
Pitsburgh
Vehicle Year
91, 98
Make / Model
ford
Engine Size
3.0/4.0
Transmission
Automatic
Tom, you sir are a pimp! Thank you so very much. I've been meaning to deal with this issue for awhile now, but now I have to since it's time for emissions inspections.
Thanks!
 

cvar

Member
Joined
Apr 27, 2012
Messages
588
Reaction score
19
Points
18
Vehicle Year
1997
Make / Model
Mazda
Engine Size
4.0L V6
Transmission
Automatic
Excellent write-up. Thanks Tom. Yeah, I have that same pesky code. CEL comes & goes every other day. I'll print this and go check my solenoid & sensor.

Cracked hoses cause it too? Hmm. This P1443 started about when I removed the gas tank and replaced brake lines, incl. beside the evap canister. Maybe I dislodged something? My canister hoses seemed ok, but I need a vacuum gauge. I suppose the gas-tank end of that hose might also crack?

How to determine if the canister itself is working? Does it ever go bad?
 

cvar

Member
Joined
Apr 27, 2012
Messages
588
Reaction score
19
Points
18
Vehicle Year
1997
Make / Model
Mazda
Engine Size
4.0L V6
Transmission
Automatic
Finally got around to opening the hood to solve this pesky p1443 code & CEL. Tom's excellent post found the problem. It was inoperative evap solenoid. So after replacing the $50 solenoid, my CEL is dark. Yay!

Thank you Tom! You da man!

Soon, I'll have to tackle the final p-code remaining: p1401 DPFE too high voltage. Cuz state emissions check is becoming due.
 

Kamel

New Member
Joined
Jul 1, 2012
Messages
5
Reaction score
0
Points
0
Vehicle Year
1995
Make / Model
Ford
Transmission
Manual
I'll be honest, I thought I was going to end up at some spam site when I clicked that link lol...

I was pleasantly surprised to find one of the most well written guides for vehicle repair I've ever seen. Thanks a ton for your write up Tom, I'm certain it's helped countless other people who didn't bother to say thanks. I really appreciate it!
 


Top