OBS 7.3 powerstroke glow plug relay on with engine running?


scotts90ranger

Active member
RBV's on Boost
Joined
Feb 28, 2001
Messages
3,912
Reaction score
23
Points
38
Location
Dayton Oregon
Vehicle Year
1990
Make / Model
Ford
Engine Size
2.3 Turbo
Transmission
Manual
My '97 F350 is somewhat neglected, there's an idler pulley or two that are toast and I opened the hood on a cold start on Tuesday to investigate a new growling noise (as opposed to the normal squeak) that went away as soon as I opened the hood... Anyway, I looked around and noticed a little smoke coming from the glow plug relay main power contacts while it was running which I thought was weird... shut it down and unplugged the control wires (didn't know which did what so undid both small wires) and taped up. I did a little looking online and now I'm thinking this could be normal and maybe within a minute or two it would have turned the relay off... Thoughts?
 


Rock Auto 5% Discount Code: 57CD9601BD5AB4 Expires: July 1, 2019

adsm08

Well-known member
Supporting Member
Ford Technician
TRS 20th Anniversary
Joined
Sep 20, 2009
Messages
30,807
Reaction score
570
Points
113
Location
Dillsburg PA
Vehicle Year
1987
Make / Model
Ford
Engine Type
4.0 V6
Engine Size
4.0
Transmission
Manual
2WD / 4WD
4WD
Tire Size
31X10.50X15
IIRC one the 7.3L the glow plugs are only on when the light is on.

On the later engines, the 6.0, 6.4, and 6.7 I know the computer will keep the glow plugs on after the engine is running for a little bit. I also know that if you jump start a 6.0 and disconnect your jumper cables before the glow plugs shut off you stall the engine.
 

scotts90ranger

Active member
RBV's on Boost
Joined
Feb 28, 2001
Messages
3,912
Reaction score
23
Points
38
Location
Dayton Oregon
Vehicle Year
1990
Make / Model
Ford
Engine Size
2.3 Turbo
Transmission
Manual
It was 40* the other day and I needed the thing to run, needed glow plugs... I hooked the relay back up and good to go. I imagine the heat on the posts and smoke is from a bad part ($20 Amazon special I believe...), I'll keep running it until something comes up, but for now it's working...
 


Top