• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Idle question & near stall

Mr99Ranger

New Member
Joined
Jan 20, 2010
Messages
240
Reaction score
2
Points
0
Location
West Virginia
Vehicle Year
1991
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
Hello, had a question on the idle speed on my 99 Ranger supercab. It idles around 1,000 RPM when warm and in park, and around 750 when in drive and stopped. Is this the proper speed? my 2000 runs about 900 in park and it also runs around 750 when in drive stopped. Does my 99 idle a bit too high? Also, went to move the 99 the other day, started it, and put it into 1 to pull it up the driveway, and it sputtered and tried to stall, so i put it back in park and let it warm up a little, then it ran and moved fine. My 2000 has never done this, and i tried it that morning to see if it did, and it didnt. So, answers?
 


Earl43P

Well-Known Member
U.S. Military - Veteran
Joined
Aug 7, 2007
Messages
3,158
Reaction score
37
Points
48
Location
Stafford, Va
Vehicle Year
2019
Make / Model
Ford F250 4WD
Engine Size
3.0
Transmission
Manual
Try cleaning the IAC. It controls idle.

Those idle speeds sound fine. There may be a slight vacuum leak making it idle at 1000, check the PCV tubing/elbows for cracks.
 

Mr99Ranger

New Member
Joined
Jan 20, 2010
Messages
240
Reaction score
2
Points
0
Location
West Virginia
Vehicle Year
1991
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
Checked it out, its all good. Guess replaced pcv and hose less than 500 miles ago. Guess i'll deal with it as I found it is, in fact, 950, not 1000. But what about the stalling when cold and dropped into gear. That used to happen on my carbed vehicles, but never on the truck.
 

ForOffRoadDriving

New Member
Joined
Aug 10, 2007
Messages
2,715
Reaction score
17
Points
0
Location
HIGHLAND, MICHIGAN
Vehicle Year
1994
Make / Model
FORD
Engine Size
3.0L
Transmission
Manual
my 94 will try to stall on me if i try to take off right after i first start it up, but i believe its because it is still in 'choke' mode, adding extra fuel to warm it up and when i give it gas and let out the clutch it wants to bog/ stall on me from over fueling. if it does stall i have to hold the pedal to the floor to shut off the injectors and then it will fire back up and run fine once i let it finish its warm up ritual.
 

Sponsored Ad


Sponsored Ad

Top