• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Fuel Air sensor amongst other things.

martin

New Member
Joined
Aug 6, 2007
Messages
3,219
Reaction score
23
Points
0
Age
75
Location
St Bruno, Quebec
Vehicle Year
1984
1991
Make / Model
ford
Transmission
Manual
It sounds like the pump is not running when the key is in the run position.
 


Rock Auto 5% Discount Code: BD8D9A3814E19D Expires July 5th, 2022

modelageek

Active Member
Joined
Jan 31, 2009
Messages
2,241
Reaction score
14
Points
38
Location
Boston, MA
Vehicle Year
2004
Make / Model
Ford
Engine Type
4.0 V6
Engine Size
4.0
Transmission
Automatic
2WD / 4WD
4WD
if your having this issue without any CEL. I would suspect fuel pressure. pull the vacuum line of the fuel pressure regulator and check that there is NO fuel in it. if that is ok i would do a fuel pressure test..............you put the fuel filter in the correct direction right?............
 

McFuzzie

Member
Joined
Feb 25, 2010
Messages
34
Reaction score
0
Points
6
Location
Vancouver, WA
Vehicle Year
1991
Make / Model
Ford
Engine Size
4.0 L V6
Transmission
Manual
if your having this issue without any CEL. I would suspect fuel pressure. pull the vacuum line of the fuel pressure regulator and check that there is NO fuel in it. if that is ok i would do a fuel pressure test..............you put the fuel filter in the correct direction right?............
Ok, I'll try that.

Yes, I put the fuel filter in the right way.
 

McFuzzie

Member
Joined
Feb 25, 2010
Messages
34
Reaction score
0
Points
6
Location
Vancouver, WA
Vehicle Year
1991
Make / Model
Ford
Engine Size
4.0 L V6
Transmission
Manual
It sounds like the pump is not running when the key is in the run position.
It is, I can hear it. Plus I replaced it less than a year ago.
 

Sponsored Ad


Sponsored Ad

Top