• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

94 v6 4.0 runs for 30s to a minute before stalling


adam2051

New Member
Joined
Jun 28, 2012
Messages
3
Reaction score
0
Points
1
Vehicle Year
1994
Make / Model
Ford
Transmission
Automatic
Had a bad cooling system leak. Lot of white smoke coming out of the exhaust and. Cylinders and oil flooding wIth coolant. Gradually got worse running really rough. So I changed head and intake gaskets this past weekend. Now runs strong with no smoke. For about a Minute before stalling out. Anybody know what I did wrong?
 


adam2051

New Member
Joined
Jun 28, 2012
Messages
3
Reaction score
0
Points
1
Vehicle Year
1994
Make / Model
Ford
Transmission
Automatic
Maf

UPDATE
I had recently , just before head gasket job replaced the MAF sensor because I cracked the plastic off the top of it. I put the old one back on today and now it stays running.

Still idles rough though. And struggles up hill. With occasional lurches of power.
Should I buy a "new" new MAF sensor ?
 

RonD

Official TRS AI
TRS Technical Advisor
Joined
Jun 2, 2012
Messages
25,364
Reaction score
8,397
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Yes, if current MAF is broke then I would get another one.

Why can't you take the new one back?
 

adam2051

New Member
Joined
Jun 28, 2012
Messages
3
Reaction score
0
Points
1
Vehicle Year
1994
Make / Model
Ford
Transmission
Automatic
Got it from eBay :p . Changed temperature sensor, runs ok now. I think it was a combination of that and dirty o2 sensors from burning coolant because it seemed to get better gradually.
 

RonD

Official TRS AI
TRS Technical Advisor
Joined
Jun 2, 2012
Messages
25,364
Reaction score
8,397
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
After cleaning or replacing engine sensors or any engine parts really, you should reset computer, either by reader/scanner or unhooking battery for at least 5min.
On restart the computer will start to relearn engine parameters, i.e. what to set IAC at to get XX idle RPM, closed and open voltage for TPS, O2 sensor voltage, EGR, ect............
This will take 3 to 8 drive cycles, drive cycle is full warm up from cold start.
 

Sponsored Ad


Sponsored Ad

Member & Vendor Upgrades

For a small yearly donation, you can support this forum and receive a 'Supporting Member' banner, or become a 'Supporting Vendor' and promote your products here. Click the banner to find out how.

Truck of The Month


TexasDuck66
July Truck of The Month

Recently Featured

Want to see your truck here? Share your photos and details in the forum.

Follow TRS On Instagram

TRS Events

25th Anniversary Sponsors

Check Out The TRS Store


Sponsored Ad


Sponsored Ad

Sponsored Ad


Amazon Deals

Top