• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

SOHC problem


MSGia

Active Member
Supporting Member
Joined
Dec 21, 2021
Messages
165
Reaction score
127
Points
43
Location
Central Florida
Vehicle Year
2010
Make / Model
Ford Ranger
Engine Type
4.0 V6
Engine Size
4.0L
Transmission
Automatic
2WD / 4WD
2WD
Total Drop
4, 5
Tire Size
235,55,17
Good evening all, I have been noticing some concerning things with my ranger. On startup (cold or warm) it has a really bad creaking and ticking sound. It kinda fades off after I start driving, but when I am in high RPMs, the engine sounds extremely muffled and just horrible. Any tips on what it could be? I haven’t really seriously looked into it yet,
 


MSGia

Active Member
Supporting Member
Joined
Dec 21, 2021
Messages
165
Reaction score
127
Points
43
Location
Central Florida
Vehicle Year
2010
Make / Model
Ford Ranger
Engine Type
4.0 V6
Engine Size
4.0L
Transmission
Automatic
2WD / 4WD
2WD
Total Drop
4, 5
Tire Size
235,55,17
And also it shakes hard, harder than normal, when I turn the car off.
 

funguy26

Member
Joined
Feb 24, 2020
Messages
71
Reaction score
11
Points
8
Location
Dilkon,az
Vehicle Year
2001
Make / Model
Ford Ranger XLT
Engine Type
4.0 V6
Transmission
Manual
2WD / 4WD
4WD
Tire Size
245/75R16
could be timing chain issues you can remove the driver side valve cover, or drop your oil pan. my set was done for everything was broken.
 

RonD

Official TRS AI
TRS Technical Advisor
Joined
Jun 2, 2012
Messages
25,364
Reaction score
8,391
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Check the fan clutch, reads like it broken/out of balance
 

MSGia

Active Member
Supporting Member
Joined
Dec 21, 2021
Messages
165
Reaction score
127
Points
43
Location
Central Florida
Vehicle Year
2010
Make / Model
Ford Ranger
Engine Type
4.0 V6
Engine Size
4.0L
Transmission
Automatic
2WD / 4WD
2WD
Total Drop
4, 5
Tire Size
235,55,17
Thanks for the replies all, I posted this on Sunday and I found out since then on a mechanic forum on Reddit. At the time there was no CEL, and I kept driving it and a few days later the noise kept getting worse, and I got code P0420, I think it’s because some of the honeycomb in the cat got loose or a leak, it smells like crap and the rattle. But I’ll definitely look into the fan clutch because I don’t know if that would explain the rough turn-off.
 

Sponsored Ad


Sponsored Ad

Staff online

Member & Vendor Upgrades

For a small yearly donation, you can support this forum and receive a 'Supporting Member' banner, or become a 'Supporting Vendor' and promote your products here. Click the banner to find out how.

Truck of The Month


XLTsplash
June Truck of The Month

Recently Featured

Want to see your truck here? Share your photos and details in the forum.

Follow TRS On Instagram

TRS Events

25th Anniversary Sponsors

Check Out The TRS Store


Sponsored Ad


Sponsored Ad

Sponsored Ad


Amazon Deals

Top