• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Cranks but sometimes doesn’t start


FillMarr

Member
Joined
May 16, 2016
Messages
50
Reaction score
1
Points
8
Vehicle Year
2007
Make / Model
Ford ranger xlt
Engine Type
4.0 V6
Transmission
Automatic
2WD / 4WD
4WD
Tire Size
255/70/16
Hey all,

I just did the fuel filter, I have a 2007 ranger 4x4 XLT with 180k on it. Recently sometimes (not always) I have trouble starting it. When I turn the key, it’ll crank always but sometimes “gets caught” or something and it stops cranking. Usually when I turn the key off and try again it will start right up as normal on a second try. Today it took theee tries, which makes me think it’s getting worse.
Any ideas? I’ve read the CEL would indicate bad coils. I would a imagine a bad starter wouldn’t crank at all.

I suppose my first step would be to pull a spark plug and see how bad /dirty it is?

Thanks
Phil
 


Rock Auto 5% Discount Code: 7FA902352B4C01: April 5th, 2021

rusty ol ranger

2.9L Mafia-Don
Supporting Member
Joined
Sep 22, 2007
Messages
7,841
Reaction score
2,567
Points
113
Location
Michigan
Vehicle Year
1987
Make / Model
Ford
Engine Type
2.9 V6
Engine Size
177 CID
Transmission
Manual
2WD / 4WD
2WD
My credo
A legend to the old man, a hero to the child...
Either the starter, weak battery, bad connection or the solenoid.
 

FillMarr

Member
Joined
May 16, 2016
Messages
50
Reaction score
1
Points
8
Vehicle Year
2007
Make / Model
Ford ranger xlt
Engine Type
4.0 V6
Transmission
Automatic
2WD / 4WD
4WD
Tire Size
255/70/16
Thank you. I will look into all 4 possibilities and update.
 

FillMarr

Member
Joined
May 16, 2016
Messages
50
Reaction score
1
Points
8
Vehicle Year
2007
Make / Model
Ford ranger xlt
Engine Type
4.0 V6
Transmission
Automatic
2WD / 4WD
4WD
Tire Size
255/70/16
Update: Battery has 12.6 volts, solenoid seems fine (it always cranks)...

My brother let me borrow his more sophisticated scan tool. I have the following error codes. I suppose this cries "take me to the dealer" or..... "do nothing, I'm just old!"


P1260 - "Theft detected, vehicle immobilized" possible cause: Antitheft system has failed. Possible fixes:
- replace instrument cluster,
- preform parameter reset procedure w/U2510
- replace instrument cluster module

U2510 - "Invalid or missing data for vehicle security". possible fixes:
- perform parameter reset procedure w/p1260
- repair Engine control module case ground w/U0100
- replace ignition keys w/U0100
- replace powertrain control module (PCM)
- perform PCM programming with P1260, U1900
- repaire PCM wiring w/U0100

B1602 - possible fixes:
- replace ignition keys

B1352 - ignition key in circuit fault. possible fixes:
- perform battery disconnect/reconnect w/ U1041, U1242
- repair read door jam wiring (**I did replace the rear passenger side door locking mechanism at the bottom of the door. I just plugged the new part in. Was I supposed to do something else?**)
 
Last edited:


Top