• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

misfire


  1. 2.3L ('83-'97) Intermittent Misfire

    I have 1991 Ford Ranger XLT 2.3L. 5-speed manual. I bought it for $1,000 and it seemed fine on the ride home, which was about a two hour drive. Then when I was a few miles from home, it’s like the engine lost all of it’s power and when I accelerated it was very difficult to get up to speed. It...
  2. misfire at/around 3000 rpm

    I posed this on a different ranger forum, fixed some other issues based on the replies(Thx, RonD) but not the main issue, so perhaps I can get some fresh eyes on the problem It is a misfire or intermittent lack of fire around 3000 rpm. The tach drops when it happens. I have replaced Coil, Fuel...
  3. 2008 ranger 2.3 misfiring

    Hello everyone I have a 2008 ranger 2.3 that has a misfire. I notice that it happens more often that other Times. Every time I stay at a constant speed it let me speed up and I would have to let go of the gas pedal until it down shifts to another gear. I’ve replaced air filter, fuel filter...
  4. 99 2.5L, rough idol and misfiring during acceleration and driving

    This problem has been around since I bought my Ranger, but it also comes and goes, so I always end up forgetting about it but now it seems like it’s back and is going to stay. When it first started misfiring, I replaced the MAF sensor, air filter, plugs and plug wires, and it ran perfectly...
  5. Ford 2.9 Weird unexplained issue

    Hello ranger station i recently bought a 1988 bronco ii 2.9 5 speed that had been running like crap, My issue is when warm my truck idle surges at around 400-550 sometimes if i give it throttle it will go back to 900. (this sucks when driving in town and stop and go traffic on hills) it feels...
  6. 3.0 Banks 1 and 2 too lean

    Hello, I recently purchased a 99 Ranger 3.0 Flex Fuel with about 184,000 miles. When I purchased it it had a fairly bad misfire on cylinder, it was noticeable at idle and driving. I have since replace the plugs and wires, ignition coil and the injector on cylinder 3, all helped a little and the...
  7. 3.0 barely runs

    ive got a 93 ranger with a 3.0. it will start up easy but then starts to miss out. ive replaced the distributor with a good used one, cap/ rotor, wires and plugs with no change. all 6 injectors good used, nothing. the head and intake gaskets are new so no vac leaks. good known ground to the...
  8. Severe Misfire Under Load and Intermittent Misfire at Idle

    Hello all. It's been a long time since I've posted. I sold my old 86 BII several years ago to a forum member here but I've, in the past year, bought another 86 AND an 89. My issue is with the 86. Base model, manual everything. TK5 transmission with 3.73 limited slip rear. Running...
  9. 96 2.3 2wd 5 speed timing or misfire

    Awhile back I was coming home and lost power and seemed to be misfiring and blowing gas from the pipe. It threw a p0340 code. It was out of time. Put new timing belt on and got back in time. Still wont hold an idle, hard to start, runs rough and shakes like a beast. Changed the cam sensor...
  10. truck missing after new alternator

    recently after a fishing trip my 89 ford ranger 2.3l would not start battery was dead. si u out my boat battery in it and used it to start the truck and i kept the boat battery in it untill i got home. when i got home i pulled the pos. cable off the battery and the truck died so i figured it was...
  11. Dprocks100

    Idle issue - About ready to sell this old girl

    This whole problem started 3 weeks ago. I started my truck and let it idle for about 5 minuets and took off down the road. About 1-2 min later when I went to put the clutch in, it stalled as it went down to idle. Tried 4-5 times to start it, and it ran like normal. Drove it another 1-2 min and...
  12. Intermittent misfires rough idle and acceleration

    I have a 2000 Ford Ranger 4.0 Extended Cab 4x4 off-road. About three weeks ago, the engine light came on so I stopped by AutoZone to pull the codes. It was a misfire on bank 6. So, I changed out the plug and all was fine... for a few weeks. Then, the rough running came back and engine light...
  13. Joined from SE Florida

    I've been using the information from the forum for some time now to troubleshoot my 1998 Ranger XLT 4.0L that I'm selling after 9 years and my new acquisition 2007 Ranger Sport 3.0L. I have found some very useful information and troubleshooting methods. I decided to join to post some of my...
  14. Acceleration/power issues. Timing? Misfire? Help..

    Recently bought a 94 ranger xl 4x4 v6 3.0 manual. When I accelerate it feels like it's just not getting all the power to the wheels..bogs going up hills, and acceleration isn't consistent. Rpms move smoothly, but acceleration slows and speeds up and so on, as if I was feathering the gas...
  15. 5.0 Engine misfire but no codes

    I have a 97 ford explorer 5.0 V8 in a 2000 ranger. The complete wiring harness from the 4 door explorer is in this vehicle. This is my second 5.0 that has been in this vehicle. I have now been having problems with the engine misfiring, with no misfire cylinder codes. Doing 55 down the road it...
  16. Misfire 2.9

    I have a 1988 bronco 2 and it is running really weird, it idles not to bad in park but there is still a misfire but as soon as I put it into drive it bogs down doesn't like to go it sputters when I press on the gas and if I stop at a stop sign or street light it dies. I took it to a shop and...
  17. 99 2.5L RUNNING HORRIBLY no CEL

    New member to this site but I've been using it since I was 15. Finally got smart and became a member...11 Rangers later. I just picked up a 99 Ranger XLT 2.5L auto 2wd with 158k miles. Bought it running REALLY ROUGH and drove it over an hour back home. Seems like it's running on 2 cyl's. Can't...
  18. 1998 Ford ranger bucking issue please help

    I have a 1998 ford ranger xlt with the 3.0 and its 2wd with 185,000 miles on it. For the past 2 months its been bucking while I drive and its lost performance and sounds like i have a misfire. It only bucks when i accelerate or when i stay at a constant speed over 40. I have checked for low...
  19. theGreatDane

    4.0 engine problems

    my 1999 ranger has the 4.0 liter v6 and 4 wheel drive. my truck has presented the cylinder 6 misfire code twice in the last 6 months, which I have fixed with a new spark plug in that cylinder. The other day, however, it started stuttering heavily under load, and all of the sudden had very little...
  20. theGreatDane

    Engine Problems, HELP!!!!

    my 1999 ranger has the 4.0 liter v6 and 4 wheel drive. my truck has presented the cylinder 6 misfire code twice in the last 6 months, which I have fixed with a new spark plug in that cylinder. yesterday, however, it started stuttering heavily under load, and all of the sudden had very little...


Top