• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

ignition

  1. Intermittent loss of power or stalling

    So i've been chasing an eletrical problem for a couple months, and i've about lost it. to preface, I have an 89 Ranger, 2.3 manual DIS. Somewhere around 260,000 miles, original engine and transmission. Starting around three months ago, my tach quit working. Not a big deal, i've driven the...
  2. neggen32

    Starting Issues after 4.0 Swap!

    I posted a while ago about issues I was having with my '88 Ranger, in which the previous owner swapped a 4.0 from a 92' Explorer into. Apparently all the issues stemmed from him using the original 2.9 harness for the computer and some of the sensors, and splicing everything into the 4.0. I don't...
  3. 2004 Ford Ranger Won't Start

    I was driving my truck with the windows down. I parked and cut the engine. I realized I hadn't rolled my windows up. I got to turn on my accessories, to roll the windows up. Nothing happens. I go to start the truck and the ignition lock is totally slack. There is no resistance. I turned the key...
  4. '86 Carbed w/ HEI Ignition/Power issues

    Okay so here is the story about a demon truck that has been altered so far from stock that I have absolutely no idea where to start. My main issue: Random periods of NO power. Nothing to any gauges/lights/radio, nothing to starter, won't crank, nothing. My most recent experience was driving...
  5. No spark at distributor

    I have just bought my second bronco 2 with a 2.9 liter v6 the guy has replaced the old 2.9 with a new one and he has tried to get spark but there is none so after buying it and getting it in my shop I have started to look after that problem and I have had to replace the starter scyloniod to get...
  6. No star, no click problem

    Hello all, I am at the end of my rope on this and looking for help. I have a 1994 ranger 2.3 2wd that has a no start, no click. I have replaced the solenoid, ignition switch, and the clutch position switch. The only thing I know is left is the ignition lock cylinder. Is it possible this could be...
  7. Accel Coil pack in 2001 Ranger

    Went to put in accel coil pack in my 2001 ranger and low and behold I feel it didn't fit. I looked it up on line and it was stated that I got the right one. The plug wires don't "click" into place when installed. Anyone else ran into this issue before?
  8. 94 2.3l 5spd sputters, wont start

    OK, heres the story. 1994 2.3l 5spd, no AC with califoirnia emissions. It's been trowing engine codes and not firing from the primary coil. I ran the ICM test and it came back with a back crank position sensor. So I replaced the crank position censor AND the Cam position censor (California...
  9. Crank position sensor??? which one?

    so I have a '94 Ranger, 2.3l stick, California. the crank sensor has gone bad. I see that there are two choices with, and without a harness, but the sensor itself looks completely different from one another. which one am i supposed to use? I'm so confused.
  10. nesralyrrej

    Engine stumble/ clutch won't disengage fully

    So it will sit and idle fine then stumble and doesn't seem to want catch its self, if you rev it up it usually goes away, but always comes back I'm thinking idle air control valve what do you guys think? Also my clutch feels stiff but doesn't disengage fully, when I got it there was no brake...
  11. 1994 4.0l Camshaft Position Sensor - Camshaft Synchronizer

    Hello. I was hoping someone could help me. I've got a 1994 Mazda B4000. It had a terrible lower intake manifold gasket leak and I decided to perform the fix. When I went to dis-connect the "camshaft position sensor/camshaft synchronizer" connector, I broke the connection on the sensor and...
  12. Truck will not crank without assistance

    I just replaced the alternator today because it tested bad (diode). The truck will not crank without using my jump starter. I also had the battery checked out and it tested good. I seem to have a problem with my ignition not working correctly. When I put in the key sometimes it is not straight...
  13. #2 cylinder misfire...

    Hello, I drive a 1998 Ford Ranger XLT 3.0 v6, manual with 236k miles. replaced the head gasket, timing chain, and cracked timing chain cover and spark plugs 2 months ago(about 5k miles ago) Aside from my slave cylinder and clutch beginning to go bad I haven't had any problems since, until my...
  14. Ditchbanger

    Little misfire aroun 1500-1600 RPMs

    93 3.0 This has me stumped. I have fresh ignition everything. Plugs, wires, coil, distributor cap etc. It doesnt always do it but if i keep it at steady throttle around 1500-1600 RPMs it acts like it has a misfire. Any more or any less throttle and its fine. Ive sea foamed it and that worked but...
  15. No longer wants to start...suspect fuel pressure.. recommendations?

    I have a '88 B2 with the 2.9 EFI V6. It was my daily driver; I stopped driving it for a few weeks and it now refuses to start. The engine will turn over and try to catch. I put a fuel pressure gauge on the rail under the hood. I can hear a fuel pump running and the pressure holds stead at...
  16. Ignition Switch Harness

    Hey peeps, I just took the cover of the steering column, and i don't see the ignition harness. I'm tryin to install a Remote Starter. I unpluged every connector there and the truck still starts, and i don't see anymore wires, what am i missing? Can someone point me in the right direction in...
  17. Ford Duraspark II Ignition Module

    Hello folks. I just bought some doors and a fender from a man who gave me the motivation to go with the Duraspark conversion... Well I am not sure where to find the Duraspark II Ignition Module... Does anyone on here have one for sale? I would be happy to buy that and any other Duraspark parts...
  18. nktidwel

    Ignition fuse blows..

    96 2.3 manual Every single time I attempt to crank the ranger (with just the key), the ignition fuse blows, and it does not crank at all. I followed the ignition wire (red/blue) from the ignition switch. I have continuity with the bottom terminal (black/heavier wire) of the fender solenoid. I...
  19. idriveafordranger94

    Okay guys, I'm officially stumped

    This absolutely confuses the hell out of me. I am completely stumped by this. So here's the story: The '94 blue Ranger I just bought quit running, so I decided to see what was wrong. Meanwhile, I had my brother's red '94 Ranger in my garage for a new clutch. I read some of the forums and...
  20. No spark 93

    My 93 died on me driving down the road. No spark detected, installed a new coil and still no spark. I read around the forum and got info about the cam sensor and the ICM. The problem is I don't know how to test these components for failures. I have power to the coil but the other cable gives me...

Sponsored Ad


Sponsored Ad

Top