• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Little misfire aroun 1500-1600 RPMs


Ditchbanger

New Member
Joined
Sep 24, 2011
Messages
91
Reaction score
0
Points
0
Location
Maine
Vehicle Year
1993
Make / Model
Ford
Engine Size
3.0
Transmission
Manual
93 3.0 This has me stumped. I have fresh ignition everything. Plugs, wires, coil, distributor cap etc. It doesnt always do it but if i keep it at steady throttle around 1500-1600 RPMs it acts like it has a misfire. Any more or any less throttle and its fine. Ive sea foamed it and that worked but i also had it goin 75 that day (usually average 55). There is no certain time or conditions that it does the misfire. Wondering if its a distributor. Any ideas?
 


Rock Auto 5% Discount Code: 70D65189E6D8FF: January 5th, 2022

jewalker7842

New Member
Joined
Sep 28, 2011
Messages
40
Reaction score
0
Points
0
Location
Tennessee
Vehicle Year
2001
Make / Model
Ford
Engine Size
3.0
Transmission
Automatic
I'm no expert, I'm just going tho throw a suggestion your way. If it was the distributor wouldn't it be doing it randomly on all RPM's? Are you seeing your RPM's drop with the miss? Have you changed your fuel filter?
 

Ditchbanger

New Member
Joined
Sep 24, 2011
Messages
91
Reaction score
0
Points
0
Location
Maine
Vehicle Year
1993
Make / Model
Ford
Engine Size
3.0
Transmission
Manual
Re:

No, my rpms arent dropping with the miss. I can feel the lack of power and hear it from my exhaust. I put a fresh fuel filter in it 2000 miles ago. It just sat for 5 hours, i just went out and it was doing it bad. Took it for a 2 mile ride and it stopped... Theres no certain time when it will start again.
 

jewalker7842

New Member
Joined
Sep 28, 2011
Messages
40
Reaction score
0
Points
0
Location
Tennessee
Vehicle Year
2001
Make / Model
Ford
Engine Size
3.0
Transmission
Automatic
No, my rpms arent dropping with the miss. I can feel the lack of power and hear it from my exhaust. I put a fresh fuel filter in it 2000 miles ago. It just sat for 5 hours, i just went out and it was doing it bad. Took it for a 2 mile ride and it stopped... Theres no certain time when it will start again.
Have you taken a look at your EGR valve? They can cause some weird issues. My 93 Dodge RAM was having all sorts of issues at random RPM's including stalling and acting like it had a miss. I took the vacuum hose off the EGR valve and it all went away. I replaced it and problem solved. I would try cleaning it first if you haven't already and see what happens.
 


Top