Home Ford Ranger Forum Tech Articles Other Articles Featured Rangers Readers Rangers Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum  

Go Back   The Ranger Station Forums > Help Forums - Engine & Transmission Forums > 4-bangers > 4-Cylinder (2000 & Older)

Reply
 
Thread Tools Display Modes
Old 09-21-2012, 12:15 AM   #11
thomas swingruber
New Member
 
Join Date: Sep 2012
Posts: 1
Vehicle Year: 1996
Vehicle Make: ford
Vehicle Model: ranger
Rep Power: 0
thomas swingruber is on a distinguished road
Default

HI
I have written a detailed manual to trouble shoot the P1443 problem.
With lots of pictures.
I just got pissed trying to find good data.

Don't use a search engine! Just enter the address in the address bar www.tomshints.com
If you find it helpful send me an email at the address on the web page.
Enjoy
Tom

Last edited by thomas swingruber; 09-21-2012 at 12:18 AM.
thomas swingruber is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')
Old 10-19-2012, 02:24 AM   #12
bustedknuckle
New Member
 
Join Date: Sep 2009
Location: Pitsburgh
Posts: 8
Vehicle Year: 91, 98
Vehicle Make: ford
Vehicle Model: ranger
Rep Power: 0
bustedknuckle is on a distinguished road
Default

Tom, you sir are a pimp! Thank you so very much. I've been meaning to deal with this issue for awhile now, but now I have to since it's time for emissions inspections.
Thanks!
bustedknuckle is offline   Reply With Quote
Old 10-19-2012, 07:37 PM   #13
cvar
Member
 
cvar's Avatar
 
Join Date: Apr 2012
Posts: 588
Vehicle Year: 1997
Vehicle Make: Mazda
Vehicle Model: B4000
Rep Power: 17
cvar is just really nicecvar is just really nicecvar is just really nicecvar is just really nicecvar is just really nice
Default

Excellent write-up. Thanks Tom. Yeah, I have that same pesky code. CEL comes & goes every other day. I'll print this and go check my solenoid & sensor.

Cracked hoses cause it too? Hmm. This P1443 started about when I removed the gas tank and replaced brake lines, incl. beside the evap canister. Maybe I dislodged something? My canister hoses seemed ok, but I need a vacuum gauge. I suppose the gas-tank end of that hose might also crack?

How to determine if the canister itself is working? Does it ever go bad?
__________________
1997 4x4 Mazda B4000 SE, Ext.Cab
cvar is offline   Reply With Quote
Old 04-02-2013, 12:38 PM   #14
cvar
Member
 
cvar's Avatar
 
Join Date: Apr 2012
Posts: 588
Vehicle Year: 1997
Vehicle Make: Mazda
Vehicle Model: B4000
Rep Power: 17
cvar is just really nicecvar is just really nicecvar is just really nicecvar is just really nicecvar is just really nice
Default

Finally got around to opening the hood to solve this pesky p1443 code & CEL. Tom's excellent post found the problem. It was inoperative evap solenoid. So after replacing the $50 solenoid, my CEL is dark. Yay!

Thank you Tom! You da man!

Soon, I'll have to tackle the final p-code remaining: p1401 DPFE too high voltage. Cuz state emissions check is becoming due.
__________________
1997 4x4 Mazda B4000 SE, Ext.Cab
cvar is offline   Reply With Quote
Old 05-21-2013, 12:41 PM   #15
Kamel
New Member
 
Join Date: Jul 2012
Posts: 5
Vehicle Year: 1995
Vehicle Make: Ford
Vehicle Model: Ranger XLT
Rep Power: 0
Kamel is on a distinguished road
Default

I'll be honest, I thought I was going to end up at some spam site when I clicked that link lol...

I was pleasantly surprised to find one of the most well written guides for vehicle repair I've ever seen. Thanks a ton for your write up Tom, I'm certain it's helped countless other people who didn't bother to say thanks. I really appreciate it!
Kamel is offline   Reply With Quote
Reply

Bookmarks

Tags
1997, 2.3, 4 banger, check engine light, dummy light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 11:42 PM.




1999-2014 / 959 Media LLC / All Rights Reserved