Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'MastuhWaffles'
November 2014 OTOTM

Mini Truck Of The Month

'ATX'
November 2014 MTOTM
 

Go Back   The Ranger Station Forums > Engine & Transmission Forums > V6 Forums > 3.0 Liter Forum

Notices

Reply
 
Thread Tools Display Modes
Old 05-28-2011, 11:26 AM   #1
jerrygallion
New Member
 
Join Date: May 2011
Posts: 2
Vehicle Year: 2001
Vehicle Make: ford
Vehicle Model: ranger
Rep Power: 0
jerrygallion is on a distinguished road
Default 2001 ford ranger 3.0 timing off need help

just rebuilt my motor put in back in the truck won't run right got the piston to top dead center set the distuibor and it will start but back fires andt no power when u put it in gear totaly lost on this 1 thanks
jerrygallion is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Old 05-28-2011, 06:34 PM   #2
Original_Ranger84
Member
 
Original_Ranger84's Avatar
 
Join Date: Aug 2007
Location: Homer, Ak/ Anchorage, AK/Fairbanks, AK
Posts: 4,701
Vehicle Year: 1984, 1999
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Project, DD
Rep Power: 26
Original_Ranger84 is a jewel in the roughOriginal_Ranger84 is a jewel in the roughOriginal_Ranger84 is a jewel in the rough
Default

With an 01 truck there shouldn't be a distributor... it should have a camshaft syncronizer that has to go in just right. perhaps you got a wire crossed or something? It happened on my buddies chevy and we could not figure out what was wrong.
__________________
99 Ranger DD - 3.0L, 5spd, 4x4, 4 door, step side, 31's, 4x KC driving lights.
84 Ranger Project - 2.8L, 5spd, 4x4, regular cab, long bed, 3" body lift, 31's, 4x KC long ranges, Dual CD player/Blaupunkt Speakers.
Quote:
Originally Posted by Myself View Post
"Tall Trucks, Small trucks, whos got the balls to roll with our trucks?"
Original_Ranger84 is offline   Reply With Quote
Old 05-28-2011, 07:30 PM   #3
jerrygallion
New Member
 
Join Date: May 2011
Posts: 2
Vehicle Year: 2001
Vehicle Make: ford
Vehicle Model: ranger
Rep Power: 0
jerrygallion is on a distinguished road
Default

I double check the wiring and it's right I worked on it all day and still don't know got it to tdc on the piston and no matter what I do I have a backfire
jerrygallion is offline   Reply With Quote
Old 05-29-2011, 06:19 PM   #4
locovaca
Member
 
Join Date: Jan 2008
Location: DeWitt, IA
Posts: 706
Vehicle Year: 1993
Vehicle Make: Ford
Vehicle Model: Ranger XLT
Rep Power: 15
locovaca is on a distinguished road
Default

Codes? Check Engine Light? Sure you have all the sensors connected?
locovaca is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 07:01 AM.




1999-2014 / 959 Media LLC / All Rights Reserved