The Bronc's 4.0


bronc

New member
Joined
Aug 13, 2007
Messages
48
Reaction score
1
Points
0
Location
Calgary, AB
Vehicle Year
1989
Make / Model
Ford
Engine Size
4.0
Transmission
Manual
Someone had asked to see pics of the swap. I had this on the old TRS but here it is again with a bit of a writeup.

Finished the swap.
Here is the 4.0 in the ex. Pretty ugly.

Pulling the 2.9

And the rebuilt 4.0 in it's new home.


Dana 35 is in. You can see the difference in width. It aligned better than the old dana 28. Still used adjustable shims. The caster is much better. Around 3 degrees. Steering is tighter and handles better than ever.

Here is where all the wiring took place.


Here is how to swap pins. Get a couple picks like the ones shown. Pick out the red thing in the middle by picking at one of the middle 4 pins. You'll see the holes in the red thing in the pic below.

Then use a pick to press the little tab about half way down the pin towards the middle while pulling on the wire. Be easy on the tab cuz they break easy. Practice on a plug your not using. Then put the wire in the correct spot and press it back in. You hear a click. Then replace the red middle thing.

Don't buy reman lifters since all they do is clean them. If yours are in godd shape then follow this to clean em. Use a pick to pry the plastic top piece off. Comes off easy. Place the pick in the holes at the bottom of the plastic cup and pry.

My lifters were still pressured up after a month of sitting. I could not move the plunger. This means they are holding pressure and are good.
Next use your fingernails to grab the little plunger out. It should be protruding a bit to grab. Then use the pick to press down in the middle of the next plunger piece. The hole in the middle is where the check ball is. By pressing it you release the pressure. Don't look right at it while doing this or you get an eye full of oil. It can shoot out good. Then pick it out. The spring is underneath that. Clean everything with some varsol or ATF. Use a brush in the lifter if possible too.

Next once clean, coat everything in oil and put all back together. Do not fill the lifter with oil or you won't be able to move the plunger. You don't have to prime them. They prime quickly on their own. They should be able to move freely so they adjust to the correct spot on their own once running.


Some of my wiring notes:
If you need to see this better let me know I can send you my MS Word version. It has the BII wires on the left and Ex on the right. Tells you exactly what I did for my swap. Remembering I used the 4.0 engine harness only. Used the BII headlight harness (BWP Big White Plug) and the BII dash. So the problems came on the passenger side where the 4.0 engine harness meets the BII headlight harness.


Remember each swap is a little different depending on what you are using. You NEED the wiring diagrams for both vehicles. The diagrams are really easy to use once you figure out which plugs are which on the diagrams. Just trace wires to where they go and then find the partner. Most of them are color coded the same from vehicle to vehicle but they go to different plugs, so you splice. Sometimes they go to the same plug but not the same spot, they don't match up. So you swap pins. There are a few colors that changed over the years. You can find them from my word document. There is only a couple I think.

Also there is a black and light blue one that is for the temp sensor. On the BII it went throught the trans harness and up to a plug and into the dash. On the 4.0 it goes on the engine harness over to the pass side and then to a plug by the battery and the around to the drivers side and into the dash. The plug by the battery is a 4 pin plug. The BII side only has 3 wires and the 4.0 side has the extra one. Pull the pin on it and run and wire and splice it to its buddy on the drivers fender.

Yea the RORRC link isn't too great. It provides pics of the plugs and kinda get an idea of where the problems are. But they didn't post any of their solutions on there so it is kinda useless. I used the 4.0 EEC harness. Use the original BII or ranger, headlight harness (big white plug harness) unless you are swapping dashes. Then use all 4.0 stuff. So the problems (which my word document covers) are between the connections of the engine harness and the headlight harness since they are different. You will also need the 4.0 starter harness, battery cables (grounds included) along with the alternator harness. The alt. is part of the headlight harness but since the alt. is different you need to splice. There are 2 wires that do not matter and 2 that you have to splice. When you get to this step, let me know and I can get the colors for you and tell you exactly what to do.

Do not remove the headlight harness from you truck. Use the original ranger/ BII headlight harness. Use the 4.0 engine harness. Cut the wires that go to the 4.0 alt. off of the donor's headlight harness. Then cut the same wires off of your headlight harness. Splice them. I'll get the colors for you. Not sure what you mean by remove the cover off the headlight harness. Other than the alt. wires, do not touch the headlight harness.

The ideal way to do it would be to swap all in from the 4.0 (engine harness, headlight harness, dash) then all matches up and should have no problems. I however did not want to swap my dash so I did it this way.

If you do it this way using the BII headlight harness you will not have DRL's (if all ex's had them?). Your lights and whatnot will function as they did before. You do not need any of that stuff. It is way more work to swap the EX headlight harness in. If you wanted to you could put the ex's headlight harness in but then the trouble would be at the big white plug. Very little matches up and would be more work. So just leave your ranger headlight harness in. Then the splices will be between it and the ex's engine harness on the drivers fender. Basically put the engine harness in and hook everything up that you can. Leave you ranger headlight harness alone. Then follow my word document for the ones on the drivers fender. You will be able to look at the plug color (grey or black) and the color of the wires to find out which plug is which. Put a temorary piece of tape on the plug with the number of the plug on it for easy reference. Or on the grey plugs just use permanent marker to put the # on. The #'s come from a book I had. The 2 119's are both from the ex. This goes to the trans. Plug em in. The 2 117's go together. Plug the 116's together. Plug 101's together. Plug #'s 136 and 122 in the end will dissapear. They did on mine anyways.


I also rebuilt my motor (did not bore it, it was only 2.5 thou tapered). Everything else is new though. Crank was ground. I chose to use a delta cams cam since it was way cheaper than comp cams. Here's my story on them:

I ordered their rocker set, some rebuilt lifters, and a cam with the specs I gave them from the 410 comp cams cam. I got it all about 2 weeks later. Would have been shorter if they would not have screwed up the shipping. It went back to them and they had to send it again. I am in Canada too remember although the distance isn’t far since they are in Washington state. So I got my stuff and it came time to put it in the new motor. I was inspecting their stuff and found the cam had 2 back nicks in it on the bearing journals. Not only that but there were nicks all over in places that would not have matter but it looked like crap. The journals were nice however since they were ground. So I went over to see my buddy who is a machinist, threw it on the lathe and found out the nicks were 4 thou deep. Not only that but it was bent by about 4 thou. I doubt it would have even went in if I tried. So I call em up and give em hell. They say no problem that’s not how we do business. So they ground another up and sent it out ASAP. So they are good people and helped out. Got it a week later. Quicker this time. It looked a lot nicer. Don’t know how the other one got through their quality control. Pretty bad. But they got it right the 2nd time around and they do have a good warranty right on the box that they gotta hold up.

Doesn’t end there though. When I went to put lifters in, I notice a few (5) have scoring on the side where it rides in the bore and I know you aren’t supposed to use em. Also one roller doesn’t even turn. Now they don’t do these in house but still, they are the ones with their name on the box. All they likely do is disassemble and clean em. And if I would have known how to do that at the time, I wouldn’t have bought em. I do know how now though. So I decide to use 5 originals. And it is working so I guess no harm done. I didn’t have time to call em and get more of them. I wanted to get it going. I am going to take good pics of everything though and send them an email and see what they say. I didn’t send the 1st cam back, they said it didn’t matter so the 2nd one was at no cost at all to me. But they said if I do send stuff back for a core charge, they would like it back to see it. I was disappointed in the lifters thought too and caused some headaches. But I figured it out in the end. So don’t buy rebuilt lifters if yours turn freely and the lifter sides are in good shape and they hold pressure. They are easy to disassemble and clean out. So there is my story about them. They were helpful but did screw up. So just be careful. I wouldn’t say to not do business through em but I am just sharing my story.

Also their rocker set was nice. No problems there. Hardened tips looked good. I used smith brothers pushrods about 5.530” long I think it was. Delta cams adds 40 thou to the rocker arms so I didn’t have to go the full 5.550 everyone usually does. I figure it gave me about 40 thou preload.

Another thing I learnt is when you get new parts, even if your not going to use them for a while, inspect them thoroughly right away incase you do have problems.
 


Rock Auto 5% Discount Code: 248EE46702D889 Expires: October 1, 2019

bronc

New member
Joined
Aug 13, 2007
Messages
48
Reaction score
1
Points
0
Location
Calgary, AB
Vehicle Year
1989
Make / Model
Ford
Engine Size
4.0
Transmission
Manual
I also want to add that it now drives better, straighter than ever before. I think the alignment is better, caster better. It has WAY more power than the 2.9. The 4.0 runs great. It is a blast to drive now. Anyone thinking about this swap, do it! Stop thinking about it. It doesn't take too long to do. This is the first time I had tackled anything nearly this big. Well worth it.

It now comfortably goes down the highway at 110 km/hr. Even in the wind. Could never do that with the 2.9.
 

albertabronco

New member
Joined
Aug 16, 2007
Messages
40
Reaction score
0
Points
0
Location
Red Deer, Alberta, Canada
Vehicle Year
1987
Make / Model
Ford
Transmission
Automatic
hey buddy care to help a bro out when i do my swap do a long weekend party beerfest motor swap? i would appreciate the experience let me know im in red deer alberta
 

Will

Forum Staff Member
Forum Moderator
Joined
Nov 30, 2001
Messages
6,596
Reaction score
83
Points
48
Location
Gnaw Bone, Indiana
Vehicle Year
2007
Make / Model
Toyota
Engine Size
4.0
Transmission
Manual
Eh, that's a few weekends. You'll make a better friend by doing everything you can yourself and only asking help when you really need it. I've been on the helping end of an engine swap and basically lost a friend over it.

Looks great bronc. Pretty engine too. Yep, I love the 4.0 compared to the 2.9. Holds cruise on any hill, gets a trailer moving with ease and makes a 5-speed nearly as good as an auto when creeping up things.
 

351ranger

Member
Joined
Aug 6, 2007
Messages
231
Reaction score
0
Points
16
Location
Casco, MI
Vehicle Year
2000 ranger 2.5
Transmission
Automatic
I just got my b2 back from wiring up the 4.0 and I'm amazed by the power difference! Looks good dude. Like he said the swap is definitly worth it!
 

Ozwynn

Well-known member
Joined
Aug 6, 2007
Messages
6,395
Reaction score
76
Points
48
Age
42
Location
Enumclaw WA
Vehicle Year
2014, 1984,1990
Make / Model
Dodge, Honda, F
Engine Size
2.4L, 1100cc, 5.0l
Transmission
Manual
My credo
If you can't go through it or around it, then go over it.
Very informative....... almost makes me want to trade my LandCruiser for a B2
 

CopyKat

New member
Joined
Aug 18, 2007
Messages
2,274
Reaction score
6
Points
0
Location
Manitoba, Coldest place in Canada
Vehicle Year
1987
Make / Model
Ford
Engine Size
4.0L
Transmission
Manual
Did one on mine too. It's time for a rebuild on the upper end though. Good info on cleaning the lifters. Can you really feel a difference with the 410 cam? I've been thinking about going the 422 cam with the 95 heads I have. BTW how much did the cam and push rods cost you with shipping? Cdn funds that is, as I'm in Canada too.
 

bronc

New member
Joined
Aug 13, 2007
Messages
48
Reaction score
1
Points
0
Location
Calgary, AB
Vehicle Year
1989
Make / Model
Ford
Engine Size
4.0
Transmission
Manual
Well it is the 410 cam specs but made by delta cams as I said. If you can fork out the money for the delta cams, I'd say go with them because of the hassle I went through. As for feeling a difference, I can't tell since I went from a 2.9 to a 4.0. Did not drive the healthy 4.0 before the cam. I can only compare it to my dad's 2wd 92 ranger and thats not much to compare to since it is way lighter. I'd say if anything maybe only 10 horsepower or so. An amount barely noticable. What I wanted it for is the low end torque and it is really good. You realize you need a bunch of other stuff for the 422 cam right? Not sure exactly but it is more work and more $$. The 410 you just put in and get some longer pushrods. My rods were 5.530" I believe, 55 thou longer than stock. I used smith brothers pushrods and they make a very high quality pushrod. I recommend the delta cams rockers though. They rebuild them with hardened tips. Do that along with new pushrods and will likely fix your problem. Do the cam if you want but then you gotta worry about the correct size pushrods.

Cam was like 110 American, rockers were 180. So 290 american plus 30 shipping. Woulda been around 350 canadian. Pushrods from smith bros were 73 bucks 20 to ship. So woulda been around 110 canadian or so maybe.
 

pjksr1955

New member
Joined
Mar 5, 2009
Messages
2
Reaction score
0
Points
0
Vehicle Year
1990
Make / Model
bronco 11
Transmission
Manual
Bronco 11 4.0 engine swap

Bronc, What a great article and job you did on the engine swap. I have a 1990 Bronco 11 and have put the engine in but need your help on the electrical part. The engine and wiring harness is from a 1993 explorer with an auto trans. My Bronco has a manual trans. Would I need a wiring harness from a auto trans. Can you e-mail me your MS WORD VERSION and any sugestions that might help to pjksr1955@yahoo.com again, what a great job you did. Pete
Someone had asked to see pics of the swap. I had this on the old TRS but here it is again with a bit of a writeup.

Finished the swap.
Here is the 4.0 in the ex. Pretty ugly.

Pulling the 2.9

And the rebuilt 4.0 in it's new home.


Dana 35 is in. You can see the difference in width. It aligned better than the old dana 28. Still used adjustable shims. The caster is much better. Around 3 degrees. Steering is tighter and handles better than ever.

Here is where all the wiring took place.


Here is how to swap pins. Get a couple picks like the ones shown. Pick out the red thing in the middle by picking at one of the middle 4 pins. You'll see the holes in the red thing in the pic below.

Then use a pick to press the little tab about half way down the pin towards the middle while pulling on the wire. Be easy on the tab cuz they break easy. Practice on a plug your not using. Then put the wire in the correct spot and press it back in. You hear a click. Then replace the red middle thing.

Don't buy reman lifters since all they do is clean them. If yours are in godd shape then follow this to clean em. Use a pick to pry the plastic top piece off. Comes off easy. Place the pick in the holes at the bottom of the plastic cup and pry.

My lifters were still pressured up after a month of sitting. I could not move the plunger. This means they are holding pressure and are good.
Next use your fingernails to grab the little plunger out. It should be protruding a bit to grab. Then use the pick to press down in the middle of the next plunger piece. The hole in the middle is where the check ball is. By pressing it you release the pressure. Don't look right at it while doing this or you get an eye full of oil. It can shoot out good. Then pick it out. The spring is underneath that. Clean everything with some varsol or ATF. Use a brush in the lifter if possible too.

Next once clean, coat everything in oil and put all back together. Do not fill the lifter with oil or you won't be able to move the plunger. You don't have to prime them. They prime quickly on their own. They should be able to move freely so they adjust to the correct spot on their own once running.


Some of my wiring notes:
If you need to see this better let me know I can send you my MS Word version. It has the BII wires on the left and Ex on the right. Tells you exactly what I did for my swap. Remembering I used the 4.0 engine harness only. Used the BII headlight harness (BWP Big White Plug) and the BII dash. So the problems came on the passenger side where the 4.0 engine harness meets the BII headlight harness.


Remember each swap is a little different depending on what you are using. You NEED the wiring diagrams for both vehicles. The diagrams are really easy to use once you figure out which plugs are which on the diagrams. Just trace wires to where they go and then find the partner. Most of them are color coded the same from vehicle to vehicle but they go to different plugs, so you splice. Sometimes they go to the same plug but not the same spot, they don't match up. So you swap pins. There are a few colors that changed over the years. You can find them from my word document. There is only a couple I think.

Also there is a black and light blue one that is for the temp sensor. On the BII it went throught the trans harness and up to a plug and into the dash. On the 4.0 it goes on the engine harness over to the pass side and then to a plug by the battery and the around to the drivers side and into the dash. The plug by the battery is a 4 pin plug. The BII side only has 3 wires and the 4.0 side has the extra one. Pull the pin on it and run and wire and splice it to its buddy on the drivers fender.

Yea the RORRC link isn't too great. It provides pics of the plugs and kinda get an idea of where the problems are. But they didn't post any of their solutions on there so it is kinda useless. I used the 4.0 EEC harness. Use the original BII or ranger, headlight harness (big white plug harness) unless you are swapping dashes. Then use all 4.0 stuff. So the problems (which my word document covers) are between the connections of the engine harness and the headlight harness since they are different. You will also need the 4.0 starter harness, battery cables (grounds included) along with the alternator harness. The alt. is part of the headlight harness but since the alt. is different you need to splice. There are 2 wires that do not matter and 2 that you have to splice. When you get to this step, let me know and I can get the colors for you and tell you exactly what to do.

Do not remove the headlight harness from you truck. Use the original ranger/ BII headlight harness. Use the 4.0 engine harness. Cut the wires that go to the 4.0 alt. off of the donor's headlight harness. Then cut the same wires off of your headlight harness. Splice them. I'll get the colors for you. Not sure what you mean by remove the cover off the headlight harness. Other than the alt. wires, do not touch the headlight harness.

The ideal way to do it would be to swap all in from the 4.0 (engine harness, headlight harness, dash) then all matches up and should have no problems. I however did not want to swap my dash so I did it this way.

If you do it this way using the BII headlight harness you will not have DRL's (if all ex's had them?). Your lights and whatnot will function as they did before. You do not need any of that stuff. It is way more work to swap the EX headlight harness in. If you wanted to you could put the ex's headlight harness in but then the trouble would be at the big white plug. Very little matches up and would be more work. So just leave your ranger headlight harness in. Then the splices will be between it and the ex's engine harness on the drivers fender. Basically put the engine harness in and hook everything up that you can. Leave you ranger headlight harness alone. Then follow my word document for the ones on the drivers fender. You will be able to look at the plug color (grey or black) and the color of the wires to find out which plug is which. Put a temorary piece of tape on the plug with the number of the plug on it for easy reference. Or on the grey plugs just use permanent marker to put the # on. The #'s come from a book I had. The 2 119's are both from the ex. This goes to the trans. Plug em in. The 2 117's go together. Plug the 116's together. Plug 101's together. Plug #'s 136 and 122 in the end will dissapear. They did on mine anyways.


I also rebuilt my motor (did not bore it, it was only 2.5 thou tapered). Everything else is new though. Crank was ground. I chose to use a delta cams cam since it was way cheaper than comp cams. Here's my story on them:

I ordered their rocker set, some rebuilt lifters, and a cam with the specs I gave them from the 410 comp cams cam. I got it all about 2 weeks later. Would have been shorter if they would not have screwed up the shipping. It went back to them and they had to send it again. I am in Canada too remember although the distance isn’t far since they are in Washington state. So I got my stuff and it came time to put it in the new motor. I was inspecting their stuff and found the cam had 2 back nicks in it on the bearing journals. Not only that but there were nicks all over in places that would not have matter but it looked like crap. The journals were nice however since they were ground. So I went over to see my buddy who is a machinist, threw it on the lathe and found out the nicks were 4 thou deep. Not only that but it was bent by about 4 thou. I doubt it would have even went in if I tried. So I call em up and give em hell. They say no problem that’s not how we do business. So they ground another up and sent it out ASAP. So they are good people and helped out. Got it a week later. Quicker this time. It looked a lot nicer. Don’t know how the other one got through their quality control. Pretty bad. But they got it right the 2nd time around and they do have a good warranty right on the box that they gotta hold up.

Doesn’t end there though. When I went to put lifters in, I notice a few (5) have scoring on the side where it rides in the bore and I know you aren’t supposed to use em. Also one roller doesn’t even turn. Now they don’t do these in house but still, they are the ones with their name on the box. All they likely do is disassemble and clean em. And if I would have known how to do that at the time, I wouldn’t have bought em. I do know how now though. So I decide to use 5 originals. And it is working so I guess no harm done. I didn’t have time to call em and get more of them. I wanted to get it going. I am going to take good pics of everything though and send them an email and see what they say. I didn’t send the 1st cam back, they said it didn’t matter so the 2nd one was at no cost at all to me. But they said if I do send stuff back for a core charge, they would like it back to see it. I was disappointed in the lifters thought too and caused some headaches. But I figured it out in the end. So don’t buy rebuilt lifters if yours turn freely and the lifter sides are in good shape and they hold pressure. They are easy to disassemble and clean out. So there is my story about them. They were helpful but did screw up. So just be careful. I wouldn’t say to not do business through em but I am just sharing my story.

Also their rocker set was nice. No problems there. Hardened tips looked good. I used smith brothers pushrods about 5.530” long I think it was. Delta cams adds 40 thou to the rocker arms so I didn’t have to go the full 5.550 everyone usually does. I figure it gave me about 40 thou preload.

Another thing I learnt is when you get new parts, even if your not going to use them for a while, inspect them thoroughly right away incase you do have problems.
 

akagomer

New member
Joined
Sep 19, 2010
Messages
5
Reaction score
0
Points
0
Vehicle Year
1989
Make / Model
Ford
Transmission
Automatic
Making the swap

I'm in the process of making the 2.9 to 4.0 swap. Have a 1989 Bronco II 4X4, auto. And the donor vehicle is a 1993 Explorer 2X4, 4.0, auto.
So far everything has gone ok. Have the motor sitting in place. And didn't have to drill motormount holes.
Have changed the computer and passenger side wiring harness. And left the driverside in place.
Am in the process of putting the 89's automatic transmission and transfer case up to the 4.0.
Think I might need a copy of what you figured out in the wiring harness. Would you please send me a copy ? dapatt2002@yahoo.com.
Am already getting excited about getting this thing back on the road. Have always loved driving it. Even though I don't do much 4 wheeling.
 
Last edited:

akagomer

New member
Joined
Sep 19, 2010
Messages
5
Reaction score
0
Points
0
Vehicle Year
1989
Make / Model
Ford
Transmission
Automatic
2.9 to 4.0 swap

I'm swaping from a 2.9 , 89 Bronco II to a 93 4.0 Explorer... Need to know if I should be swapping out the wiring harness from the drivers side also.
The Explorer wiring for the doors goes from the front of the fender wells back to the door. While the Bronco door wires come from under the dash.
But I'm having problems mateing the wiring harneses.
I have fuel pump, and am able to crank the motor over, but it is not firing. Not sure where it all went wrong... HELP !!!
 


Top