• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Fuel Delivery Issues


Madracingalley

New Member
TRS Banner 2010-2011
Joined
Apr 14, 2008
Messages
284
Reaction score
0
Points
0
Age
33
Location
Gansevoort, NY
Vehicle Year
2000
Make / Model
Volvo....
Engine Size
2.4L T5
Transmission
Automatic
Ok so a few days ago the Ranger started Dogging and Bucking. And I figured It would have been another Vaccuum leak. But, sadly after hooking up the smoke machine at school. Nothing...... So In my own Rage.... I brought the MODIS out and connected it to the DLC and out pops a 553 and 556 OBD-I codes along with the usual O2 Sensor codes (that don't effect anything) but I have been chasing these wires around looking for a short and cant find out where the 22 pin is on the ecm? If anyone could show me, that would help me alot.

I posted this under the misc. electrical but It got no responce and that seemed like headlight and interior light stuff so,
It is a engine driveablility issue so I figured It ask here.

Thank you.

1994 4.0L Std. RWD
 


BRUTUS_T_HOG

New Member
Article Contributor
ASE Certified Tech
TRS Banner 2010-2011
Joined
Aug 26, 2008
Messages
2,222
Reaction score
36
Points
0
Location
Rainier, OR
Vehicle Year
89
Make / Model
Ford
Engine Size
2.3L
Transmission
Manual
if you look very closely on the back of the ECM plug, there is a number 1 at one corner. count 22 and thats the pin. what problem are you having exactly and what have you done to test it.

sounds like you are going to school to be a mechanic? you should have enough equipment to diagnose this.
 

Madracingalley

New Member
TRS Banner 2010-2011
Joined
Apr 14, 2008
Messages
284
Reaction score
0
Points
0
Age
33
Location
Gansevoort, NY
Vehicle Year
2000
Make / Model
Volvo....
Engine Size
2.4L T5
Transmission
Automatic
Yes I am in an Auto Technology Program at my local Vocational School. Cars are my life.

Every once in a blue moon It won't start. Untill I move The Pile of wires connected to the ECM.

Now It has gotten worse and started losing power, Bucking, Missing at idle, and running rough.

Tonight, I went through and disconnected the ECM and cleaned the connector, and now it does run better, but I will look at it further later
 

BRUTUS_T_HOG

New Member
Article Contributor
ASE Certified Tech
TRS Banner 2010-2011
Joined
Aug 26, 2008
Messages
2,222
Reaction score
36
Points
0
Location
Rainier, OR
Vehicle Year
89
Make / Model
Ford
Engine Size
2.3L
Transmission
Manual
what are the code definitions? bad ECM ground?
 

Madracingalley

New Member
TRS Banner 2010-2011
Joined
Apr 14, 2008
Messages
284
Reaction score
0
Points
0
Age
33
Location
Gansevoort, NY
Vehicle Year
2000
Make / Model
Volvo....
Engine Size
2.4L T5
Transmission
Automatic
553-
556-

Ill edit this when I get the codes from the book
 

Sponsored Ad


Sponsored Ad

Members online

Today's birthdays

Member & Vendor Upgrades

For a small yearly donation, you can support this forum and receive a 'Supporting Member' banner, or become a 'Supporting Vendor' and promote your products here. Click the banner to find out how.

Latest posts

Truck of The Month


Mudtruggy
May Truck of The Month

Recently Featured

Want to see your truck here? Share your photos and details in the forum.

Follow TRS On Instagram

TRS Events

25th Anniversary Sponsors

Check Out The TRS Store


Sponsored Ad


Sponsored Ad

Sponsored Ad


Amazon Deals

Top