Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'PlumCrazy'
October 2014 OTOTM

Mini Truck Of The Month

'Ted R.'
October 2014 MTOTM
 

Go Back   The Ranger Station Forums > Engine & Transmission Forums > V6 Forums > 2.9 Liter Forum

Notices

Reply
 
Thread Tools Display Modes
Old 11-06-2009, 09:24 PM   #1
tommy182018
New Member
 
Join Date: Mar 2008
Posts: 20
Vehicle Year: 1986
Vehicle Make: ford
Vehicle Model: ranger
Rep Power: 0
tommy182018 is on a distinguished road
Angry no injector pulse

got a 86 ranger super 4x4 i hooked up a noid light and have no injector pulse i replaced the distibuter the haleffect and the controll module and the computer it has good fuel presure at the rail just no pulse none into the motor any ideas i love the truck but i am getting mad enough to scrap it it ran fine just neaded a trans put the trans in and a new feul pump ran fine for a day and died replaced everything i listed and still wont run but does run on starting fluid but as soon as it is gone dead put on 3 different control modules did nothing rebuild the distributer nothing put in a new one nothing computer works in my dads bronco 2 with same setup ... any ideas were to look what to try a sencer some were pehaps i looked in my book for it and the computer the control modul and the distributer is the only thing in the circute for the injector ??? please same me from putting her down any info or idea will help
tommy182018 is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Old 11-06-2009, 11:02 PM   #2
Earl43P
Premium Member

 
Join Date: Aug 2007
Location: E-City, NC
Posts: 3,079
Vehicle Year: 2000
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: a driveway ornament, light hauling
Rep Power: 25
Earl43P is just really niceEarl43P is just really niceEarl43P is just really niceEarl43P is just really niceEarl43P is just really nice
Default

If it runs on starting fluid, it's a FP problem, not ignition.

Check the fuel pressure, 12v on both inertia switch pins(connected), and Fuel Pump(s).
Earl43P is offline   Reply With Quote
Old 11-07-2009, 01:27 AM   #3
tommy182018
New Member
 
Join Date: Mar 2008
Posts: 20
Vehicle Year: 1986
Vehicle Make: ford
Vehicle Model: ranger
Rep Power: 0
tommy182018 is on a distinguished road
Default

ir has good pressure and the inertia switch is hard wired i checked the fuel flow as well it is all in spec but the injectors will not fire there is no electrical charge to them at all .... it is not fuel pressure or valume
tommy182018 is offline   Reply With Quote
Old 11-07-2009, 07:36 AM   #4
IMenriched
Member
 
IMenriched's Avatar
 
Join Date: Aug 2007
Location: NE Iowa John Deere country
Posts: 1,494
Vehicle Year: 1986 02'
Vehicle Make: ford
Vehicle Model: ranger f150 fx4
I use this vehicle for: exercise and DD & hauling college kids stuff
Rep Power: 17
IMenriched is on a distinguished road
Default

Quote:
Originally Posted by tommy182018 View Post
ir has good pressure and the inertia switch is hard wired i checked the fuel flow as well it is all in spec but the injectors will not fire there is no electrical charge to them at all .... it is not fuel pressure or valume
Is this manual or auto tranny???

has the safety neutral switch been checked

might also be missing a ground some where?? back of the head perhaps, or the ground near the ECM
__________________
IMenRiched
By the power of Lord Jesus

2 are willing to die for you.
one is a soldier, but the 1st was Jesus Christ
~few appreciate either~
IMenriched is offline   Reply With Quote
Old 11-07-2009, 06:38 PM   #5
tommy182018
New Member
 
Join Date: Mar 2008
Posts: 20
Vehicle Year: 1986
Vehicle Make: ford
Vehicle Model: ranger
Rep Power: 0
tommy182018 is on a distinguished road
Default

it has the ground on the back of the head and the one by the ecm and all clean and a good ground on the 02 sencer it has a 5 speed out of an 89 and the nutral safty switch is good cuz it crancks over
tommy182018 is offline   Reply With Quote
Old 11-10-2009, 02:35 AM   #6
tommy182018
New Member
 
Join Date: Mar 2008
Posts: 20
Vehicle Year: 1986
Vehicle Make: ford
Vehicle Model: ranger
Rep Power: 0
tommy182018 is on a distinguished road
Default

went back through and re checked all grounds under hood all of them are good . anyone have a clue what to look at next????
tommy182018 is offline   Reply With Quote
Old 11-10-2009, 07:02 AM   #7
Bob Ayers
Premium Member
 
Join Date: Aug 2007
Location: Durham, NC
Posts: 2,264
Vehicle Year: 1999
Vehicle Make: Ranger
Vehicle Model: St. Cab
Rep Power: 21
Bob Ayers has a spectacular aura aboutBob Ayers has a spectacular aura aboutBob Ayers has a spectacular aura about
Default

Check and see if your getting 12V to the injectors. If the PCM isn't pulsing them (negative pulse) you should see 12V on both sides of the injector coil.
__________________
"you can rant, rave, scream, shout invective, claim infinite experience,
and ultimatly deny that you are wrong until hell freezes, but you are WRONG." Alland
Bob Ayers is offline   Reply With Quote
Old 11-11-2009, 07:06 PM   #8
tommy182018
New Member
 
Join Date: Mar 2008
Posts: 20
Vehicle Year: 1986
Vehicle Make: ford
Vehicle Model: ranger
Rep Power: 0
tommy182018 is on a distinguished road
Default

i am going to check this out ether today or tomarrow when it stops raining (i have to work on it out side) .... were does the 12v come from so i can chase it back the other way if i dont have it??? is it one of the fusable links on the starter silinoid
tommy182018 is offline   Reply With Quote
Old 11-11-2009, 07:27 PM   #9
Bob Ayers
Premium Member
 
Join Date: Aug 2007
Location: Durham, NC
Posts: 2,264
Vehicle Year: 1999
Vehicle Make: Ranger
Vehicle Model: St. Cab
Rep Power: 21
Bob Ayers has a spectacular aura aboutBob Ayers has a spectacular aura aboutBob Ayers has a spectacular aura about
Default

Quote:
Originally Posted by tommy182018 View Post
i am going to check this out ether today or tomarrow when it stops raining (i have to work on it out side) .... were does the 12v come from so i can chase it back the other way if i dont have it??? is it one of the fusable links on the starter silinoid
Check your PMs.
__________________
"you can rant, rave, scream, shout invective, claim infinite experience,
and ultimatly deny that you are wrong until hell freezes, but you are WRONG." Alland
Bob Ayers is offline   Reply With Quote
Old 11-11-2009, 07:47 PM   #10
tommy182018
New Member
 
Join Date: Mar 2008
Posts: 20
Vehicle Year: 1986
Vehicle Make: ford
Vehicle Model: ranger
Rep Power: 0
tommy182018 is on a distinguished road
Default

PMs what and were is that
tommy182018 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 10:59 PM.




1999-2014 / 959 Media LLC / All Rights Reserved