• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

vacuum


  1. Vacuum hose diagram for heating/AC

    I have a 2005 Ford Ranger 2.4 l engine, manual transmission, AC Does anyone have a diagrams showing the vacuum hoses to/from the switch for various vent/air conditioning? I have removed part of the dash, that is to say, the center panel where the ventilation/heating/air conditioning switches are...
  2. Captain Ledd

    A new approach to bleeding your Power Steering system.

    I had meant to do a write-up on this for a while now (original thread was over a year ago) but never got around to it. Lately I had some PM's concerning this process so I decided it was time to put an actual how-to together. Difficulty: 1 out of 10 Time to install: Tubes and hoses - maybe 10...
  3. High RPMs on neutral, possible vaccum leak?

    Hey everyone, happens to be my first post! I just recently bought a used Ranger (2003 2.3L 4cyl) and it just developed a small RPM issue. I'll do my best to be verbose: When I start the engine, the RPMs are very slow to settle down. Starts out at about 2k and works its way down to ~800 over...
  4. Compression Test Results

    1996, 2.3 liter ford ranger with 207k miles on her. I recently replaced the head gasket and repaired a handful of vacuum leaks. Symptoms: poor idle rough start while cold impossible to start while warm smell of gas after second attempt, however it could be I'm flooding it trying so much...
  5. Vacuum Problem?

    I've lurked for years, though never had any problems worthy of you guys. Hopefully you can help... My vehicle had been running rough for a while. I finally got around to checking it out and replaced two vacuum hoses. Now, it is very difficult to start the vehicle (it'll turn over for a while...
  6. Vacuum Leak stock 2.8

    Okay, so the weather is cooling down around here (though it's Phoenix, so that means 40s overnight), and it's causing my bone-stock 84 BII to idle HORRIBLY first thing in the morning. I've been driving it with a known vacuum leak for months now 'cause I just got tired of looking for it, but I'm...
  7. Engine running lean???

    I've recently replaced the EGR valve and the tube on my 4.0 and now I am getting a few engine codes... 1. Bank 2 sensor 1 slow response, 2. Bank 2 too lean, 3. OBD test incomplete. The O2 sensor is switching from rich to lean and I don't see any damage on the wires. Is there supposed to be...
  8. maemae

    Vacuum issue: HVAC only out defroster vents.

    So I know this topic has been posted here many times before, but I still can't find my solution. I have a 2004 ranger 2.3L 2 wheel drive, which has the hvac only coming out the defroster. I read that it is a vacuum line issue, so I looked at my lines under the hood. I realized that the gray...
  9. Vacuum Sucks

    So my warm engine hesitation /misfire isn't posting codes 21 and 24 anymore. Must have been just an improper test. Now i'm posting code 41 HEGO reads too lean. First thought O2 sensor as the problems seem to start when going into closed-loop. The previous owner said it was recently replaced...
  10. loud humming sound 96 b4000 4x4

    while driving i get a loud humming sound it starts out faint then gets louder and faster until it stops. when it does my tach drops from around 1300 right down to about 500 or less sometimes stalling the engine. if i step on the gas it goes away. this seems to happen mostly when i am slowing...
  11. Heater/thermostat/vacuum problem

    Currently my 2001 Ranger 2.3L has had some trouble with the heater temperature. For the past month when I start it (very cold outside) the engine makes a slight singing noise but once warmed up this goes away. Now I havent noticed the sound as much even though it is a little warmer, but to my...


Top