• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Recent content by Craig0320


  1. Craig0320

    Ford ranger 2002 3.0 4x4

    You really have to be careful ordering from amazon. I ordered two sets for a cherokee and both were terrible. Sent them back and ordered oem reman's on ebay for 80 bux and that was 40k ago. No issues.
  2. Craig0320

    Issues after rebuild :( Low oil pressure & gas smell in coolant

    https://www.amazon.com/Block-Tester-BT-500-Combustion-Leak/dp/B06VVBSFTF/ref=sr_1_4?dchild=1&keywords=head+gasket+test+kit&qid=1614773680&sr=8-4 Buy one of these to test for head gasket leak. It has worked every time for me if combustion gases were present in the coolant. Cheap tool to save...
  3. Craig0320

    NO VOLTAGE TO INJECTORS

    Glad you got it going.
  4. Craig0320

    NO VOLTAGE TO INJECTORS

    Contact a good remote tuner. They can delete pats and the auto transmission programming out of the pcm and ship it back to you. Should cost 100-150 bux. I'm not sure if he does remote pcm tuning by contact https://www.facebook.com/TuningbyJames/.
  5. Craig0320

    pats help

    Foxbody seats sound like a great solution.
  6. Craig0320

    NO VOLTAGE TO INJECTORS

    Yup. They are a mated pair. The module reads the key and then sends the signal to the pcm with the stored matched signal. If the computer doesn't see the correct signal from the pats module it will not send signal ground to fire the injectors. The injectors have power all the time. They just...
  7. Craig0320

    NO VOLTAGE TO INJECTORS

    You either have a bad wire or blown fuse somewhere. The injectors should have 12volts all the time with key in run position. As Gump stated also could be the pcm isn't sending the ground to trigger the injectors. Have you used a multimeter to test and see if you have 12volts. If so the pats...
  8. Craig0320

    pats help

    No problem. Glad I can.
  9. Craig0320

    pats help

    Leave the black/white wire out and put some tape around it.
  10. Craig0320

    pats help

    Remove pin 8 Black/Yellow wire from 10 pin connector and remove the Black/White wire from pin 1 on the 16 pin connector and install the pin 8 Black/Yellow wire.
  11. Craig0320

    pats help

    I'm the same height and weigh 230lbs. I feel your pain. I am getting ready to sell my ranger and by a full size. I am getting constant back pain and I know it's from riding in the ranger. Nothing wrong with the seat foam. I have to put a towel between my knee and the door panel.
  12. Craig0320

    pats help

    I wired pats into my 98 ranger and all the wiring was the same. Pats started in 99 model year for ranger so you might have all the wiring behind the dash to just plug the explorer module in.. If not mount the key and transceiver up above your brake pedal and away from any metal. I had...
  13. Craig0320

    New here and need help

    Did you replace the iac with a cheap parts store aftermarket. I had the same idle issues. I bought a factory ford iac and it worked perfect ever since, Even the hitachi brand works well.
  14. Craig0320

    Wanted M50D-R1 HD

    I beat the living crap outta my 98 5 speed and never had a problem. Sold it with a ton of miles on it too.
  15. Craig0320

    First Ranger

    Damn baby yoda gets me every time.


Top