Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'RICO9'
July 2014 OTOTM

Mini Truck Of The Month

'Cole' Dave'
July 2014 MTOTM
 

Go Back   The Ranger Station Forums > TRS Photo & Video Galleries > Your Garage > Off-Road Rangers Under Construction

Off-Road Rangers Under Construction Share your off-road Ranger projects here so we can follow the progress.

Reply
 
Thread Tools Display Modes
Old 03-07-2012, 04:18 PM   #1
xeducatex
New Member
 
xeducatex's Avatar
 
Join Date: Jul 2009
Location: orange county
Posts: 8
Vehicle Year: 1987
Vehicle Make: mazda
Vehicle Model: b2600
I use this vehicle for: daily driver
Rep Power: 0
xeducatex is on a distinguished road
Default 1987 mazda b2600 build

so yesterday i picked up a 1987 mazda b2600 4x4 manual trans

the owners were asking 1200 but after seeing all the work needing to be done i was reluctant to offer the 700$ that i did but they ended up taking it

i was pretty dead set on towing it home but my mechanic friend was certain it would make the 45 mile trip back home so we drove back with no issues

once we got back into town we did a compression check and turns out all four cyl are giving good compression so thats a HUGE vicotry for me already. also found there is nothing but water in the radiator. which compounded with the dead temp sensor prolly isnt a good thing. lucky for me the PO rarely used the truck.....mostly just a extra truck to move big things.

the PO said they replaced the transmission with a new one in 09 and a new clutch 3 months ago. it shifts pretty smooth but there is alot of play when in nuetral

we also found that a pipe that looks to be running from what i believe is the air control unit to the exhaust by where it meets the engine is rusted to crap. idk what exactly its for but due to the spider webs in it i know its been like that for quite some time. im not sure if its even the air control unit because i cant find a decent engine diagram. ill post pics later tonight


PO also said the axle fell off a few months ago due to old bushings and ball joints but it was repaired by a family mechanic friend and from what me and MY mechanic friend can tell, there is no damage from taht other then a badly mangled front fender.


currently ill be daily driving while slowly fixing

as far as the drivetrain goes everything seems to be sound. most of my time will be focused on vacuum leaks, sensors, gaskits, hoses, fluids, fine tuning the crappy stock carb.

it seems to be a good reliable truck but it has NO power......in first and second there is a SMALL bit of power but after that i can be peddle to the metal and there wont be any significant change in acceleration. just a slow steady acceleration. we got it up to 80 on the freeway so it can get going it just takes a while to get there/


i never thought id be the owner of a mazda truck

i honestly never once saw a cool looking mazda truck or a 4x4 mazda truck in my entire life before this truck. it seems like its going to be with me for a while tho.






btw before you even start......
this thread is worthless without pics
xeducatex is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Old 03-07-2012, 04:33 PM   #2
koda6966
Member
 
koda6966's Avatar
 
Join Date: Nov 2007
Location: The green part of NY.
Posts: 7,912
Vehicle Year: 1993
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Giving me pride.
Rep Power: 36
koda6966 is a splendid one to beholdkoda6966 is a splendid one to beholdkoda6966 is a splendid one to beholdkoda6966 is a splendid one to beholdkoda6966 is a splendid one to beholdkoda6966 is a splendid one to beholdkoda6966 is a splendid one to behold
Default

That sounds odd for a B2600i to not have power, I used to be able to roast the tires on mine, never had any problem getting up to speed or up my hills either. I live in the foothills of the Catskill Mountians in NY.
__________________
1993 Ford Ranger XL 3.0/Auto. Edge Conversion. 03 Explorer seats. Never ending project. Get's cannibalized then rebuilt monthly.
1997 Jeep Cherokee Sport. 4x4/4.0/auto. Daily Driver & parts snagger.
1989 Chevy Cheyenne 1500. 305/auto. PLEASE BURN IT
2004 Nissan Titan LE 5.6/auto/4x4. Light Duty Tow Pig.


Ranger Build Thread.
Jeep XJ Build Thread.
koda6966 is offline   Reply With Quote
Old 03-07-2012, 05:19 PM   #3
infantry grunt
Member
 
infantry grunt's Avatar
 
Join Date: May 2009
Location: alabama
Posts: 215
Vehicle Year: 1994
Vehicle Make: mazda
Vehicle Model: b-3000
I use this vehicle for: everything
Rep Power: 11
infantry grunt will become famous soon enough
Default

does it have over sized tires or stock,that could cause it to be sluggish pulling hills and slow acceleration on the highway.My truck was the same way after the 33s were installed and before the proper gear ratio
__________________
4 inch skyjacker,3 inch body,d35 and 99 explorer 8.8 with disc brakes,33x1250-15,4.56 gears,flat black paint, spare tire carrier(made from sway bar and some angle iron)
infantry grunt is offline   Reply With Quote
Old 03-07-2012, 05:54 PM   #4
koda6966
Member
 
koda6966's Avatar
 
Join Date: Nov 2007
Location: The green part of NY.
Posts: 7,912
Vehicle Year: 1993
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Giving me pride.
Rep Power: 36
koda6966 is a splendid one to beholdkoda6966 is a splendid one to beholdkoda6966 is a splendid one to beholdkoda6966 is a splendid one to beholdkoda6966 is a splendid one to beholdkoda6966 is a splendid one to beholdkoda6966 is a splendid one to behold
Default

Your truck was probably slow from the beginning, being powered by the 3.slow and all.

Don't worry, I have that engine too.
__________________
1993 Ford Ranger XL 3.0/Auto. Edge Conversion. 03 Explorer seats. Never ending project. Get's cannibalized then rebuilt monthly.
1997 Jeep Cherokee Sport. 4x4/4.0/auto. Daily Driver & parts snagger.
1989 Chevy Cheyenne 1500. 305/auto. PLEASE BURN IT
2004 Nissan Titan LE 5.6/auto/4x4. Light Duty Tow Pig.


Ranger Build Thread.
Jeep XJ Build Thread.
koda6966 is offline   Reply With Quote
Old 03-08-2012, 03:14 AM   #5
xeducatex
New Member
 
xeducatex's Avatar
 
Join Date: Jul 2009
Location: orange county
Posts: 8
Vehicle Year: 1987
Vehicle Make: mazda
Vehicle Model: b2600
I use this vehicle for: daily driver
Rep Power: 0
xeducatex is on a distinguished road
Default




test
xeducatex is offline   Reply With Quote
Old 03-08-2012, 03:34 AM   #6
xeducatex
New Member
 
xeducatex's Avatar
 
Join Date: Jul 2009
Location: orange county
Posts: 8
Vehicle Year: 1987
Vehicle Make: mazda
Vehicle Model: b2600
I use this vehicle for: daily driver
Rep Power: 0
xeducatex is on a distinguished road
Default

ok so i finally got myself some pics!


i took a couple of the rusted and rotting out pipe so that hopefully someone can tell me wtf it is

but first a few of the truck

as you can see grunt it does have a bit of a lift and im not sure how bug the tires are but they appear bigger than stock

sorry for the crappy angles but with the exhaust leak it gets loud and i didnt want to back her out all the way.

hopefully heading over to my mechanics house after work tommorrow to get some things acomplished.

id like to at least replace all the rubber.......unfourtuetly some bills have popped up and took a chunk out of my truck fund but my tax return will hopefully make up for it.


obviously outside of the truck



Uploaded with ImageShack.us
fairly rust free bed



Uploaded with ImageShack.us
still got a lil life left in the tires



Uploaded with ImageShack.us
cool bumper aye



Uploaded with ImageShack.us
decent interior



Uploaded with ImageShack.us
everything



Uploaded with ImageShack.us
thats the stupid rusted out pipe that im clueless about



Uploaded with ImageShack.us
more of the same pipe. as you can see its had repairs before. i hope its not hard to come by!



Uploaded with ImageShack.us
and more of the stuppid pipe

anyone got an idea of what it is and what its purpose is?
xeducatex is offline   Reply With Quote
Old 03-08-2012, 03:38 AM   #7
xeducatex
New Member
 
xeducatex's Avatar
 
Join Date: Jul 2009
Location: orange county
Posts: 8
Vehicle Year: 1987
Vehicle Make: mazda
Vehicle Model: b2600
I use this vehicle for: daily driver
Rep Power: 0
xeducatex is on a distinguished road
Default

btw im sure some of the power issues are attributed to the vacuum leaks and the crappy untuned carb. along with the gearing of course

im reserving judgement until a few more repairs are done.
xeducatex is offline   Reply With Quote
Old 03-08-2012, 10:34 PM   #8
xeducatex
New Member
 
xeducatex's Avatar
 
Join Date: Jul 2009
Location: orange county
Posts: 8
Vehicle Year: 1987
Vehicle Make: mazda
Vehicle Model: b2600
I use this vehicle for: daily driver
Rep Power: 0
xeducatex is on a distinguished road
Default

So i changed the oil todayand found a small leak has popped up but i dont know where.




Then on the way home the truck started.to stumple.upon acceleration but is completely fine in nutral. My mechanic pal says its the egr. Sooo looks like im out of action until i get myself a new one





anyone know if other bseries pickups have a compatible egr i can yank from the jy?
xeducatex is offline   Reply With Quote
Old 05-08-2012, 04:20 PM   #9
xeducatex
New Member
 
xeducatex's Avatar
 
Join Date: Jul 2009
Location: orange county
Posts: 8
Vehicle Year: 1987
Vehicle Make: mazda
Vehicle Model: b2600
I use this vehicle for: daily driver
Rep Power: 0
xeducatex is on a distinguished road
Default

Well I have discovered its not the egr valve. I cant work on it at my apartments so I gotta drive it to my aunts but the temp sensor doesnt work so I dont know if its running hot or not. plus ive been too broke to buy the fluid for the flush. This friday I should be able to get alot done tho. Ill have money and I got what I need to do the cooling.

I changed the temp sensors and the gauge didnt move so I am going to change the water pump and thermostat and see if that fixes it. Also discovered alot of calcium build uo. I guess PO just ran water in it for god knows how long. Any ideas on how to take care of that?

Ive only driven it a few times since it was doing the sumble on acceleration and it hasnt done it since but ti havnt driven it for more than a minute or two.

Im hoping I can get the temp sensor working asap so I can start narrowing down the problems.

Ill also be getting a carb rebuild kit to try and avoid the high cost of a remanufactured one.



Ill keep uodating but u guys gotta show some interest plz
xeducatex is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 01:13 PM.




1999-2014 / 959 Media LLC / All Rights Reserved