Home Ford Ranger Forum Builders Guide How To Tech Other Articles Featured Rangers Readers Rangers Classifieds Shirts & Decals

 

Go Back   The Ranger Station Forums > Help Forums - Engine & Transmission Forums > V6 Forums > 4.0 Liter Forum

Notices

Reply
 
Thread Tools Display Modes
Old 01-09-2019, 08:49 PM   #1
Rangerdanger2000
New Member
 
Join Date: Apr 2017
Location: South Jersey
Posts: 11
Vehicle Year: 1997
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: eventual daily
Rep Power: 0
Rangerdanger2000 is on a distinguished road
Default 1997 4.0 ohv with rich codes (both banks) ???

Good Evening fellow enthusiasts! Still trying to get the kinks out of my 1997 Ranger xlt so far have replaced mass air flow sensor, performed tune up (autolite plugs and duralast wires) both EGR tubes and valve have been replaced and all vacuum hoses checked over. now check engine light is on with codes P0172 and P0175. Only diffence in performance I notice is when I first start driving there is a lot of smoke exiting tailpipe then it starts to go away when warmed up other than that fuel mileage seems decent and idle is smooth. Where should I start?
Rangerdanger2000 is offline   Reply With Quote
Advertisement - Don't want to see the forum ads? Click HERE to find out how to be a Supporting Member.


Rock Auto 5% Discount Code: 29781F0E77DE4B Expires: March 31, 2019
Old 01-10-2019, 02:16 PM   #2
Rangerdanger2000
New Member
 
Join Date: Apr 2017
Location: South Jersey
Posts: 11
Vehicle Year: 1997
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: eventual daily
Rep Power: 0
Rangerdanger2000 is on a distinguished road
Default

anyone??
Rangerdanger2000 is offline   Reply With Quote
Old 01-10-2019, 08:30 PM   #3
RonD
Member
 
Join Date: Jun 2012
Location: canada
Posts: 12,279
Vehicle Year: 1994
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 55
RonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant future
Default

Check the Fuel Pressure Regulator(FPR)
It should be behind alternator on lower intake
It is at the end of the fuel rail and has Return Fuel line attached and a smaller Vacuum hose

You need to check that vacuum hose for gasoline, replace FPR if gasoline is found
This is more likely if BOTH banks see Rich codes


Leaking injector should only effect 1 bank


Rich code doesn't mean engine is actually running Rich
Same as Lean code doesn't mean engine is running Lean

These codes tells you that the computer's calculated open time for each injector is incorrect
After computers air/fuel mix is burned in the engine computer gets feedback from the Oxygen sensors(O2s)
Too little oxygen is Rich mix, too much oxygen is Lean mix

So computer adjusts the injector Open Time to get O2 sensors reading correct oxygen levels in exhaust
If you get Rich codes on both banks then computer had to reduce the open time for the injectors on both banks of the engine
So engine is not running Rich the computer is closing injector sooner, the code are to let you know there is a problem.

Partial blocked exhaust can cause Rich codes, and if you have a single exhaust, then Rich on both banks as well.

Partially blocked exhaust should cause problems at higher RPMs highway speeds and a lack of power
But lower speeds or idle would be fine
RonD is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
4.0 ohv rough idle runs rich codes ect code i forgot 159koeo/r, 412koer 129koer blue_pill85 4.0 Liter Forum 7 08-21-2018 12:26 AM
The issues keep piling up - '91 2.9 runs rich, shuts off, codes 41 & 42... Fairlaniac General Discussions 25 12-24-2015 12:02 PM
Running so rich it's fouling plugs and stall,codes. ben_2_go 4-Cylinder (2000 & Older) 35 09-06-2015 05:26 PM
random misfire, runs rich, engine codes kunar 4.0 Liter Forum 6 10-01-2012 02:03 AM
Rich/Lean codes adamputz 4.0 Liter Forum 3 01-22-2009 11:30 AM




All times are GMT -5. The time now is 07:54 PM.




© 1999-2018 / 959 Media LLC / All Rights Reserved