Home Ford Ranger Forum Builders Guide How To Tech Other Articles Featured Rangers Readers Rangers Classifieds Shirts & Decals

 

Go Back   The Ranger Station Forums > Help Forums - Engine & Transmission Forums > Transmissions

Notices

Reply
 
Thread Tools Display Modes
Old 01-13-2019, 11:25 AM   #1
ben_2_go
Member
 
Join Date: Aug 2007
Location: Third rock from sun
Posts: 134
Vehicle Year: 2001
Vehicle Make: Turd
Vehicle Model: Ranger Xtra Large Turd
I use this vehicle for: wasting money on repair parts.
My credo: None at all.
Rep Power: 23
ben_2_go is on a distinguished road
Exclamation Transmission trouble codes after DPFE replacement

This past Tuesday I replaced the DPFE sensor due to a P1401 trouble code and cleared the trouble code out of the PCM. The new DPFE cleaned up the idle and intermitting stalling problems. I had a high idle problem though, 950 to 1100 rpm. I drove the truck hoping it would settle down and the computer would "learn" the new sensor. During this time, my GF admitted that her brother screwed with the throttle plate stop screw. He thought it was an idle adjustment screw. I didn't have time to go through the procedure to reset the throttle plate screw properly due to some family issues.



Friday, on my way to lunch the truck started shifting hard. Eventually, the O/D light started flashing and the check engine light came on. The truck would start from a stop in second gear, shift hard into third and stay there until I came to a complete stop. Then it would start all over. I've searched and read that some people have had similar issues and after shutting down the truck for awhile then restarting it seems to go away. That's not my case. I scanned the PCM and got these codes,



P1401 DPFE sensor circuit high voltage detected



P0133 (h2os-11) circuit slow response


P0141 (ho2shtr12) heater circuit malfunction


P0732 transmission gear incorrect ratio


P1756 solenoid (shift(b))-open or short


I replaced both O2 sensors less than 10,000 miles ago and the DPFE sensor less than 75 miles ago. I also cleaned the VSS connection less than 6000 miles ago due to erratic shifting. Could all these random issues indicate a bad or failing PCM? I find it hard to believe that this truck went from needing a DPFE sensor to having this many issues and codes after the sensor replacment. The truck has close to 260,000 miles on it now. I've maintained it in top condition. I did the maintenance on it when my GF owned the truck.
__________________
2001 Furd Strangler/Xtra Large Turd/2.5Looser Autoshatic/4x 1 wheel spins
ben_2_go is offline   Reply With Quote
Advertisement - Don't want to see the forum ads? Click HERE to find out how to be a Supporting Member.


Rock Auto 5% Discount Code: 29781F0E77DE4B Expires: March 31, 2019
Old 01-13-2019, 11:53 AM   #2
Dirtman
Member
 
Join Date: May 2018
Location: Over there --->
Posts: 562
Vehicle Year: 2009
Vehicle Make: Ford
Vehicle Model: ranger
I use this vehicle for: Squishing jelly beans
My credo: give me money.
Rep Power: 4
Dirtman will become famous soon enoughDirtman will become famous soon enough
Default

All of those codes relate to electrical issues obviously and all of those systems wiring comes together near the dpfe sensor... So highly suspicious circumstance.

My first step would be to check the harness near the dpfe sensor as well as the ground strap at the firewall and pcm connection itself. Also hard reset the pcm (disconnect the battery and hold the terminals together for 10 or so mins).

Last edited by Dirtman; 01-13-2019 at 11:55 AM.
Dirtman is offline   Reply With Quote
Old 01-13-2019, 02:21 PM   #3
ben_2_go
Member
 
Join Date: Aug 2007
Location: Third rock from sun
Posts: 134
Vehicle Year: 2001
Vehicle Make: Turd
Vehicle Model: Ranger Xtra Large Turd
I use this vehicle for: wasting money on repair parts.
My credo: None at all.
Rep Power: 23
ben_2_go is on a distinguished road
Default

Quote:
Originally Posted by Dirtman View Post
All of those codes relate to electrical issues obviously and all of those systems wiring comes together near the dpfe sensor... So highly suspicious circumstance.

My first step would be to check the harness near the dpfe sensor as well as the ground strap at the firewall and pcm connection itself. Also hard reset the pcm (disconnect the battery and hold the terminals together for 10 or so mins).

You're right. I have cleaned several connections under the truck over the past few years. I will clean those and do the reset and see what happens. Just gotta let all this rain move out first. No shop currently to work in.
__________________
2001 Furd Strangler/Xtra Large Turd/2.5Looser Autoshatic/4x 1 wheel spins
ben_2_go is offline   Reply With Quote
Old 01-13-2019, 02:29 PM   #4
RonD
Member
 
Join Date: Jun 2012
Location: canada
Posts: 12,279
Vehicle Year: 1994
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 55
RonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant future
Default

Check/replace Fuse #41(20amp) in the engine fuse box
RonD is offline   Reply With Quote
Old 01-13-2019, 02:57 PM   #5
ben_2_go
Member
 
Join Date: Aug 2007
Location: Third rock from sun
Posts: 134
Vehicle Year: 2001
Vehicle Make: Turd
Vehicle Model: Ranger Xtra Large Turd
I use this vehicle for: wasting money on repair parts.
My credo: None at all.
Rep Power: 23
ben_2_go is on a distinguished road
Default

Quote:
Originally Posted by RonD View Post
Check/replace Fuse #41(20amp) in the engine fuse box



Can you elaborate on why and what fuze that is for? I don't have my manual handy to see what fuse that covers. TIA
__________________
2001 Furd Strangler/Xtra Large Turd/2.5Looser Autoshatic/4x 1 wheel spins
ben_2_go is offline   Reply With Quote
Old 01-13-2019, 04:20 PM   #6
RonD
Member
 
Join Date: Jun 2012
Location: canada
Posts: 12,279
Vehicle Year: 1994
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 55
RonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant future
Default

O2 heaters, trans sensors, solenoids, a few other things
RonD is offline   Reply With Quote
Old 01-13-2019, 10:15 PM   #7
ben_2_go
Member
 
Join Date: Aug 2007
Location: Third rock from sun
Posts: 134
Vehicle Year: 2001
Vehicle Make: Turd
Vehicle Model: Ranger Xtra Large Turd
I use this vehicle for: wasting money on repair parts.
My credo: None at all.
Rep Power: 23
ben_2_go is on a distinguished road
Default

Quote:
Originally Posted by RonD View Post
O2 heaters, trans sensors, solenoids, a few other things



Depending on the weather tomorrow, I am going to try and make some headway cleaning connections and swapping out that fuse you mention. Can't hurt to try. I have a few dozen of fuses laying around just waiting for their chance to blow.
__________________
2001 Furd Strangler/Xtra Large Turd/2.5Looser Autoshatic/4x 1 wheel spins
ben_2_go is offline   Reply With Quote
Old 01-15-2019, 05:26 PM   #8
ben_2_go
Member
 
Join Date: Aug 2007
Location: Third rock from sun
Posts: 134
Vehicle Year: 2001
Vehicle Make: Turd
Vehicle Model: Ranger Xtra Large Turd
I use this vehicle for: wasting money on repair parts.
My credo: None at all.
Rep Power: 23
ben_2_go is on a distinguished road
Default

I went through all the connectors, grounds, and fuses. I cleaned and wiped everything down. I found no corrosion anywhere but cleaned everything anyway. I changed the #41 underhood fuse. Mine was a 10A mini fuse. I've never had a blown fuse in this truck, neither has my GF. I think it's all coincidental that these problems cropped up right after the DPFE change. The transmission in this truck has never shifted properly since it was bought slightly used with less than 50k miles. The truck now has just about 250K miles. I think it's time for the junkyard.
__________________
2001 Furd Strangler/Xtra Large Turd/2.5Looser Autoshatic/4x 1 wheel spins
ben_2_go is offline   Reply With Quote
Reply

Bookmarks



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
87 ranger 2.3 dpfe replacement parts??? MikeW 4-Cylinder (2000 & Older) 7 05-02-2017 11:40 AM
Trouble codes pvtmikes 3.0 Liter Forum 0 10-07-2016 01:28 PM
Help with Trouble Codes. AtomicVette 4-Cylinder (2000 & Older) 1 10-28-2011 04:33 PM
Trouble codes HELP dragonboi 4.0 Liter Forum 6 03-15-2010 12:15 AM
Trouble codes mht95ranger 4.0 Liter Forum 1 03-18-2008 02:37 PM




All times are GMT -5. The time now is 02:05 AM.




© 1999-2018 / 959 Media LLC / All Rights Reserved