• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Vehical speed sensor... Help

FloridaGrown

New Member
Joined
Oct 6, 2014
Messages
35
Reaction score
0
Points
0
Vehicle Year
2000
Make / Model
Ford
Engine Size
4.0 v6
Transmission
Automatic
I'm new to this site and could use some help from some of the gurus. I just bought a 2000 Ford ranger sport v6 4.0 2wd and I'm getting a check engine light and my Speedo wasn't working either. So after grabbing a bite to eat and getting some gas and getting getting to the house I started pulling fuses and realized there was a fuse missing. I put a fuse in and the Speedo started working. I still have the light. I went to advanced auto and got the truck scanned and the vehicle speed sensor was the only code. I understand how the VSS functions but could the lack of a fuse cause the light? Do I have to clear the code? I'm confused.. I don't know wether to clear the code or look into replacing the VSS by the way how do you clear the code? Pop the ground off the battery or do I have to do it with a scanner? thanks in advance!
A-Ron
 


OneEyedGimpyGuy

New Member
Joined
Aug 31, 2014
Messages
11
Reaction score
1
Points
0
Vehicle Year
2005
Make / Model
Ford
Transmission
Automatic
Clear the code. If it comes back replace vss then clear again. The vss isn't too expensive or hard to replace. I did it to my old 2000 3.0 4X4.
 

OneEyedGimpyGuy

New Member
Joined
Aug 31, 2014
Messages
11
Reaction score
1
Points
0
Vehicle Year
2005
Make / Model
Ford
Transmission
Automatic
Oh, advance should be able to clear it for u
 

Earl43P

Well-Known Member
U.S. Military - Veteran
Joined
Aug 7, 2007
Messages
3,159
Reaction score
37
Points
48
Location
Stafford, Va
Vehicle Year
2019
Make / Model
Ford F250 4WD
Engine Size
3.0
Transmission
Manual
Disconnect battery, turn on headlamps, then off.
Reconnect battery, code will be cleared.
 

Sponsored Ad


Sponsored Ad

Top