V8 swap electrical issues.


yoshi

New member
Joined
Dec 12, 2018
Messages
7
Reaction score
6
Points
3
Location
Texas
Vehicle Year
1988
Make / Model
Ford
Transmission
Manual
Hey y'all. Working on my 5.0 Ranger swap and I have run into my first electrical issue. The fuel pump relay pin that should be grounded by the PCM in run position or cranking is instead reading 8.7v when in run. Testing other wires I found some with -3.3v, some with 12v, and some with 8.7v. The relay is not activating as the potential across the relay pins is only 3v and the fuel pump is not running.
My first thought was bad grounds. I ran a dedicated ground from the battery to the computer ground wires, no change.
Any thoughts?
I'm using the engine harness from a 95 F-150 5.0 with an M50D and Speed Density, Ranger is a 1988 2.9 5-Speed 4x4.
Thanks.
 


Rock Auto 5% Discount Code: 32B05A80BF19AF Expires: July 1st, 2020

yoshi

New member
Joined
Dec 12, 2018
Messages
7
Reaction score
6
Points
3
Location
Texas
Vehicle Year
1988
Make / Model
Ford
Transmission
Manual
Update for anyone who encounters this issue, I had grounded the case of the PCM but not the power ground on pin 40 and 60. After grounding these pins everything worked as expected.
 

alwaysFlOoReD

Forum Staff Member
Forum Moderator
TRS Banner 2012-2015
TRS 20th Anniversary
Joined
Apr 13, 2009
Messages
10,364
Reaction score
1,305
Points
113
Location
Red Deer, Canada
Vehicle Year
'91, '94, '80
Make / Model
Ford, GMC
Engine Size
4.0,4.0,350
Transmission
Manual
Thanks for the update and fix.
 


Top