• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

V8 help


alwaysFlOoReD

Forum Staff Member
TRS Forum Moderator
TRS Banner 2012-2015
TRS 20th Anniversary
Joined
Apr 13, 2009
Messages
13,927
Reaction score
5,077
Points
113
Location
Calgary, Canada
Vehicle Year
'91, '80, '06
Make / Model
Ford, GMC,Dodge
Engine Size
4.0,4.0,5.7
Transmission
Manual
2WD / 4WD
4WD
ALRIGHTY BOYS, and ladies.... I stripped the engine down to the pistons to check my piston walls, no damage was detected. I got her all put back together, and while I was at it, I ordered some new OEM injectors, thinking that might be the cause of any possible engine flooding. And now she runs great, I'm really hoping that the new injectors will also solve my low MPG's problem. Since the conclusion of the community there was that I possibly had a fuel leak, though, I couldn't find where. So Two birds one stone. As far as the engine being frozen before, I have no idea what caused the engine to sound like a "diesel truck" I pulled the water pump, and everything was completely fine, so IDK... but its not a problem now. I popped two freeze plugs out, both in the hardest place possible to replace them, but I managed to jack the engine up and install the neoprene fastener replacement, they seem to be working properly... for now. It seems I almost entirely avoided any damage to the engine from the deep freeze. I say "almost" because now my rear main seal, which was leaking like a drop or two a day, has enlarged to many many drops every time I run the truck. I guess I can't complain too much since I avoided a much more expensive fix, but now I'm cursed to be continually checking my oil level until June when I'll be back home with my floor jack to drop the transmission. Oh, Also, I fixed the issue I was having with voltage as well. I was having random times when my truck would drop to 13.5 volts or lower volts while running, which was... concerning, but I couldn't find what was wrong. turns out the Passenger side fire wall to engine block ground was not properly installed. So, when I put the engine back together this time, I was able to properly connect the firewall ground to the cylinder head, now everything is running perfectly at 14.5.

In conclusion. I fixed my gas flooding issue, and, I hope my bad MPG's. I fixed my popped freeze plugs, and I got my voltage regulation problem solved. I gained, however, a larger rear main seal leak. Can't win them all, but it would seem this break down has been an overall positive turn of events. thanks for every ones help.
Check your PCV system.
 


Tomm1468

Active Member
V8 Engine Swap
Joined
Apr 22, 2021
Messages
101
Reaction score
41
Points
28
Location
Spokane, WA
Vehicle Year
2000
Make / Model
Ranger XLT
Engine Type
V8
Engine Size
5.0
Transmission
Automatic
2WD / 4WD
4WD
Total Lift
3"
Tire Size
245/75R16
Check your PCV system.

Just went and checked it out, it was all plugged in and working fine, what I did find was that the oil was not leaking out of the rear main seal.. for the most part. It was leaking out the back of my valve cover, So I pulled the intake off and have an order in for a new rubber fel-pro gasket. I also spent 10 minutes hammering the holes flat, since I figure thats the reason it was leaking in the first place. Thanks for the advice, it indirectly helped me figure things out.
 

Tomm1468

Active Member
V8 Engine Swap
Joined
Apr 22, 2021
Messages
101
Reaction score
41
Points
28
Location
Spokane, WA
Vehicle Year
2000
Make / Model
Ranger XLT
Engine Type
V8
Engine Size
5.0
Transmission
Automatic
2WD / 4WD
4WD
Total Lift
3"
Tire Size
245/75R16
new valve cover gasket installed, no oil leak, so i guess the rear main was fine and I had a small valve cover leak before. guess thats what I get for using the crappy cork Gaskets. My new gasket is the fel pro silicone.
 

Tomm1468

Active Member
V8 Engine Swap
Joined
Apr 22, 2021
Messages
101
Reaction score
41
Points
28
Location
Spokane, WA
Vehicle Year
2000
Make / Model
Ranger XLT
Engine Type
V8
Engine Size
5.0
Transmission
Automatic
2WD / 4WD
4WD
Total Lift
3"
Tire Size
245/75R16
Ok, so I've finally been able to get in a decent amount of driving and my MPG still sucks nuts, about 10 in the city. All the things that have been replaced within the past month. IAC, PCV, Spark Plugs, Wires, all vacuum lines, Fuel injectors, 02 sensors (upstream). I realize that I'm basically just throwing money at the problem, but can't figure out how to get it to go away. Today I started looking at the live data and notice 1.) my engine (at operating temp) idles at around 650, and sounds not quite like it's misfiring, but more like a stumble every now and again. 2.) my long term fuel trim 1 and 2 are both high while I'm idling in drive (both are sitting at about 14-16. 3.) my Short term fuel trim 1 and 2 are sitting at their top range when I'm idling in park (both sitting between 8-11). 4.) my MAF was reading intake air between 60 and 85 degrees, though its only 40 outside. I didn't see anything else noteworthy, but I'm reallllly new to reading the computer live data for diagnostic purposes, so I need help. I have a new MAF sensor that I've been sitting on installing because I didn't have the special security star screw head set, but I'll probably install that today and see if it helps at all, otherwise, I can't think of anything it could be. All the parts I'm buying are quality parts and are reading "what I think" is accurately. The last thing it might be, thats on my mind is my coil packs, I bought some new ones off ebay for relatively cheap when I built the engine, I still have the OEM ones somewhere, but if the new aftermarket ones are already starting to fade, this could be the problem too. anyway. I'll attach some pics of the live data for comment, I know its not a vacuum leak, because 1.) new hoses and 2.) I've gone around with propane and tested all the hoses that way as well.
 

Attachments

Tomm1468

Active Member
V8 Engine Swap
Joined
Apr 22, 2021
Messages
101
Reaction score
41
Points
28
Location
Spokane, WA
Vehicle Year
2000
Make / Model
Ranger XLT
Engine Type
V8
Engine Size
5.0
Transmission
Automatic
2WD / 4WD
4WD
Total Lift
3"
Tire Size
245/75R16
also I should probably note, My cats are both brand new, since I had to build the exhaust system for the 5.0, and my fuel filter was changed probably 5 months ago. and the guy who deleted the PATS system off my explorer computer also added an "87 octane performance package" to the computer, which, I have no idea what It means.
 

89RanBrII

Member
Joined
Jun 19, 2023
Messages
39
Reaction score
33
Points
18
Age
19
Location
Newcastle, Wyoming
Vehicle Year
1989
Make / Model
Ranger & BrII
Engine Type
4.0 V6
Engine Size
Ranger: 2.9; BroncoII: 4.0
Transmission
Manual
2WD / 4WD
4WD
What does your air filter look like?
 

Tomm1468

Active Member
V8 Engine Swap
Joined
Apr 22, 2021
Messages
101
Reaction score
41
Points
28
Location
Spokane, WA
Vehicle Year
2000
Make / Model
Ranger XLT
Engine Type
V8
Engine Size
5.0
Transmission
Automatic
2WD / 4WD
4WD
Total Lift
3"
Tire Size
245/75R16
new symptom, its just started to intermittently hesitate to shift up around 40 mph. Not a ton of times, but not none either. I have no idea whats up with this truck.
Also, I put in the new MAF, it brought the long term fuel trim down from 14-16 to within spec (barely) having them sit between 9 and 11.7. the short term is down too. but its still idling around 650 at stop lights, but a little bit smoother of an idle.
 

89RanBrII

Member
Joined
Jun 19, 2023
Messages
39
Reaction score
33
Points
18
Age
19
Location
Newcastle, Wyoming
Vehicle Year
1989
Make / Model
Ranger & BrII
Engine Type
4.0 V6
Engine Size
Ranger: 2.9; BroncoII: 4.0
Transmission
Manual
2WD / 4WD
4WD
its just started to intermittently hesitate to shift up around 40 mph. Not a ton of times, but not none either. I have no idea whats up with this truck.
Automatic transmission???
 

Tomm1468

Active Member
V8 Engine Swap
Joined
Apr 22, 2021
Messages
101
Reaction score
41
Points
28
Location
Spokane, WA
Vehicle Year
2000
Make / Model
Ranger XLT
Engine Type
V8
Engine Size
5.0
Transmission
Automatic
2WD / 4WD
4WD
Total Lift
3"
Tire Size
245/75R16
Automatic transmission???
Yes, I have a 302 out of an 00 Mountaineer and the accompanying 4R70W. Both of which only had 80k miles on them.
my transfer case doesn't work, pretty sure the chain is broken inside, but its a manual shift BW4406 out of an 00 F150. maybe that's the culprit ?
 

Tomm1468

Active Member
V8 Engine Swap
Joined
Apr 22, 2021
Messages
101
Reaction score
41
Points
28
Location
Spokane, WA
Vehicle Year
2000
Make / Model
Ranger XLT
Engine Type
V8
Engine Size
5.0
Transmission
Automatic
2WD / 4WD
4WD
Total Lift
3"
Tire Size
245/75R16
new symptom, P0340 code has popped up, I did have my cam synchronizer go out and I replaced it with the highest quality one I could find. I have a new sensor, and a new alternator, and haven't had any trouble with this code over the last 200 miles since I put the motor back together.
 

Tomm1468

Active Member
V8 Engine Swap
Joined
Apr 22, 2021
Messages
101
Reaction score
41
Points
28
Location
Spokane, WA
Vehicle Year
2000
Make / Model
Ranger XLT
Engine Type
V8
Engine Size
5.0
Transmission
Automatic
2WD / 4WD
4WD
Total Lift
3"
Tire Size
245/75R16
So, I think I solved the transmission issues, I took the time to do a proper fluid check and got it perfect and haven't had any other problems. the P0340, idk what its about, i have a new alternator in so it should be ok, so if it comes back up, then Ill check it. the engine is running a little smoother, but still low mpg's. ill just have to accept for now.
 

Sponsored Ad


Sponsored Ad

Staff online

Members online

Member & Vendor Upgrades

For a small yearly donation, you can support this forum and receive a 'Supporting Member' banner, or become a 'Supporting Vendor' and promote your products here. Click the banner to find out how.

Latest posts

Truck of The Month


Shran
April Truck of The Month

Recently Featured

Want to see your truck here? Share your photos and details in the forum.

Follow TRS On Instagram

TRS Events

25th Anniversary Sponsors

Check Out The TRS Store


Sponsored Ad


Sponsored Ad

Sponsored Ad


Amazon Deals

Top