• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Truck starts but stalls until warmed up.


VTChavez

New Member
U.S. Military - Veteran
Joined
Jul 28, 2021
Messages
5
Reaction score
0
Points
1
Location
USA
Vehicle Year
1997
Make / Model
Ford Ranger
Transmission
Automatic
I have 97 ranger that starts fine but will not stay running until engine is warmed up. It’s worse on cold mornings but it will warm up and run fine. It’s throwing codes P0171 and P0174 again. I had the intake manifold gaskets replaced and the IACV replaced and no codes for about a year. Any suggestions? It didn’t start the stalling until after the work was completed. The codes are more recent.
 


Rock Auto 5% Discount Code: F9A1A579ACFAD1: October 1st, 2021

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
20,205
Reaction score
3,985
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Welcome to TRS :)

You will need to replace the ECT(engine coolant temp) sensor, its reporting warm engine when its actually cold, so you are not getting a Choke mode, rich mix and high idle
Your description is kind of a classic sign of a failed ECT sensor

On a 1997 4.0l OHV engine
Look on lower intake behind thermostat housing you will see TWO temp units screwed into the lower intake

ECT sensor will have two wires, one is a grey/red wire, this is a 5volt sensor, and only used by the computer

The other temp unit is 12volt and used by dash temp gauge, usually has one wire, red/white


You will need to drain some coolant out before removing the ECT sensor
 

VTChavez

New Member
U.S. Military - Veteran
Joined
Jul 28, 2021
Messages
5
Reaction score
0
Points
1
Location
USA
Vehicle Year
1997
Make / Model
Ford Ranger
Transmission
Automatic
Thank you RonD for your quick response. I will check this out in a couple of days. This is a big help. Thanks again.
 

VTChavez

New Member
U.S. Military - Veteran
Joined
Jul 28, 2021
Messages
5
Reaction score
0
Points
1
Location
USA
Vehicle Year
1997
Make / Model
Ford Ranger
Transmission
Automatic
Finally got around to replacing the ECT sensor. Same problem. Any other ideas anyone?
 


Top