• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

terrible fuel economy and no power

maxwell.hunt

New Member
Joined
Jan 3, 2011
Messages
37
Reaction score
0
Points
0
Vehicle Year
1992
Make / Model
ford
Transmission
Automatic
hey i have a 1992 ranger 2wd 4L and yesterday i whent though a quarter tank driving 47 km's. when i start it in the morning it always tries to stall and the only way to keep it running is to hold it at 2k rpm. the gas peddle seems to be alot stiffer lately aswell. when im at a stop sign the truck jumps like crazy and tries to stall, it usually gets better when it warms up, still no power though. im at abuot 3k rpm to hold my speed up a hill. its got a new fuel filter, fuel pump/sending unit, new alternator and starter, new pcv, cats are good, muffler is brand new, brand new spark plugs and wires (speaking of which my plugs were fouled like crazy before i changed them) and a brand new fuel pressure regulator. i dont have a clue what the problem could be, thanks for the input
 


BlackBII

Ranger Custom
Article Contributor
OTOTM Winner
TRS Banner 2010-2011
Joined
Aug 14, 2007
Messages
7,874
Reaction score
839
Points
113
Location
UT
Vehicle Year
1989
Make / Model
Ford
Engine Type
4.0 V6
Transmission
Manual
2WD / 4WD
4WD
Total Lift
5
Tire Size
33
Have you pulled the codes?

Tested the TPS?

Cleaned the MAF?

Checked compression?
 

maxwell.hunt

New Member
Joined
Jan 3, 2011
Messages
37
Reaction score
0
Points
0
Vehicle Year
1992
Make / Model
ford
Transmission
Automatic
haven't checked compression tire pressure is good maf is clean, and the scanner wouldnt hook up it said there was no power oing to it :s
 

ronclark

Member
Supporting Member
Ham Radio Operator
GMRS Radio License
Joined
Oct 22, 2008
Messages
915
Reaction score
19
Points
18
Location
Woodland, WA
Vehicle Year
1987
Make / Model
Ford
Engine Type
4.0 V6
Engine Size
95 4.0 with 93 ECU
Transmission
Manual
2WD / 4WD
4WD
Total Lift
2
Tire Size
30
haven't checked compression tire pressure is good maf is clean, and the scanner wouldnt hook up it said there was no power oing to it :s
check your lighter fuse, it also powers the OBD2 Port
 

DasBaldDog

New Member
Joined
Dec 10, 2010
Messages
36
Reaction score
0
Points
0
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
92 wouldn't have OBD2, I don't think. My 94 doesn't.
 

maxwell.hunt

New Member
Joined
Jan 3, 2011
Messages
37
Reaction score
0
Points
0
Vehicle Year
1992
Make / Model
ford
Transmission
Automatic
lighter works theres a red wire with a squarish end that is hanging near my distribution block. would that be it?
 

alliantdevil

New Member
Joined
Feb 11, 2011
Messages
2
Reaction score
0
Points
0
Vehicle Year
1999
Make / Model
ford
Transmission
Automatic
i know you mentioned getting a new fuel filter/pump/sending unit (as i had as well) but i had a very, very similar issue and it was resolved by cleaning the intake / fuel injectors (which should really be done when replacing the fuel filter). i had done several other things in an attempt to resolve this issue with no success, then it donned on me one day i hadn't cleaned the intake/injectors in about 6 years! when i exposed the throttle body there was so much carbon caked up around/on the butterfly that as i soon as i cleaned it (take the TB off for this, please do not just clean it on engine and run all that crap back down the rest of the air intake) the gas pedal freed up and wasn't stiff and the power was restored by the injector cleaning.

before i had done any of this an on ramp to the freeway seemed like i was trying to drive up mount Everest and the air would dump out through the defrost vents (as it's supposed to when the engine is under extreme load, from what i gather).

A bit basic but sometimes overlooked, it's worth a try if you haven't done it in a while anyway.

--good luck
 

maxwell.hunt

New Member
Joined
Jan 3, 2011
Messages
37
Reaction score
0
Points
0
Vehicle Year
1992
Make / Model
ford
Transmission
Automatic
ill try it i have cleaned it but never with hte tb off. did that give you the terrible fuel economy aswell?
 

06RangerXLT

New Member
Joined
Jul 24, 2010
Messages
2,876
Reaction score
54
Points
0
Location
Georgetown Ontario
Vehicle Year
2006
Make / Model
Ford
Engine Size
4.0L
Transmission
Automatic
sounds like a clogged air filter or plugged cats
 

maxwell.hunt

New Member
Joined
Jan 3, 2011
Messages
37
Reaction score
0
Points
0
Vehicle Year
1992
Make / Model
ford
Transmission
Automatic
cats are mint. and the air filter is a brand new k&n filter
 

Sponsored Ad


Sponsored Ad

Top