• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Starting Issues 2.9l 4x4 1986 Ranger (auto)

rusty ol ranger

Im a Jeep guy now.
Supporting Member
Joined
Sep 22, 2007
Messages
9,853
Reaction score
4,822
Points
113
Location
Michigan
Vehicle Year
1987
Make / Model
Ford
Engine Type
2.9 V6
Engine Size
177 CID
Transmission
Manual
2WD / 4WD
2WD
My credo
A legend to the old man, a hero to the child...
Whens the last time you put plugs in it? If the coolant sensor was bad it was probably running pig rich and coulda fouled a few plugs.
 


paulschmitz82

New Member
Joined
Sep 2, 2022
Messages
12
Reaction score
0
Points
1
Location
Germany
Vehicle Year
1986
Make / Model
Ford Ranger
Transmission
Automatic
yes it ran rich, but replaced the plugs some weeks ago so they‘re brand new
 

rusty ol ranger

Im a Jeep guy now.
Supporting Member
Joined
Sep 22, 2007
Messages
9,853
Reaction score
4,822
Points
113
Location
Michigan
Vehicle Year
1987
Make / Model
Ford
Engine Type
2.9 V6
Engine Size
177 CID
Transmission
Manual
2WD / 4WD
2WD
My credo
A legend to the old man, a hero to the child...
yes it ran rich, but replaced the plugs some weeks ago so they‘re brand new
Hmm....could be plug wires, dist cap, or worst case compression. You may even have injectors sticking closed on those cylinders.
 

paulschmitz82

New Member
Joined
Sep 2, 2022
Messages
12
Reaction score
0
Points
1
Location
Germany
Vehicle Year
1986
Make / Model
Ford Ranger
Transmission
Automatic
compression is fine, everything on the engine itself is brandnew it just got rebuilt.
Injectors are also new, dist cap and plug wires aswell.
 

2011Supercab

Active Member
Joined
Dec 10, 2021
Messages
141
Reaction score
135
Points
43
Location
Washington
Vehicle Year
2011
Make / Model
Ford Ranger
Engine Type
4.0 V6
Transmission
Automatic
2WD / 4WD
4WD
compression is fine, everything on the engine itself is brandnew it just got rebuilt.
Just because it's "rebuilt" doesn't mean the compression is fine, Have you verified it?
 

paulschmitz82

New Member
Joined
Sep 2, 2022
Messages
12
Reaction score
0
Points
1
Location
Germany
Vehicle Year
1986
Make / Model
Ford Ranger
Transmission
Automatic
yes i did, i measured the compression and it‘s totally perfect
 

rusty ol ranger

Im a Jeep guy now.
Supporting Member
Joined
Sep 22, 2007
Messages
9,853
Reaction score
4,822
Points
113
Location
Michigan
Vehicle Year
1987
Make / Model
Ford
Engine Type
2.9 V6
Engine Size
177 CID
Transmission
Manual
2WD / 4WD
2WD
My credo
A legend to the old man, a hero to the child...
Try to verify which cylinders are misfireing, pull each plug wire indvidually while it idles untill you dont notice a difference in engine tone/roughness.

Being its batch fire you may have a wireing or ECM issue if all the parts are new.

Curious....what were the PSI numbers on compression?
 

Sponsored Ad


Sponsored Ad

Top