• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Rough running

saskboy

New Member
Joined
Jan 15, 2020
Messages
10
Reaction score
0
Points
1
Location
alberta
Vehicle Year
1997
Make / Model
ford ranger
Hey Ramcharger 90, I saw u had a setup similar to mine. I have 89 mustang engine all stock sensors, intake, Maf and TB and injectors. I swapped to Edel performer rpm heads and Trick Flow stage one cam. Idle is very rough, smoother at 2500 rpm but still not good, fuel pressure 39 psi koeo. What area should I look at, check engine lite is on but egr is not connected
 


Junglejoe

Active Member
Joined
Mar 9, 2016
Messages
492
Reaction score
66
Points
28
Location
Columbia Missouri
Vehicle Year
2006
Make / Model
Ford
Engine Size
6.0
Transmission
Automatic
I assume you checked for vacume leaks? The computer is going to need tuned for that combo
 

saskboy

New Member
Joined
Jan 15, 2020
Messages
10
Reaction score
0
Points
1
Location
alberta
Vehicle Year
1997
Make / Model
ford ranger
I can't detect any vac leaks, I checked compression again, all 130 on my gauge, fuel press KOEO 39, KOER 31. I ran engine for a few mins then shut off, started shortly after, won't start, just cranks, checked spark is ok, checked one plug, is wet with gas, tripped inertia switch then cranked until it ran then stalled as it ran out of gas. Reset inertia switch and tried again, same result. Seems as engine warms up PCM is adding excess fuel until it stalls. Could be a ect sensor problem?
 

Junglejoe

Active Member
Joined
Mar 9, 2016
Messages
492
Reaction score
66
Points
28
Location
Columbia Missouri
Vehicle Year
2006
Make / Model
Ford
Engine Size
6.0
Transmission
Automatic
What injectors do you have? With those heads and cam.. youll need a tune for sure.
 

Sponsored Ad


Sponsored Ad

Top