2.3L ('83-'97) Rough Idle when cold. Runs great when warm.


TurdFerguson728

New member
Joined
Mar 22, 2020
Messages
2
Reaction score
0
Points
1
Location
California
Vehicle Year
1997
Make / Model
Ranger
Transmission
Manual
Recently my 97 started misbehaving. Since Ive had it (4 years now) its always had a bit of a rough idle when it was cold, especially after not being driven for a while. Now the idle is super low RPMs until it starts to warm up, and then it smooths out and runs great.
A month ago it wouldnt even start, so I replaced all the wires and plugs, fuel and air filters and the fuel pump and filler hose. Now it starts but the cold idle issue remains. What should I check next?
 


Rock Auto 5% Discount Code: 32B05A80BF19AF Expires: July 1st, 2020

Dirtman

Clam chowdah!
EMT / Paramedic
Joined
May 28, 2018
Messages
7,862
Reaction score
4,643
Points
113
Location
Over there --->
Vehicle Year
2009
Make / Model
Ford
Engine Type
2.3 (4 Cylinder)
Engine Size
466.63 teaspoons.
Transmission
Automatic
2WD / 4WD
2WD
Tire Size
So friggin big!
My credo
Give me money.
ECT sensor would be where I would start.
 

sheep herder

Well-known member
U.S. Military - Veteran
Joined
Nov 7, 2019
Messages
383
Reaction score
284
Points
63
Location
sheep pen
Vehicle Year
2011
Make / Model
Ford Ranger
Engine Type
4.0 V6
Transmission
Automatic
2WD / 4WD
2WD
If it's misbehaving, it's probably learned bad habits from you.






















:icon_cheers:I know who you are from a different forum.
 


Top