• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

2.3L ('83-'97) Rough idle/engine shake/stalling


MDeBo

New Member
Joined
Jan 22, 2020
Messages
8
Reaction score
0
Points
1
Location
Newnan Georgia
I had even went as far as checking the voltage's at my inlet temp sensor and MAF when running rough and smooth and it all checked out. Makes no sense as to what the hell is wrong.
 


Rock Auto 5% Discount Code: 7FA902352B4C01: April 5th, 2021

martinglen

New Member
Joined
Apr 28, 2020
Messages
13
Reaction score
0
Points
1
Location
Arkansas
Vehicle Year
1997
Make / Model
Ford Ranger
Transmission
Manual
I had even went as far as checking the voltage's at my inlet temp sensor and MAF when running rough and smooth and it all checked out. Makes no sense as to what the hell is wrong.
I know. It's driving me crazy. I just checked the vacuum with a gauge and it is steady at 22 which is normal. I thought maybe a clogged cat. but the vacuum was steady during acceleration all in normal range. I'm going to get the temp. before and after the cat with an infrared thermometer and see if there's a difference. I know that would be an expensive fix but at this point it would be worth it to get this headache over with.
 

MDeBo

New Member
Joined
Jan 22, 2020
Messages
8
Reaction score
0
Points
1
Location
Newnan Georgia
Hate to say it because it's been such a good truck, but I'm to the point where it's not really worth spending any more money on this problem, not with 373,000+ miles on her. Unless you or anyone else finds an easy fix. And I think we've exhausted the easy fix options.
 


Top