• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

2.3L ('02-'11) Potential plugged heater core


Blmpkn

Well-Known Member
Joined
Feb 15, 2020
Messages
771
Reaction score
336
Points
63
Location
Southern maine
Vehicle Year
2010
Make / Model
Ford ranger
Engine Type
2.3 (4 Cylinder)
Engine Size
2.3
Transmission
Manual
2WD / 4WD
2WD
Tire Size
235/75/15
Couple weeks ago during the first real cold morning of the year I noticed that my heat doesn't work. Brrr.

Read some stuff from another forum posted by ranger Jesus RonD that helped me partially diagnose why. It's NOT the vacuum valve under the hood, its either the blend door actuator or a plugged core.

NOW, I dont currently know where my mirror on a stick is.. so it's hard for me to see if the blend door actuator is functioning.. BUT both hoses coming through the firewall seem to be roughly the same temperature AND the coolant is about as clean as one could expect.

This leads me to believe its the actuator, but the much higher price tag to have the core replaced coupled with how good my luck is has me preparing for worse case ontario.

Would a vehicle with a plugged core have clean coolant? I would think that it would be gross. I'm gonna hit both hoses through the firewall with my infrared thermometer tomorrow to see exactly what the temperature difference is.

Thoughts? Is a crummy blend door actuator common on rangers? How bout a plugged core? Thanks gang.
 


Rock Auto 5% Discount Code: 7FA902352B4C01: April 5th, 2021

Dirtman

President of The United States
Supporting Member
Joined
May 28, 2018
Messages
14,224
Reaction score
8,293
Points
113
Location
41N 75W
Vehicle Year
2009
Engine Type
2.3 (4 Cylinder)
Transmission
Automatic
2WD / 4WD
2WD
Total Lift
It's up there.
Total Drop
It's down there.
Tire Size
Round.
Bad blend door motors are very common on your era ranger. It's not overly complicated to remove, there's 3 - 7 or 8mm bolts. It's behind the glove box, and very cramped but can be removed without doing anything more than just popping the glove box out. Unbolt it, wiggle it out enough to see it while keeping it plugged in and then turn the temp knob and see if it moves.

Plugged heater core would be way less common than a bad blend door motor.
 

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
17,637
Reaction score
2,619
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
+1 ^^^

Yes, I agree, Blend Door is far more likely problem when there is no heat control in the cab

If you start engine cold, one heater hose at the firewall should start to warm up right away, thats the IN to core
The other one should also then start to heat up, thats the OUT back to water pump
If that happens then core is most likely just fine
You should reverse these 2 hoses at the firewall every 2 years or so, you lose almost no coolant doing this
This will "back flush" the core, while driving, helping it last longer
 

scotts90ranger

Well-Known Member
RBV's on Boost
Joined
Feb 28, 2001
Messages
4,857
Reaction score
445
Points
83
Location
Dayton Oregon
Vehicle Year
1990, 1997
Make / Model
Ford
Engine Type
2.3 (4 Cylinder)
Engine Size
2.3 Turbo
Transmission
Manual
2WD / 4WD
4WD
Total Lift
6
Tire Size
35"
I'm with them, but throwing other things in... my wife's '98 Explorer (same dash I'm pretty sure) the blend door is stuck which is extra annoying with the climate control in the V8 Explorers, I so wish they just had a hot cold slider instead of a temperature goal to meet...

With that said, my '97 Ranger is just stupid, manual trans 2.3L so has the smallest radiator, anything under 50F and the heater is enough to get the window defrosted and take the chill off but the coolant temperature is low and heater output doesn't seem hot, over 50F and it gets toasty in there and the engine temp gets all the way to 180F (192F new Motorcraft thermostat). Sometime in the next week I'm going to block off half the radiator... I tried my spare fan clutch which is probably also bad so I'll go electric at some point but I don't have time for that right now...
 

Dirtman

President of The United States
Supporting Member
Joined
May 28, 2018
Messages
14,224
Reaction score
8,293
Points
113
Location
41N 75W
Vehicle Year
2009
Engine Type
2.3 (4 Cylinder)
Transmission
Automatic
2WD / 4WD
2WD
Total Lift
It's up there.
Total Drop
It's down there.
Tire Size
Round.
Limas have ALOT of iron for a little motor, they practically don't even need radiators. :ROFLMAO:
 

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
17,637
Reaction score
2,619
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Yes, +1 ^^^^

People up North with the 2.3l Limas often put cardboard in front of radiator in the winter months to keep operating temp high enough for good heat in cab and good engine operation
There are also 205deg thermostats made for these engines

Diesel trucks do the same, the snap-on or zippered covers over the front grills used in cold weather to keep engine warmer for best power and MPG
 


Top