• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

OK here we go again!


groovtubin

Member
U.S. Military - Veteran
Joined
Jun 9, 2020
Messages
35
Reaction score
14
Points
8
Location
NC
Vehicle Year
86
Make / Model
Ford Bronco II
Engine Type
2.9 V6
Transmission
Automatic
2WD / 4WD
4WD
Went out to crank the Bronco II Key over, FUEL PUMP PRIME ...NO start...... Its cold, i dont have a garage, soon as it warms up, il TS the Ignition again, this XACT same thing happened over late summer, n i repaired a broke coil wire to Ignition module, what will it be this time? :) In last post i was ALMOST home it sputtered n went into limp mode..
 


Rock Auto 5% Discount Code: 70D65189E6D8FF: January 5th, 2022

groovtubin

Member
U.S. Military - Veteran
Joined
Jun 9, 2020
Messages
35
Reaction score
14
Points
8
Location
NC
Vehicle Year
86
Make / Model
Ford Bronco II
Engine Type
2.9 V6
Transmission
Automatic
2WD / 4WD
4WD
Went out to crank the Bronco II Key over, FUEL PUMP PRIME ...NO start...... Its cold, i dont have a garage, soon as it warms up, il TS the Ignition again, this XACT same thing happened over late summer, n i repaired a broke coil wire to Ignition module, what will it be this time? :) In last post i was ALMOST home it sputtered n went into limp mode..
OK Braved the harsh elements of nature, pulled off the IGN Module connector, SLAMMED that puppy home, Key over FUEL PUMP PRIME WE HAVE IGNITION! :)
 

groovtubin

Member
U.S. Military - Veteran
Joined
Jun 9, 2020
Messages
35
Reaction score
14
Points
8
Location
NC
Vehicle Year
86
Make / Model
Ford Bronco II
Engine Type
2.9 V6
Transmission
Automatic
2WD / 4WD
4WD
OK, NO time to get into it heavy today ( no im not on a date) All i had time today to do was pull back carpet slightly and the WHITE BUTTON on INERTIA switch actually CLICKED when i pushed down, i hvnt checked for 12 volts at fuel relay, B4 this either.... Ive got RUN n COIL voltage at TPI connector, didnt get to CRANK voltage Also the OHMS is GOOD on COIL, i PULLED the secondary wire tab... used a test light, it LIT up cranking....., but couldnt tell if it was FLASHING...( pulled secondary tab OFF the coil n read that directly, maybe wrong?) anyhoo, ill try n crank tomorrow, gotta fuel press gauge for troubleshooting on way, did i say how MUCH i miss driving the Bronco II ?? Its my main ride man! :)
 

groovtubin

Member
U.S. Military - Veteran
Joined
Jun 9, 2020
Messages
35
Reaction score
14
Points
8
Location
NC
Vehicle Year
86
Make / Model
Ford Bronco II
Engine Type
2.9 V6
Transmission
Automatic
2WD / 4WD
4WD
Installed SPARE TFI Module ( it wil miss @ 2500 RPM) but does ....................START............ Going to FordMOCO n get the REAL thing, Car parts n Advanced Zone are worthless...for TPI's imho.......................YMMV.............
 


Top