• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

No tailights/brakelights after body lift, help!

Danno1985

Member
Joined
Nov 20, 2018
Messages
83
Reaction score
20
Points
8
Location
MKE, WI
Vehicle Year
2011
Make / Model
Ford
Engine Type
2.3 (4 Cylinder)
Transmission
Manual
2WD / 4WD
2WD
Total Lift
stock
Total Drop
stock
Tire Size
stock
Hey all, looking for some quick help here. I recently had a 3" performance accessories body lift installed on my 2010 XLT. Didn't realize until I got home that I now have no brake lights, no taillights, no reverse, no rear blinkers - even the 3rd brake light on the cab doesn't work. Front blinkers work but they're much faster than they should be. If I have to take it back down to the shop I will, but if it's something quick i can fix here I'd rather avoid risking a tailgater hitting me or getting pulled over. What should I be looking at here?
 


adsm08

Senior Master Grease Monkey
Supporting Member
Article Contributor
Ford Technician
TRS 20th Anniversary
Joined
Sep 20, 2009
Messages
34,625
Reaction score
3,583
Points
113
Location
Dillsburg PA
Vehicle Year
1987
Make / Model
Ford
Engine Type
4.0 V6
Engine Size
4.0
Transmission
Manual
2WD / 4WD
4WD
Tire Size
31X10.50X15
Well, are you missing power, or ground?
 

Danno1985

Member
Joined
Nov 20, 2018
Messages
83
Reaction score
20
Points
8
Location
MKE, WI
Vehicle Year
2011
Make / Model
Ford
Engine Type
2.3 (4 Cylinder)
Transmission
Manual
2WD / 4WD
2WD
Total Lift
stock
Total Drop
stock
Tire Size
stock
Well, are you missing power, or ground?
Man, I'm not sure, I'm stuck at work and haven't gotten that far yet. Wiring stuff is admittedly voodoo to me. The fact that i have no 3rd brake light on the cab makes me inclined to think this has to do with the multifunction switch or something else in the cab not being reassembled correctly. But again, I'm pretty new to Rangers and electrical isn't really something I feel confident in, so I'm not really sure what I should be looking for.
 

Ranger850

Banned... except Florida... and here soon
Supporting Member
TRS 20th Anniversary
Joined
Jan 24, 2018
Messages
7,816
Reaction score
4,122
Points
113
Location
Tallahassee Florida
Vehicle Year
2001
Make / Model
Ford
Engine Size
Born with a 3.0, looking for a donor V8
Transmission
Manual
2WD / 4WD
2WD
Total Lift
Stock 2"
Tire Size
Stock
My credo
Doing things wrong, until I get it right.
Pinched or broken wires; blown fuse; blown bulbs; loose connections; that's what I would start with, then take it back to them if you can't figure it out
 

adsm08

Senior Master Grease Monkey
Supporting Member
Article Contributor
Ford Technician
TRS 20th Anniversary
Joined
Sep 20, 2009
Messages
34,625
Reaction score
3,583
Points
113
Location
Dillsburg PA
Vehicle Year
1987
Make / Model
Ford
Engine Type
4.0 V6
Engine Size
4.0
Transmission
Manual
2WD / 4WD
4WD
Tire Size
31X10.50X15
Man, I'm not sure, I'm stuck at work and haven't gotten that far yet. Wiring stuff is admittedly voodoo to me. The fact that i have no 3rd brake light on the cab makes me inclined to think this has to do with the multifunction switch or something else in the cab not being reassembled correctly. But again, I'm pretty new to Rangers and electrical isn't really something I feel confident in, so I'm not really sure what I should be looking for.
Something happened to take out all those different lights at once. Most of them share a fuse, most of them share a ground.

I realize you aren't sure what you should be looking for, and I am telling you that you need to start by looking at power and ground, at the bulb socket, for all the lights that don't work.

Wiring isn't voodoo, it is plumbing.
 

Uncle Gump

Forum Staff Member
Forum Moderator
Supporting Member
TRS Event Participant
Joined
Sep 17, 2018
Messages
11,155
Reaction score
9,053
Points
113
Location
Ottawa IL
Vehicle Year
2006/1986
Make / Model
Ranger/BroncoII
Engine Size
4.0L SOHC/2.9L
2WD / 4WD
4WD
My credo
Lead, Follow or get out of my way
Sounds to me like the rear lamp harness come unplugged... or was unplugged and not reconnected. But ummm... I'm no genius
 

Danno1985

Member
Joined
Nov 20, 2018
Messages
83
Reaction score
20
Points
8
Location
MKE, WI
Vehicle Year
2011
Make / Model
Ford
Engine Type
2.3 (4 Cylinder)
Transmission
Manual
2WD / 4WD
2WD
Total Lift
stock
Total Drop
stock
Tire Size
stock
Sounds to me like the rear lamp harness come unplugged... or was unplugged and not reconnected. But ummm... I'm no genius
D'oh, turns out that's exactly what it was. Problem solved. I read a bunch of posts about people having problems with the multifunction switch in the steering column and sort of assumed it had something to do with that, but I'm glad I didn't have to dig too far.

Shameless lift pic included for good measure.
 

Attachments

Uncle Gump

Forum Staff Member
Forum Moderator
Supporting Member
TRS Event Participant
Joined
Sep 17, 2018
Messages
11,155
Reaction score
9,053
Points
113
Location
Ottawa IL
Vehicle Year
2006/1986
Make / Model
Ranger/BroncoII
Engine Size
4.0L SOHC/2.9L
2WD / 4WD
4WD
My credo
Lead, Follow or get out of my way
Sweet truck man...

Maybe I am... genius???

Always look for the simple stuff first... bad grounds and poor connections... or in your case... no connection after a repair will fix most issues you didn't have before the repair.
 

Ranger850

Banned... except Florida... and here soon
Supporting Member
TRS 20th Anniversary
Joined
Jan 24, 2018
Messages
7,816
Reaction score
4,122
Points
113
Location
Tallahassee Florida
Vehicle Year
2001
Make / Model
Ford
Engine Size
Born with a 3.0, looking for a donor V8
Transmission
Manual
2WD / 4WD
2WD
Total Lift
Stock 2"
Tire Size
Stock
My credo
Doing things wrong, until I get it right.
Sweet truck man...

Maybe I am... genius???

Always look for the simple stuff first... bad grounds and poor connections... or in your case... no connection after a repair will fix most issues you didn't have before the repair.
Or maybe I'm a genius and you read my post. That is exactly what I said to do.
 

Uncle Gump

Forum Staff Member
Forum Moderator
Supporting Member
TRS Event Participant
Joined
Sep 17, 2018
Messages
11,155
Reaction score
9,053
Points
113
Location
Ottawa IL
Vehicle Year
2006/1986
Make / Model
Ranger/BroncoII
Engine Size
4.0L SOHC/2.9L
2WD / 4WD
4WD
My credo
Lead, Follow or get out of my way
Or maybe I'm a genius and you read my post. That is exactly what I said to do.
You're probably right... not sure how I ever made it through 35 years of being a master technician before reading a single post of yours.
 

Ranger850

Banned... except Florida... and here soon
Supporting Member
TRS 20th Anniversary
Joined
Jan 24, 2018
Messages
7,816
Reaction score
4,122
Points
113
Location
Tallahassee Florida
Vehicle Year
2001
Make / Model
Ford
Engine Size
Born with a 3.0, looking for a donor V8
Transmission
Manual
2WD / 4WD
2WD
Total Lift
Stock 2"
Tire Size
Stock
My credo
Doing things wrong, until I get it right.
You're probably right... not sure how I ever made it through 35 years of being a master technician before reading a single post of yours.
Me either?:icon_rofl: but I did say the same damn thing, but hey you're the genius so he probably took your advice and not mine.
 

Uncle Gump

Forum Staff Member
Forum Moderator
Supporting Member
TRS Event Participant
Joined
Sep 17, 2018
Messages
11,155
Reaction score
9,053
Points
113
Location
Ottawa IL
Vehicle Year
2006/1986
Make / Model
Ranger/BroncoII
Engine Size
4.0L SOHC/2.9L
2WD / 4WD
4WD
My credo
Lead, Follow or get out of my way
sigh...

To be a good forum member... I will once again bow out of a thread because of you.


To the OP... glad you got your truck back working properly.
 

Sponsored Ad


Sponsored Ad

Top