• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Mazda B4000 Vibration


Jeff Simmons

New Member
Joined
Oct 13, 2013
Messages
4
Reaction score
0
Points
0
Vehicle Year
1994
Make / Model
Mazda
Transmission
Automatic
Help needed please, I replaced U-Joints, Carrier Bearing, marked the driveshaft so I put it back together correctly and now I have a terrible vibration. At low speeds (15-35 mph) it feels like the rear end is hopping. At 45+ mph the entire truck goes into what feels like space shuttle re-entry. Jacked the truck up and ran it to 45 mph, noticed the rear hubs appear to be elliptical in shape. Very little play in rear axle bearing, up and down, in and out both. Any suggestions?
 


Rock Auto 5% Discount Code: 70D65189E6D8FF: January 5th, 2022

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
20,402
Reaction score
4,087
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Any history on the truck?
i.e. did you just get it and found this problem or have you had it for awhile and this just started

Have you had someone watch while you drive away to see if the 4 wheels are tracking the same or "crabbing" so out of 4 wheel alignment.

Hit any Curbs lately, :), bent rim

Did you look over the drive line for clean spots where balance weights might have come off, same with rear wheels/tires, and signs of missing weights?

What size wheels and tires are on it?

And no steering wheel vibration, so not a front end vibration?

Is it a 2WD or 4WD?
 
Last edited:

Jeff Simmons

New Member
Joined
Oct 13, 2013
Messages
4
Reaction score
0
Points
0
Vehicle Year
1994
Make / Model
Mazda
Transmission
Automatic
Yes, new tires and wheels [stock sizes] . Nothing missing on driveshaft as far as weights go. The truck didn't have the vibration prior to replacing joints and carrier . I did put the small end of the 2 piece driveshaft in a vice to tighten the yoke nut ? Don't think I damaged anything though. Didn't hit any curbs. Tires balanced out fine , a couple required a little more weight than normal . I have not torn into the rear end yet other than replacing fluids . The truck sat for a couple years prior to me purchasing it .[bought it for my son , first truck ] Thanks
 

Jeff Simmons

New Member
Joined
Oct 13, 2013
Messages
4
Reaction score
0
Points
0
Vehicle Year
1994
Make / Model
Mazda
Transmission
Automatic
Forgot to mention it is 4 wheel drive !
 

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
20,402
Reaction score
4,087
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
well........if it didn't vibrate with old carrier and u-joints then.............problem would be with one of the new u-joints, maybe carrier.

If you jack up the back again, put tranny in neutral and rotate the driveline slowly you may be able to hear a bad u-joint, or feel a binding at certain points

Could be a new u-joint was bad out of the box, "new" no longer means "it works", with price competition "new" now means "never tested" and manufacturer just warranties any bad ones.
So user/installer is now the Quality Control Department for most parts manufacturers

In other words we, the DIYers, are our own worst enemy, we demand less expensive parts by our buying habits, so we get untested cheaper parts :)
 
Last edited:

Jeff Simmons

New Member
Joined
Oct 13, 2013
Messages
4
Reaction score
0
Points
0
Vehicle Year
1994
Make / Model
Mazda
Transmission
Automatic
Thanks for the help Ron! I will give it a try and let you know how it turns out!
 

Andy D

Active Member
Joined
Jul 9, 2011
Messages
1,940
Reaction score
8
Points
38
Location
Marshfield MA
Vehicle Year
94
Make / Model
The Rat
Engine Size
4.0 OHV
Transmission
Manual
My credo
to prevent Found On the Road Dead, Fix Or Repair Daily
well........if it didn't vibrate with old carrier and u-joints then.............problem would be with one of the new u-joints, maybe carrier.

If you jack up the back again, put tranny in neutral and rotate the driveline slowly you may be able to hear a bad u-joint, or feel a binding at certain points

Could be a new u-joint was bad out of the box, "new" no longer means "it works", with price competition "new" now means "never tested" and manufacturer just warranties any bad ones.
So user/installer is now the Quality Control Department for most parts manufacturers

In other words we, the DIYers, are our own worst enemy, we demand less expensive parts by our buying habits, so we get untested cheaper parts :)
Parts cars are where most of the parts for my old BMWs come from. With junk parts you know that they worked at one time. :D No parts Ranger yet. I get parts for the Rat from the Auto Zone down town. The only new part failure so far has been the rear U_Joint. I'm pretty sure it was a bad job by me, not a bad part.

I dont like buying Chinese stuff, but the price and availability from AZ is excellent for Ranger parts. The Rat isn't a daily driver, so I'm not too worried. I did order a LUK rep set for the clutch. But the rear main seal , flywheel, master, slave and line were from AZ .

The brake parts have been very reasonable , I have replaced almost all of the entire brake system with stuff from AZ. from the heat coming from the RR drum, more parts are prolly needed. I've been lucky so far, the Rat hasnt needed electrical parts :D
 
Last edited:

Majagit

New Member
Joined
Dec 2, 2013
Messages
10
Reaction score
0
Points
0
Transmission
Automatic
It shakes more when there is a load in the bed. Did not rotate tires yet... Rear of truck shakes. Steering wheel does not shake at all...
 


Top