• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

loss of power till 3,000 RPM????


Rangermilitia

New Member
Joined
Nov 12, 2008
Messages
60
Reaction score
0
Points
0
Location
San Ramon, Ca
Vehicle Year
1987, for the m
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
Very weird, i have a loss of power utill 3,000 rpm. any ideas? 2.9L ranger with 4X4
 


Rock Auto 5% Discount Code: 81874766E40C6A 5th, 2022

Cyberbeer

New Member
Joined
Jan 30, 2009
Messages
264
Reaction score
1
Points
0
Location
Spotsylvania, VA
Vehicle Year
1987
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
Whens the last time you did a tune up? Any weird smoke coming out the tail pipe after its warmed up? I'd start simple and check the air filter first, and clean out the intake hoses.
 

4x4fun

Active Member
U.S. Military - Veteran
Joined
Sep 20, 2008
Messages
1,433
Reaction score
9
Points
38
Location
delwhere
Vehicle Year
2011
Make / Model
really?
Engine Size
4.0L
Transmission
Automatic
if i recall they 3000 is the bottom of the curve so it doesn't start making any real power till then.
 

tanbuddy

New Member
Joined
Aug 16, 2007
Messages
446
Reaction score
1
Points
0
Age
40
Location
Poconos, Pa
Vehicle Year
1989
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
peak torque is at 2600 rpm so it should have power lower than 3000 rpm. Is it misssing real bad or just weak?
 

Rangermilitia

New Member
Joined
Nov 12, 2008
Messages
60
Reaction score
0
Points
0
Location
San Ramon, Ca
Vehicle Year
1987, for the m
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
lagging...

ok so it lags really bad untill 3,000 rpm then the power seems like it doubles. its really sluggish and feels like its missfirig, or lurching.. also a few times the motor willl cut in and out, and i noticed that even though i'm going 40mph and the clutch is still engaged, the rpm needle drops to zero. the other day it died while driving and wouldnt start for about 10 min. this truck will be the death of me..
 

Rangermilitia

New Member
Joined
Nov 12, 2008
Messages
60
Reaction score
0
Points
0
Location
San Ramon, Ca
Vehicle Year
1987, for the m
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
starting..

also when i start it up, it missfires for the first minute untill i get moving, usually round 3-5 mph it smooths up
 

LittleHorse

New Member
Joined
Jan 22, 2009
Messages
964
Reaction score
1
Points
0
Location
Pryor, OK
Vehicle Year
1990
Make / Model
Ford
Engine Size
2.9L
Transmission
Automatic
I'd start with a tune-up - plugs/wires, cap/rotor.

If your tach is dropping to zero it's probably not getting the signal pulse from the distributor to tell it the engine speed. I haven't delved into these 2.9L's to know whether the tach signal goes through the computer first or not, but there's a chance that if your tach is getting an intermittent signal, then your ignition coil may be getting an intermittent signal also.
 

BlackBII

Ranger Custom
Article Contributor
OTOTM Winner
TRS Banner 2010-2011
Joined
Aug 14, 2007
Messages
7,809
Reaction score
702
Points
113
Location
UT
Vehicle Year
1989
Make / Model
Ford
Engine Type
4.0 V6
Transmission
Manual
2WD / 4WD
4WD
Total Lift
5
Tire Size
33
Check your fuel pressure, may be on the high side, running rich.

Bad mileage or black smoke from tailpipe?
 

The Fox

New Member
Joined
Oct 31, 2008
Messages
139
Reaction score
1
Points
0
Vehicle Year
1988
Make / Model
Ford
Engine Size
2.9L
Transmission
Manual
Check the TFI on the side of the dizzy, it could be loose, so it is going to cut in and out.
Nick
 

Rangermilitia

New Member
Joined
Nov 12, 2008
Messages
60
Reaction score
0
Points
0
Location
San Ramon, Ca
Vehicle Year
1987, for the m
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
done it

i've done the tune up stuff.. tps and put a new distributor and tfi module. but i think the kragen distributor is junk, haha they actually ended up giving me money for taking their dist, after core and stuff. anywho.. i'll check the fuel pressure. any ideas on maybe the egr valve is robbing power or something?
 

IMenriched

New Member
Joined
Aug 7, 2007
Messages
1,507
Reaction score
4
Points
0
Age
58
Location
NE Iowa John Deere country
Vehicle Year
1986
02'
Make / Model
ford
Engine Size
2.9 & 5.4
Transmission
Automatic
i've done the tune up stuff.. tps and put a new distributor and tfi module. but i think the kragen distributor is junk, haha they actually ended up giving me money for taking their dist, after core and stuff. anywho.. i'll check the fuel pressure. any ideas on maybe the egr valve is robbing power or something?
HAve you check the vacuum ports on the upper intake for crusting over with carbon... I'd exspecially check the small line and port just behind the throttle plate.

check for vacuum leaks all together and take readings
 

88gt

New Member
RBV's on Boost
Joined
Apr 24, 2008
Messages
1,092
Reaction score
1
Points
0
Location
central VA
Vehicle Year
88
Make / Model
ford
Engine Size
2.3t swap in prog...
Transmission
Manual
if your haveing problem like that, your fuel mileage is proablly crap. i would recommend changing the battery cables. corroded cables will give you all those problems. been there...done that.
 

Rangermilitia

New Member
Joined
Nov 12, 2008
Messages
60
Reaction score
0
Points
0
Location
San Ramon, Ca
Vehicle Year
1987, for the m
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
thanks for the good info.. i checked resistance on my battery wires and all seems well. i wonder if the EGR valve is not working correctly. i have heard they are not even in operation untill about 3,000 rpm.. also my carbon canister in the engine compartement is clogged with dried up mud.. really bad. could this possibly cause the surging and dying problem..
 

IMenriched

New Member
Joined
Aug 7, 2007
Messages
1,507
Reaction score
4
Points
0
Age
58
Location
NE Iowa John Deere country
Vehicle Year
1986
02'
Make / Model
ford
Engine Size
2.9 & 5.4
Transmission
Automatic
1 way to find out...clean and or replace...retest
 


Top