• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' the posts that you read.

Lack of power, please hep!


94STXRanger

New member
Joined
Aug 7, 2007
Messages
768
Reaction score
0
Points
0
Location
Kansas City
Vehicle Year
1994,1965
Make / Model
Ford
Engine Size
4.0, 302
Transmission
Manual
Alright so a few days ago i start my truck and it runs like its not getting fire on all six. turn it off and start it again a few times, and it runs fine. Now tonight i start it and it runs like hell again and it just gets worse. So i bust back into work and take a fuel filter and put it on in the parking lot. The old one was f-ing clogged. So start it and it still seems like it wont get fuel. Rev it and it spits and sputters and wont accelerate. Has no power, and doesnt seem to be firing on all cyl. I can hear the pump run at key on. I havent had time to do much since its so late. Tomorrow i will do a pressure test.

Has new plugs, wires, fuel filter. Air filter wasnt to bad.

So what is some of your guys guesses on this? Pump, pressure regulator? Sensor? It will start and run, barely, so i wouldnt think crank or cam sensor.

Any input would be greatly appreciated.
Thanks guys.
 


Rock Auto 5% Discount Code: 80CBDBD15DC160 Expires: January 4th, 2021

94STXRanger

New member
Joined
Aug 7, 2007
Messages
768
Reaction score
0
Points
0
Location
Kansas City
Vehicle Year
1994,1965
Make / Model
Ford
Engine Size
4.0, 302
Transmission
Manual

Nhaz

New member
Joined
Jan 29, 2009
Messages
896
Reaction score
4
Points
0
Location
The Great White North, Ottawa, Canada
Vehicle Year
1998 and a few
Make / Model
Ranger+Ranger+E
Engine Size
4.0 3.0
Transmission
Automatic
last night my Maf sensor went bad. it was barly running and i had to hold the brake and accel down just to move. top speed was 20. floored.

replaced the maf sensor from my parts truck reset the computer and all was fine.

it sounds similar to your problem.

if it idles unplug the maf sensor if the truck changes idle higher or lower/stall the maf maybe working but it it makes no diff to how the truck runs its prolly dead.
 

94STXRanger

New member
Joined
Aug 7, 2007
Messages
768
Reaction score
0
Points
0
Location
Kansas City
Vehicle Year
1994,1965
Make / Model
Ford
Engine Size
4.0, 302
Transmission
Manual
Good thought. Now it wont start up though. just crank no start.
 

AllanD

TRS Technical Staff
TRS Technical Advisor
Joined
Jun 1, 2001
Messages
7,898
Reaction score
117
Points
63
Age
59
Location
East-Central Pennsylvania
Vehicle Year
1987... sorta
Make / Model
Ford
Engine Size
'93 4.0
Transmission
Manual
Pull the spark wires off the coil pack one at a time (Engine OFF!)
and LOOK inside the coil towers for corrosion on the aluminum
contacts inside the towers.

AD
 

94STXRanger

New member
Joined
Aug 7, 2007
Messages
768
Reaction score
0
Points
0
Location
Kansas City
Vehicle Year
1994,1965
Make / Model
Ford
Engine Size
4.0, 302
Transmission
Manual
Why engine off? I figured out it was the pressure regulator leaking through the diaphram.
 


Top