Just checking in


Ozwynn

Well-known member
Joined
Aug 6, 2007
Messages
6,390
Reaction score
79
Points
48
Age
43
Location
Enumclaw WA
Vehicle Year
2014, 1984,1990
Make / Model
Dodge, Honda, F
Engine Size
2.4L, 1100cc, 5.0l
Transmission
Manual
My credo
If you can't go through it or around it, then go over it.
Just checking in. How’s everybody doing? I’m still riding my V65 Magna to work every day because some days my truck runs and some days it doesn’t. Seems to be completely random. The rear fuel pump dies randomly. I did drive it 200 miles on the 12yo gas in the front tank. Ran 5gal of fresh gas and fuel stabilizer along with fuel system cleaner through it and it’s running smooth but still randomly dies. I’m thinking maybe the fuel pump relay is bad.

It goes through fuel filters like they are candy... like 2 a month.... I got some crap in the rear tank somewhere. Guess I need to pull the trigger and drop the tanks and clean the out.

So happy Christmahauniquanzica and a merry new year to everybody :icon_hornsup:
 


Rock Auto 5% Discount Code: 32B05A80BF19AF Expires: July 1st, 2020

Shran

Junk Collector
Forum Moderator
Supporting Member
Article Contributor
V8 Engine Swap
Solid Axle Swap
Joined
Mar 4, 2008
Messages
4,947
Reaction score
568
Points
113
Location
Rapid City SD
I'm doing 'aight. Happy holidays and whatnot to you too.

Might check your battery cable ECM ground - the little wire that comes straight off the negative battery terminal. That grounds out the ECM and fuel pump... I have had issues with it on a bunch of '85 up EFI Fords. Gets corroded and can be broken inside the insulation.
 

Ozwynn

Well-known member
Joined
Aug 6, 2007
Messages
6,390
Reaction score
79
Points
48
Age
43
Location
Enumclaw WA
Vehicle Year
2014, 1984,1990
Make / Model
Dodge, Honda, F
Engine Size
2.4L, 1100cc, 5.0l
Transmission
Manual
My credo
If you can't go through it or around it, then go over it.
This wire you speak of.... I had one little black wire coming off the battery terminal clamp that went straight to ground (which I changed to 4g) and a 2g wire going to the block. No other wires off the neg.

Where in the harness do I find the ground wires for the ecu and fuel pump?
 


Top