• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Going back in.... last time i hope..


Orca

Active Member
Joined
Jul 30, 2020
Messages
141
Reaction score
37
Points
28
Location
USA
Vehicle Year
2004
Make / Model
Ford Ranger
Engine Type
4.0 V6
Transmission
Automatic
2WD / 4WD
4WD
If it were me, I'd set up a FORScan or Torque Pro screen and just monitor the upstream O2 sensors' voltage.
Forgot to mention... It's far better to graph it, not show a single display of a (rapidly) changing value.
 


Rock Auto 5% Discount Code: 81874766E40C6A 5th, 2022

Shadowridr1

Member
Supporting Member
Joined
Jun 25, 2021
Messages
173
Reaction score
19
Points
18
Age
46
Location
Abilene tx
Vehicle Year
2003
Make / Model
Mazda b3000
Engine Type
3.0 V6
Transmission
Manual
2WD / 4WD
2WD
Forgot to mention... It's far better to graph it, not show a single display of a (rapidly) changing value.
68424
 

Orca

Active Member
Joined
Jul 30, 2020
Messages
141
Reaction score
37
Points
28
Location
USA
Vehicle Year
2004
Make / Model
Ford Ranger
Engine Type
4.0 V6
Transmission
Automatic
2WD / 4WD
4WD
Good. That single screenshot with graphs tells much more than the video.

To my eye, it appears that the upstream bank #2 O2 sensor (pink line) is behaving oddly. On the other hand, the upstream bank #1 O2 sensor (blue line) is behaving normally (rapidly changing between high and low values). That would tend to confirm the odd bank #2 STFT and LTFT behavior in the video of your earlier post.

The problem is knowing why the bank #2 O2 sensor is behaving oddly. It could be that the sensor or wiring is faulty. Or it could be that the sensor is accurately reporting the situation and that the real problem is something further upstream, like a bank #2 fuel injector or possibly even the PCM.

In your previous video, it seemed like the pulse width on bank #2 was consistently larger than on bank #1, making me wonder if that's a contributing factor.
 

Shadowridr1

Member
Supporting Member
Joined
Jun 25, 2021
Messages
173
Reaction score
19
Points
18
Age
46
Location
Abilene tx
Vehicle Year
2003
Make / Model
Mazda b3000
Engine Type
3.0 V6
Transmission
Manual
2WD / 4WD
2WD
Good. That single screenshot with graphs tells much more than the video.

To my eye, it appears that the upstream bank #2 O2 sensor (pink line) is behaving oddly. On the other hand, the upstream bank #1 O2 sensor (blue line) is behaving normally (rapidly changing between high and low values). That would tend to confirm the odd bank #2 STFT and LTFT behavior in the video of your earlier post.

The problem is knowing why the bank #2 O2 sensor is behaving oddly. It could be that the sensor or wiring is faulty. Or it could be that the sensor is accurately reporting the situation and that the real problem is something further upstream, like a bank #2 fuel injector or possibly even the PCM.

In your previous video, it seemed like the pulse width on bank #2 was consistently larger than on bank #1, making me wonder if that's a contributing factor.
So where do I start. This morning, the start up was with fresh oil, fresh plugs, I didn't have this issue everything was damn near perfect, the trims and o2 sensors were spot on... Keep in mind the o2 sensors, all 3 are new bosch sensors, the injectors are new oem, the pigtails to every injector is new, new fuel, fuel pump is new, fuel filter is new, fuel lines were blown out with air. Only things not NEW....crank, pistons, cam, crank sensor, fuel rail, exhaust manifolds, catalytic converters, muffler.....
 

Orca

Active Member
Joined
Jul 30, 2020
Messages
141
Reaction score
37
Points
28
Location
USA
Vehicle Year
2004
Make / Model
Ford Ranger
Engine Type
4.0 V6
Transmission
Automatic
2WD / 4WD
4WD
Well, from the limited data, it sure looks like something is amiss on Bank #2, so you should probably focus on that.

How is the engine actually running? While it's a mistake to ignore OBD2 data, it's also a mistake to over-rely on it.

Also, have you pulled DTCs since the change in behavior? If the Bank #2 LTFT is that high, I'd expect a DTC to be set eventually. Maybe there are other new DTCs. Also, check the freeze frame data since it can sometimes provide a clue.
 

mc17eln

Member
Joined
Aug 8, 2021
Messages
74
Reaction score
23
Points
8
Location
Diamond Bar, California
Vehicle Year
2002
Make / Model
Ford Ranger XLT
Engine Type
3.0 V6
Transmission
Automatic
2WD / 4WD
2WD
@Shadowridr1 Sorry to bring more bad news. You can get the relay labeled K45 (C1055) and fuse F1.17 (20A) from the 2.3L battery junction box (next to the driver side hood hinge), but there is no such relay and fuse spots in the 3.0L junction box. You will have to wire PCM pin 45, the fuse, the fan output and ground to the relay by yourself. Plus I am not even sure if 3.0L PCM pin 45 produces the fan-on signal at all. It doesn't seem worth it.
 
Last edited:

Shadowridr1

Member
Supporting Member
Joined
Jun 25, 2021
Messages
173
Reaction score
19
Points
18
Age
46
Location
Abilene tx
Vehicle Year
2003
Make / Model
Mazda b3000
Engine Type
3.0 V6
Transmission
Manual
2WD / 4WD
2WD
Well, from the limited data, it sure looks like something is amiss on Bank #2, so you should probably focus on that.

How is the engine actually running? While it's a mistake to ignore OBD2 data, it's also a mistake to over-rely on it.

Also, have you pulled DTCs since the change in behavior? If the Bank #2 LTFT is that high, I'd expect a DTC to be set eventually. Maybe there are other new DTCs. Also, check the freeze frame data since it can sometimes provide a clue.
Orca, I'm getting ready to mess with it what PID'S do I need to pull up to get values that will help. I'm getting a new MAF as I type and going to replace my old one. It's really the only thing I haven't replaced that works in conjunction with misfires and fuel trims.
 

Shadowridr1

Member
Supporting Member
Joined
Jun 25, 2021
Messages
173
Reaction score
19
Points
18
Age
46
Location
Abilene tx
Vehicle Year
2003
Make / Model
Mazda b3000
Engine Type
3.0 V6
Transmission
Manual
2WD / 4WD
2WD

Shadowridr1

Member
Supporting Member
Joined
Jun 25, 2021
Messages
173
Reaction score
19
Points
18
Age
46
Location
Abilene tx
Vehicle Year
2003
Make / Model
Mazda b3000
Engine Type
3.0 V6
Transmission
Manual
2WD / 4WD
2WD

Orca

Active Member
Joined
Jul 30, 2020
Messages
141
Reaction score
37
Points
28
Location
USA
Vehicle Year
2004
Make / Model
Ford Ranger
Engine Type
4.0 V6
Transmission
Automatic
2WD / 4WD
4WD
Orca, I'm getting ready to mess with it what PID'S do I need to pull up to get values that will help. I'm getting a new MAF as I type and going to replace my old one. It's really the only thing I haven't replaced that works in conjunction with misfires and fuel trims.
I'd hesitate to replace the MAF just yet. Your most recent issue seems to be specific to Bank #2 and a MAF problem would affect both banks. Furthermore, why not check the "MAF" PID in FORScan before considering replacing that sensor? I just worry that with so many things being replaced or modified, you're introducing too many "variables" into an already hard-to-solve "equation". If you've already replaced it, consider monitoring the "MAF" PID to see how the new sensor behaves. I looked at some old graphs of my 2004 Ranger's MAF output and, at speeds up to 60 mph, the MAF values ranged from 3.3 to 63.4 g/s, just to give you a reference.

Having said that, I'd be scanning the list of PIDs in FORScan to check for anything that's specific to Bank #2 and, for now, monitor those PIDS. That would include O2 sensor voltages ("O2S2x" where 'x' is 1 for upstream and 2 for downstream), O2 heater current and fault info ("HTR2x" and "HTR2xF", with same meaning for 'x'), fuel trims ("SHRTFT2" and "LONGFT2"), and fuel injector pulse width ("FUELPW2").

And, even though it's not specific to Bank #2, I'd be checking fuel injector faults ("INJx_F" where 'x' is 1 to 6 for cylinder number) too at some point.

I'd also be keeping an eye on the "FUELSYS1" PID (or whatever it's called) so that you know when the system is in "closed loop" mode.

That should be a good starting point. But scan the FORScan PID list yourself and use your own good judgment. Also, be aware that there is a lot of replication in the listed PIDs because there are sometimes several ways to get the same info from the vehicle.

And, although I said this earlier, it bears repeating: Be aware that certain PIDs like O2 sensor voltages (especially upstream) are best monitored with very few other PIDs simultaneously, to keep the graph refresh rate high enough to really see how they're behaving.

Also, don't forget to check Mode $06 misfire data. It may still be non-functional, presumably because of the P1000, but don't forget about it -- it can be very useful once it starts reporting.

I probably forgot something, but hopefully someone will jump in and remind me.

P.S. I have not looked at your latest posts (DTC & video). Might have more to say after I do....
 

Shadowridr1

Member
Supporting Member
Joined
Jun 25, 2021
Messages
173
Reaction score
19
Points
18
Age
46
Location
Abilene tx
Vehicle Year
2003
Make / Model
Mazda b3000
Engine Type
3.0 V6
Transmission
Manual
2WD / 4WD
2WD
INTERESTING TIDBITS
of stuff I checked this morning
1. At temp all exhaust ports on manifold are reading 210°
2. Top Cat bank 1
206° in & 212° out
Bank 2 cat
176° in & 185° out
Bank 1 cat 2
210° in & 208° out
When I pull plug wires AT coil pack
1- engine changes, long spark
2- engine changes, long spark
3- engine changes, short spark
4 -engine almost stalls and a long spark
5- engine changes, very short spark
6- engine almost stalls, long spark
Pull IAC engine dies
Pull MAF no change till I plug it back in, then engine revs and settles back down
Got a tick from Bank 1 valve cover when idle is around 1500
Fuel pressure at key on is 60
Fuel pressure engine running is erratic between 58-65
Fuel pressure held solid at 58 for 5 mins
 

Orca

Active Member
Joined
Jul 30, 2020
Messages
141
Reaction score
37
Points
28
Location
USA
Vehicle Year
2004
Make / Model
Ford Ranger
Engine Type
4.0 V6
Transmission
Automatic
2WD / 4WD
4WD
DTC today
ABS DTC C1230 is new. This is "Rear Wheel Speed Sensor Input Circuit Failure". Did you forget to plug in your rear axle speed sensor after you checked it? ;)

GEM DTC P0500 is the only other one on your screenshot that would concern me in the short term. But, IMHO, diagnosing that can easily wait until your engine is running properly.

P.S. Earlier, we came very close to simultaneously posting. I hope you saw my detailed post with the list of suggested PIDs.
 

Shadowridr1

Member
Supporting Member
Joined
Jun 25, 2021
Messages
173
Reaction score
19
Points
18
Age
46
Location
Abilene tx
Vehicle Year
2003
Make / Model
Mazda b3000
Engine Type
3.0 V6
Transmission
Manual
2WD / 4WD
2WD
ABS DTC C1230 is new. This is "Rear Wheel Speed Sensor Input Circuit Failure". Did you forget to plug in your rear axle speed sensor after you checked it? ;)

GEM DTC P0500 is the only other one on your screenshot that would concern me in the short term. But, IMHO, diagnosing that can easily wait until your engine is running properly.

P.S. Earlier, we came very close to simultaneously posting. I hope you saw my detailed post with the list of suggested PIDs.
Yes sir, I saw your post. Idk why the c1230 is coming up. I unplugged the ABS sensor and made sure it was plugged back in, otherwise I haven't messed with any sensors. 🤷‍♂️
I took video of
Bank 1
Bank 2
And O2S & fuel trims. I will load them shortly
 

Shadowridr1

Member
Supporting Member
Joined
Jun 25, 2021
Messages
173
Reaction score
19
Points
18
Age
46
Location
Abilene tx
Vehicle Year
2003
Make / Model
Mazda b3000
Engine Type
3.0 V6
Transmission
Manual
2WD / 4WD
2WD


Top