Fuse Blowing In Neutral


ChrisC

New member
Joined
Jul 11, 2019
Messages
4
Reaction score
0
Points
1
Location
BeeCee
Good day,

I've got an electrical problem that I think I've narrowed down to a specific event, but I'm not sure where to begin poking around.

2006 Ranger 4x4, 4L, Automatic.

Truck runs great and doesn't have any other issues that I know about. No codes, quirks, etc. The only abnormal service it's had since I purchased it from a previous owner was an airbag replacement via the original dealer due to a recall.

Recently, it started blowing the 10A fuse in position 20 of the passenger-side fuse panel. This causes the ABS and Brake lights on the dash to illuminate until the fuse is replaced. I got into the wiring in the steering column thinking that it might be the OD switch harness having worn through and causing a short. It's definitely fine, but I replaced it anyway. OD switch seems to function correctly. The rest of the wiring looks okay from what I can see.

I've narrowed the failure point to specifically when the truck is put in neutral. I can even whiz past the neutral position fast enough that the fuse stays intact. If I leave it in neutral for more than a second or two, the fuse pops and the ABS and Brake lights illuminate. No codes show up using the Torque app and my cheezy little Bluetooth dongle. As I'd expect, all other functions seem fine - A/C, radio, 4wd, windows, etc.

Anyone dealt with this problem? Ideas about what to check?

Cheers!
 


Rock Auto 5% Discount Code: 248EE46702D889 Expires: October 1, 2019

RonD

Well-known member
Joined
Jun 2, 2012
Messages
13,315
Reaction score
287
Points
83
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Welcome to TRS :)

Its also the backup light fuse, which is wired in at the DTR(digital transmission range) sensor

DTR sensor is on drivers side of transmission on the shifter, it has a few wires and can cause a short, it tells the computer what gear you select and also activates the Backup Lights
Maybe unplug that sensor and shift into Neutral and see if fuse still blows

Looks like this: http://www.electricaladvantage.net/images/products/detail/IMG_1919.1.JPG

Thats the only thing I can think of thats related to the shifter movement unless there is a wire shorting from movement of the linkage under the dash but have to be a very odd short to just do it in Neutral
 

ChrisC

New member
Joined
Jul 11, 2019
Messages
4
Reaction score
0
Points
1
Location
BeeCee
Thanks for the welcome! Appreciate the info and I'll definitely give that a peek and a poke in the morning. I've got the column apart already, so I'll also have another look to make sure it's not a short due to movement of the shifter. Agree it's unlikely, but stranger things have happened.
Thanks again!
 

ChrisC

New member
Joined
Jul 11, 2019
Messages
4
Reaction score
0
Points
1
Location
BeeCee
Finally snuck out to have a look at the DTR sensor and harness. With the harness disconnected, I can turn the electrical system on and shift through all gears without the fuse blowing. Reconnected, instant fuse failure in neutral.
Got underneath again to beep it out. I've got a dead short from pin 7 (ground) to pin 8 (neutral) on the harness (assuming my diagram is correct). I didn't test it with the electrical system on, but I can if necessary. I'm almost certain that this is my problem, but can I get confirmation that it's abnormal? (edit - good a chance that it's perfectly normal and my diagram is no good)

edit: Bah! Hot and tired. Just realized I'm probably thinking about this backwards. If the harness was shorting to itself, I'd expect it to pop the fuse whether it was connected or not. So I'm thinking bad sensor, which is a huge relief from a repair perspective. I loathe wiring. Does this sound more reasonable?
 
Last edited:

RonD

Well-known member
Joined
Jun 2, 2012
Messages
13,315
Reaction score
287
Points
83
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Yes, bad DTR sensor would be my conclusion as well


The DTR is a GROUND loop as far as the "gear" part
Pins 2 is "sig rtn", signal return, which is a Computer "ground" it is hooked to most sensors on the vehicle, as a reference gound

When Park, R, N, D, 3, 2, 1, is selected the "sig rtn" wire(pin 2) is connected to that "gears" wire, so when you shift to N for example pin 8 is connected to pin 2, a ground, but not a short

pin 9 is 12volts for the backup lights, my guess would be 8 and 9 are shorted in the DTR, so when you shift to N pin 8 is now a Ground, via pin 2, so POP goes the "weasel", lol

Good work, hopefully that is the issue, sure reads like it is

DTR does need to be "adjusted" when installing, there are a few threads and videos on how to do that without the Ford tool
 

ChrisC

New member
Joined
Jul 11, 2019
Messages
4
Reaction score
0
Points
1
Location
BeeCee
Awesome! Thanks again for all the valuable info. Everything you've explained makes perfect sense. You saved me a ton of time and I've learned more about what makes my truck tick. Cheers!
 


Top