• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Fuk! Another problem! Help please

96Greenster

New Member
Joined
Jun 1, 2009
Messages
324
Reaction score
0
Points
0
Location
Rio Grande City
Vehicle Year
1999
Make / Model
Ford
Engine Size
4.0L
Transmission
Automatic
Well today was a ruff day.. On my way to work my truck felt weird, kind of hesitating uphill, jerked a few times, I floored it and it felt like it wanted to shut off, RPM's fell to like 1 or 1.5k then it raised to like 4k... A few mins later i was cruising at around 20-25 mph it started jerking, bucking, boging u name it.. Then i suddenly shut off sputtering, It would restart and fire up for about 5 secs then shut off agin.. did it numerous of times. Fuel Pump was priming. So I let it cool down then it starts up like nothing ever happened. no cel..BTW it was hot outside like 90-95F

I searched on crankshaft sensor, seems too match the syptoms.. Please help me out guys.. Thanx..
 


srteach

New Member
Joined
Aug 11, 2007
Messages
977
Reaction score
9
Points
0
Vehicle Year
1999, 2001
Make / Model
Ranger, F350
Engine Size
4.0L, 7.3 Diesel
Transmission
Manual
It also sounds like it could be a coil pack.
 

xentris02

New Member
Joined
Oct 30, 2009
Messages
158
Reaction score
0
Points
0
Location
st.louis, mo
Vehicle Year
1993
Make / Model
ford
Engine Size
4.0 v6
Transmission
Automatic
same thing just happened to my dad on his f-150 exact same symptoms, it was the fuel filter.
 

AllanD

TRS Technical Staff
TRS Technical Advisor
Joined
Jun 1, 2001
Messages
7,899
Reaction score
125
Points
63
Age
60
Location
East-Central Pennsylvania
Vehicle Year
1987... sorta
Make / Model
Ford
Engine Size
'93 4.0
Transmission
Manual
First thing to "fix" even before you reach for the keyboard (or an EEC tester if you have one) is to replace the fuel filter.

Do that and then tell us if it fixed it or not.

people ALWAYS think it's "spark".
they are more often than not wrong.

AD
 

96Greenster

New Member
Joined
Jun 1, 2009
Messages
324
Reaction score
0
Points
0
Location
Rio Grande City
Vehicle Year
1999
Make / Model
Ford
Engine Size
4.0L
Transmission
Automatic
I will check the filter.. I replaced it a couple of months back. I drove it today, it ran like it normaly would.. But smells like unburned gas in the engine area.. and the muffler tip is black as it can be.
 

xentris02

New Member
Joined
Oct 30, 2009
Messages
158
Reaction score
0
Points
0
Location
st.louis, mo
Vehicle Year
1993
Make / Model
ford
Engine Size
4.0 v6
Transmission
Automatic
well if its not your filter and the check engine light is off i asume cause if it was on it would probaly be your o2. but if it is off you could have oil getting into you gas thats what usualy makes it so black unless its burning rich
 

Madman54

Member
ASE Certified Tech
Joined
Jan 30, 2010
Messages
45
Reaction score
10
Points
8
Location
Utah
Vehicle Year
1992
Make / Model
Ford
Engine Type
4.0 V6
Engine Size
4.0
Transmission
Manual
2WD / 4WD
4WD
My credo
Stop skipping steps and get it done right the first time.
I recently had a problem that sounds a little like this one, in a couple different fords..... One solution was the air intake hose had slipped off the end off the throttle body an dthe engine didnt like any bit of extra air, acted just like what you're describing, this happend to me one other time, but it was choking the engine out instead of over airating it...
another solution to my problems, was the MAF sensor plug had slid back and lost connection with the MAF (cuz I broke the clip off of the plug the week before...)

theres my two cents, good luck
 

96Greenster

New Member
Joined
Jun 1, 2009
Messages
324
Reaction score
0
Points
0
Location
Rio Grande City
Vehicle Year
1999
Make / Model
Ford
Engine Size
4.0L
Transmission
Automatic
The intake hose is on correctly and tight.. It seems like it running rich.. the smell is pretty bad.. I was getting a P0174 (Lean bank 2) code a while back.. but hasnt popped up in awhile.. What about the catalytic converters?? this one has 4 of them.. I was thinking of hollowing them out.. The reason I say the cats is because the smell, lack of power on wide open throttle, the flow on the exhaust tip feels low, the carbon coating on the tip.

Oh and its pinging/detonating really bad and loud when speeding up, from 2.5-4k rpm until I let off it quits pinging...
 
Last edited:

sniper141

New Member
Joined
May 24, 2009
Messages
187
Reaction score
2
Points
0
Age
43
Location
Castorland, NY
Vehicle Year
2000
Make / Model
Ford
Engine Size
4.0L OHV V6
Transmission
Automatic
clean the MAF
 

Sponsored Ad


Sponsored Ad

Top