• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Fuel pump issue?


Nez'sRanger

Active Member
Joined
Oct 6, 2018
Messages
230
Reaction score
68
Points
28
Location
Pennsylvania
Vehicle Year
1989
Make / Model
Ford
Engine Size
2.9L V6
Transmission
Manual
Hey all! My ranger has been running beautifully for months now that I worked most of it's bugs out.
This morning, I drive it to work, no problem. But, when I got in and fired it up to go to lunch, and it ran for a little bit, and then it died. It's got a full tank, so I'm assuming the pump just quit. Being that the pump is barely a year and a half old, I checked the fuse under the hood. Pulled it out, it was fine, so I put it back in, tried again, and it fired right up and got me home no prob. After lunch, it fired right up, and I drove up the alley, and it died yet again. I repeated what I did (pulling and replacing the fuse), and again it fired right up. This time I parked it in the driveway and left it alone! Ha!
Anyone have any idea what is going on? I'm leaning towards a wiring issue, and will look it over this weekend. Thanks!
 


89Twincharge

Active Member
Joined
Aug 25, 2016
Messages
265
Reaction score
182
Points
43
Vehicle Year
89
Make / Model
Ford
Transmission
Manual
Did you do filter when you did pump? What year is it? Did you pull fuse and replace with key on, if so turn key back and forth a few times and try cranking it...
 

Nez'sRanger

Active Member
Joined
Oct 6, 2018
Messages
230
Reaction score
68
Points
28
Location
Pennsylvania
Vehicle Year
1989
Make / Model
Ford
Engine Size
2.9L V6
Transmission
Manual
Yea, filter was replaced a month or so before the pump.
Key was off when I pulled the fuse.
It's an 89
 

Nez'sRanger

Active Member
Joined
Oct 6, 2018
Messages
230
Reaction score
68
Points
28
Location
Pennsylvania
Vehicle Year
1989
Make / Model
Ford
Engine Size
2.9L V6
Transmission
Manual
Well, I checked and double checked, and my pump is fine. I recently changed gas stations, and I think the new gas dislodged done sludge. I put some Chevron techtron in the tank, and it hasn't done anything goofy since.
 

Sponsored Ad


Sponsored Ad

Staff online

Member & Vendor Upgrades

For a small yearly donation, you can support this forum and receive a 'Supporting Member' banner, or become a 'Supporting Vendor' and promote your products here. Click the banner to find out how.

Truck of The Month


XLTsplash
June Truck of The Month

Recently Featured

Want to see your truck here? Share your photos and details in the forum.

Follow TRS On Instagram

TRS Events

25th Anniversary Sponsors

Check Out The TRS Store


Sponsored Ad


Sponsored Ad

Sponsored Ad


Amazon Deals

Top