• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Electrical Issue

Spencer Elder

New Member
Joined
Oct 2, 2007
Messages
11
Reaction score
0
Points
0
Location
Idaho Falls, ID
Vehicle Year
1988
Make / Model
Ford
Engine Size
2.9 V6
Transmission
Manual
Why would Electrial shut off/start to die on my 88 ford ranger when i give it gas to accelerate my radio dies and the lights dim as if im pulling a huge power load but only when i accelerate i have cheked the battery replaced the + and- power cables and alternator and it seems like it all started after i pulled this girl out of a snow drift and had a strong rubber smell now all this wasn't sure if that caused anything
thnks spencer
 


baddis

New Member
U.S. Military - Veteran
Solid Axle Swap
Joined
Jul 23, 2004
Messages
1,344
Reaction score
6
Points
0
Age
50
Location
Avon,il
Vehicle Year
2004
2014
Make / Model
Ford
Ford
Engine Size
4.0 Sohc 1.5 ecoboost
Transmission
Automatic
sounds like you have some burned wires somewhere. i would check the power wire at the back of the alternator.
 

Spencer Elder

New Member
Joined
Oct 2, 2007
Messages
11
Reaction score
0
Points
0
Location
Idaho Falls, ID
Vehicle Year
1988
Make / Model
Ford
Engine Size
2.9 V6
Transmission
Manual
well i just replaced it after this started happining i judt dono im stumpped on all aspects in thinking about just taking to this shop where they will do basic diag. for 40 to 50 bucks but it would be nice to figure it out by my self i even checked the starter wires just to see if that could be it but i might recheck them agian just to make sure
 

IMenriched

New Member
Joined
Aug 7, 2007
Messages
1,507
Reaction score
4
Points
0
Age
59
Location
NE Iowa John Deere country
Vehicle Year
1986
02'
Make / Model
ford
Engine Size
2.9 & 5.4
Transmission
Automatic
Why would Electrial shut off/start to die on my 88 ford ranger when i give it gas to accelerate my radio dies and the lights dim as if im pulling a huge power load but only when i accelerate i have cheked the battery replaced the + and- power cables and alternator and it seems like it all started after i pulled this girl out of a snow drift and had a strong rubber smell now all this wasn't sure if that caused anything
thnks spencer
HMMM

how about the belts?? what kind of condition are they in??
IS this auto tranny?? Maybe check the cooler lines up by the radiator... gotta pin hole spraying the belts after the snow pile???

just thoughts...hope it helps
 

Spencer Elder

New Member
Joined
Oct 2, 2007
Messages
11
Reaction score
0
Points
0
Location
Idaho Falls, ID
Vehicle Year
1988
Make / Model
Ford
Engine Size
2.9 V6
Transmission
Manual
so i took it to this shop and both my motor mounts bolts are snaped and an electrical fire started by the gas pedel and they found out my front axel is shot im instructed to keep the hubs unlocked and it out of 4 so i want to know what you guys think it will take and how much i would be they don't know exactaly what is wrong but i think it's might be the spider gears
 

IMenriched

New Member
Joined
Aug 7, 2007
Messages
1,507
Reaction score
4
Points
0
Age
59
Location
NE Iowa John Deere country
Vehicle Year
1986
02'
Make / Model
ford
Engine Size
2.9 & 5.4
Transmission
Automatic
so i took it to this shop and both my motor mounts bolts are snaped and an electrical fire started by the gas pedel and they found out my front axel is shot im instructed to keep the hubs unlocked and it out of 4 so i want to know what you guys think it will take and how much i would be they don't know exactaly what is wrong but i think it's might be the spider gears
WOW~ that must of been a pretty good shot into the snow.

Depends on how much you're willing to spend & what you can do yourself...things like that.

Probably best to get whole donor truck or replacement component's from the salvage yard...there most likely going to be other suspension and drive line parts compromised too. just things to concider.
 

Sponsored Ad


Sponsored Ad

Top