• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Dome light delay?

mp3deviant721

New Member
Joined
Aug 28, 2009
Messages
2,315
Reaction score
24
Points
0
Location
Eau Claire, WI
Vehicle Year
1995
Make / Model
Ford
Engine Size
2.3l of fury
Transmission
Manual
I just put in new door switches. I noticed when opening the drivers door that there is a delay in the light turning off. Is this how the GEM controls the light? This ain't a technical question. Just out of curiosity.


Sent from my iPhone using Tapatalk
 


Brownie Mobile

New Member
Joined
Mar 7, 2012
Messages
413
Reaction score
1
Points
0
Location
Williston, ND
Vehicle Year
1985
Make / Model
Ford
Engine Size
5.0
Transmission
Manual
I just put in new door switches. I noticed when opening the drivers door that there is a delay in the light turning off. Is this how the GEM controls the light? This ain't a technical question. Just out of curiosity.


Sent from my iPhone using Tapatalk
I had this problem but mine is a lot older of course, it was just sticky so i put some wd-40 on it and worked it in and now it works like butta.
 

srteach

New Member
Joined
Aug 11, 2007
Messages
977
Reaction score
9
Points
0
Vehicle Year
1999, 2001
Make / Model
Ranger, F350
Engine Size
4.0L, 7.3 Diesel
Transmission
Manual
It is likely that the switch in the door is getting slow / sticky. Very likely that it is on its' way to not working correctly.

A new switch or WD40 is the answer.
 

mp3deviant721

New Member
Joined
Aug 28, 2009
Messages
2,315
Reaction score
24
Points
0
Location
Eau Claire, WI
Vehicle Year
1995
Make / Model
Ford
Engine Size
2.3l of fury
Transmission
Manual
I don't know what's going on here, but I clearly stated that I put in new switches.


Sent from my iPhone using Tapatalk
 

shane96ranger

Well-Known Member
V8 Engine Swap
Joined
Oct 20, 2009
Messages
8,334
Reaction score
214
Points
63
Location
Utah
Vehicle Year
1997 / 1989
Make / Model
Ford F150-Stang
Engine Type
V8
Engine Size
4.6 Triton / 5.0
My 96 did have a delay of around 20 seconds. That is normal, give or take 5 seconds. Did yours not have a delay prior to changing the switches?
 

Brownie Mobile

New Member
Joined
Mar 7, 2012
Messages
413
Reaction score
1
Points
0
Location
Williston, ND
Vehicle Year
1985
Make / Model
Ford
Engine Size
5.0
Transmission
Manual
I don't know what's going on here, but I clearly stated that I put in new switches.


Sent from my iPhone using Tapatalk
and we said nothing that would suggest otherwise? A newer switch could be sticky out of the factory.
 

straycat

New Member
U.S. Military - Veteran
Joined
Oct 6, 2009
Messages
5,733
Reaction score
77
Points
0
Vehicle Year
02 06 and 2012
Make / Model
Jeeps
Transmission
Automatic
My 99 Ranger does not have any delay. It goes off whenever I shut the door. Maybe the switch you installed is set up that way? I would not bother about it as long as it does go out. One thing I do like about my Ranger is that I after parking in the garage I have closed the door and walked away and the door did not close all the way (air vacuum maybe from the windows being closed). I came back out to the garage and saw the door was a gap just a bit and thought I might have run the battery down. That is when I found out that the light is on a timer goes out after a while and that is a cool function. I tried it several times just to make sure it worked that way and it does.
 

Sponsored Ad


Sponsored Ad

Top