• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' the posts that you read.

Cranks does not Start.


Steve Dalley

New member
Joined
Mar 10, 2019
Messages
2
Reaction score
0
Points
1
Age
70
Location
Vancouvr Island BC
Vehicle Year
1989
Make / Model
Ford Ranger
Engine Type
2.9 V6
Engine Size
2.9
Transmission
Manual
2WD / 4WD
2WD
Total Lift
0
Total Drop
0
Tire Size
Stock, so far
My credo
Always Be Kind
I just got a sweet stock California 89 Ranger 2.9 5 speed 2 Wh Drive with only 120K original miles. Shut her down last night and now she cranks but does not fire, Fresh fuel and battery. Cannot hear the pump run and no pressure at the fuel rail. Checked the inertia and reset the switch. door glass says Ford Anti-Theft. Could this system shut off the power to the fuel pump ?. Key and ignition does not have the transceiver type keys. Owners manual and Haynes has no info. I'm looking for info/guidance before I drop the tank to get to the Fuel pump.
 


Rock Auto 5% Discount Code: 4FF3E9EEA14805 Expires: October 1st, 2020

Nez'sRanger

Active member
Joined
Oct 6, 2018
Messages
201
Reaction score
54
Points
28
Location
Los Angeles, CA
Vehicle Year
1989
Make / Model
Ford
Engine Size
2.9L V6
Transmission
Manual
Yea, with these old 89's, I don't even think anti-theft exists, at least not as far as this issue is concerned.
I would check the fuel pump fuse in the power distribution box under the hood before dropping the tank.
I've learned to check some dumb stuff before getting too involved. Dumb stuff like rats and squirrels chewing through wires and vacuum lines. I tried jump starting a friend's car, only to find a rat had chewed through the starter wires.
That's especially important to check when problems appear overnight.
 

hopster

Member
Ford Technician
TRS 20th Anniversary
Joined
Sep 10, 2008
Messages
422
Reaction score
9
Points
18
Location
Bedford, IN
Vehicle Year
1990,1989
Make / Model
Ford
Engine Size
2.9, 4.0, 5.0 can't decide
Transmission
Manual
There is a ground wire near the battery with a connector in it that comes unplugged or gets corroded that causes this a lot
 


Top