• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

check engine light

03ranger4x4

New Member
Joined
Oct 16, 2009
Messages
208
Reaction score
3
Points
0
Vehicle Year
2003
Make / Model
Ford
Transmission
Automatic
The truck is an 03 ranger xlt with the 4.0 SOHC v6

So finally the check engine light decided to come on my truck after 90,800 miles of service. I had it scanned at autozone, and it came up as "left cylinder bank lean" The truck runs and drives fine, i noticed no difference in the idle or anything else.

This came on shortly after the exhuast broke on my truck AFTER the cats. Basically all ive done with the exhuast since it broke is just run it straight out the side with some flex-pipe from advance. I love the sound, and it isnt too loud ethier, even without any muffler at all...unless you floor it. And with gas coming up on 4 a gallon...i cant afford to floor it lol.

Basically what im wondering is if the exhuast being such low flow with its current setup, is that some how throwing this code on the ECM? Doesnt seem likley but all vehicles differ. Ive had plenty of car with open exhuast and never had an issue.

Also i think the fuel filter has never been changed, so ima go ahead on do that this weekend. Though i doubt that would somehow cause only half the engine to run lean...but however unlikley im sure its possible.
 


adsm08

Senior Master Grease Monkey
Supporting Member
Article Contributor
Ford Technician
TRS 20th Anniversary
Joined
Sep 20, 2009
Messages
34,621
Reaction score
3,580
Points
113
Location
Dillsburg PA
Vehicle Year
1987
Make / Model
Ford
Engine Type
4.0 V6
Engine Size
4.0
Transmission
Manual
2WD / 4WD
4WD
Tire Size
31X10.50X15
Intake gaskets. Spray around the intake with brake clean and listen for it to rev up, but upper intake gaskets are a common issue on that engine.
 

Sponsored Ad


Sponsored Ad

Top