• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Check engine light-rough idle(Evap plug fault?)

DangerRanger95xlt

New Member
Joined
Jan 18, 2014
Messages
2
Reaction score
0
Points
0
Vehicle Year
1995
Make / Model
Ford
Transmission
Manual
I am having a problem with my 95 ford ranger. It's an xlt and has the 4.0 v6 and is a 5 speed. My check engine light has been on and it comes up "Evap plug fault" when i plug a computer into it. The truck also has a tendency to have a rough idle(fluctuates) when I pull up to a stop sign, etc. it'll drop to about 500 rpm. I was wondering if you guys had any help you could give me?
 


RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
22,010
Reaction score
5,331
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
What is the code number?
Some have different meanings than commonly posted

For EVAP have a look here, there are pictures:
http://www.therangerstation.com/forums/showthread.php?t=89253

Might be related to idle issue but might not.
Fuel injected engines can't use an idle screw like a carb did, no jets, so they use a controlled vacuum leak called an IAC(idle air control) valve.
Computer slides this valve to allow more air(higher idle) or less air(lower idle) into the intake manifold, so "controlled vacuum leak" :)
The IAC valve can get dirty and sticky causing idle issues, but it is easy to remove and clean.
 
Last edited:

Sponsored Ad


Sponsored Ad

Top