• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Brake Issue.

MrGearhead

Member
Joined
Nov 10, 2018
Messages
37
Reaction score
12
Points
8
Location
Illinois
Vehicle Year
𝟚𝟘𝟘𝟞
Make / Model
𝔽𝕠𝕣𝕕
Engine Type
3.0 V6
Engine Size
𝟛.𝟘
Transmission
Automatic
2WD / 4WD
2WD
The brakes on my ‘06 (2wd) are acting up. I did rotors, pads, drums, wheel cylinders & hardware. Normal driving is fine but if you try to stop quick, the pedal drops to the floor. You feel and hear the slight sound of the ABS noise and pedal vibration for a sec. No brake light, no leaks, no loss of fluid in the master. I’m guessing the master is bad but I’m afraid it’s the booster.
I only drive this truck 4 or 5 times a month and the problem wasn’t constant. But driving it home a week ago it kept happening. All I thought was.. “Time to trade it”. I had a week to calm down. Lol
9B35B1CB-D9B1-4BE7-936B-5FA68297101A.jpeg
 


Bronco ii Man

Active Member
Joined
Jun 1, 2022
Messages
146
Reaction score
43
Points
28
Age
48
Location
Southport NC
Vehicle Year
85
Make / Model
Ford Bronco ii
Engine Type
2.8 V6
Engine Size
2.8 v6
Transmission
Manual
2WD / 4WD
4WD
Total Lift
0
Total Drop
0
Tire Size
31x10.50-15
Kinda sounds like a master cylinder problem. No leaks external that you can see but leaking inside itself. Had it happen on my Bii.
 

Uncle Gump

Forum Staff Member
Forum Moderator
Supporting Member
TRS Event Participant
Joined
Sep 17, 2018
Messages
11,343
Reaction score
9,347
Points
113
Location
Ottawa IL
Vehicle Year
2006/1986
Make / Model
Ranger/BroncoII
Engine Size
4.0L SOHC/2.9L
2WD / 4WD
4WD
My credo
Lead, Follow or get out of my way
I'm pretty sure it's your ABS going off... and I've have some issue with the front wheel speed sensors.

Tell me... does it tend to wanna pull the truck left or right when it happens?

These wheel speed sensors tend to fall off when at slow speeds... but the others say it's still moving so ABS tends to unapply whatever speed sensor falls off.
 

Bronco ii Man

Active Member
Joined
Jun 1, 2022
Messages
146
Reaction score
43
Points
28
Age
48
Location
Southport NC
Vehicle Year
85
Make / Model
Ford Bronco ii
Engine Type
2.8 V6
Engine Size
2.8 v6
Transmission
Manual
2WD / 4WD
4WD
Total Lift
0
Total Drop
0
Tire Size
31x10.50-15
Press the brake a few times to get a full pedal and then press hard on it! If it holds a few seconds and slowly goes to the floor your master cylinder is bad! Booster will 90% of the time cause a vacuum leak! Thus causing a high idle situation! I’m sure you got all the air out when you bleed the system? Could be the culprit? Couple of things to look for.
 

MrGearhead

Member
Joined
Nov 10, 2018
Messages
37
Reaction score
12
Points
8
Location
Illinois
Vehicle Year
𝟚𝟘𝟘𝟞
Make / Model
𝔽𝕠𝕣𝕕
Engine Type
3.0 V6
Engine Size
𝟛.𝟘
Transmission
Automatic
2WD / 4WD
2WD
Yea. I’m just a crabby old man now .. lol. I’ve been wrenching for over 35yrs and after a 50hr week of fixing people cars, the last thing I want to do is work on my own junk anymore.
I’ll have to pick up a new master. 👍🏼
 

MrGearhead

Member
Joined
Nov 10, 2018
Messages
37
Reaction score
12
Points
8
Location
Illinois
Vehicle Year
𝟚𝟘𝟘𝟞
Make / Model
𝔽𝕠𝕣𝕕
Engine Type
3.0 V6
Engine Size
𝟛.𝟘
Transmission
Automatic
2WD / 4WD
2WD
I'm pretty sure it's your ABS going off... and I've have some issue with the front wheel speed sensors.

Tell me... does it tend to wanna pull the truck left or right when it happens?

These wheel speed sensors tend to fall off when at slow speeds... but the others say it's still moving so ABS tends to unapply whatever speed sensor falls off.
Yea but I’m not getting an ABS light. This is my issue with an “older” truck. I’m tired of chasing issues.
 

MrGearhead

Member
Joined
Nov 10, 2018
Messages
37
Reaction score
12
Points
8
Location
Illinois
Vehicle Year
𝟚𝟘𝟘𝟞
Make / Model
𝔽𝕠𝕣𝕕
Engine Type
3.0 V6
Engine Size
𝟛.𝟘
Transmission
Automatic
2WD / 4WD
2WD
Press the brake a few times to get a full pedal and then press hard on it! If it holds a few seconds and slowly goes to the floor your master cylinder is bad! Booster will 90% of the time cause a vacuum leak! Thus causing a high idle situation! I’m sure you got all the air out when you bleed the system? Could be the culprit? Couple of things to look for.
It stays hard. It only drops out when driving and a slightly aggressive braking.
 

Uncle Gump

Forum Staff Member
Forum Moderator
Supporting Member
TRS Event Participant
Joined
Sep 17, 2018
Messages
11,343
Reaction score
9,347
Points
113
Location
Ottawa IL
Vehicle Year
2006/1986
Make / Model
Ranger/BroncoII
Engine Size
4.0L SOHC/2.9L
2WD / 4WD
4WD
My credo
Lead, Follow or get out of my way
Yea but I’m not getting an ABS light. This is my issue with an “older” truck. I’m tired of chasing issues.
You won't get a light... it's working as it should.

Does it pull one way or the other?
 

Uncle Gump

Forum Staff Member
Forum Moderator
Supporting Member
TRS Event Participant
Joined
Sep 17, 2018
Messages
11,343
Reaction score
9,347
Points
113
Location
Ottawa IL
Vehicle Year
2006/1986
Make / Model
Ranger/BroncoII
Engine Size
4.0L SOHC/2.9L
2WD / 4WD
4WD
My credo
Lead, Follow or get out of my way
Yea but I’m not getting an ABS light. This is my issue with an “older” truck. I’m tired of chasing issues.
You won't get a light... it's working as it should.

Does it pull one way or the other?
 

MrGearhead

Member
Joined
Nov 10, 2018
Messages
37
Reaction score
12
Points
8
Location
Illinois
Vehicle Year
𝟚𝟘𝟘𝟞
Make / Model
𝔽𝕠𝕣𝕕
Engine Type
3.0 V6
Engine Size
𝟛.𝟘
Transmission
Automatic
2WD / 4WD
2WD

Uncle Gump

Forum Staff Member
Forum Moderator
Supporting Member
TRS Event Participant
Joined
Sep 17, 2018
Messages
11,343
Reaction score
9,347
Points
113
Location
Ottawa IL
Vehicle Year
2006/1986
Make / Model
Ranger/BroncoII
Engine Size
4.0L SOHC/2.9L
2WD / 4WD
4WD
My credo
Lead, Follow or get out of my way
Then it could be the rear sensor. If it pulled... it would be easy to tell what sensor went bad.

I would look at wheel speed data... or have someone with a tool look.

I guess I should have asked the obvious.... you don't have a wheel locking up... do you?
 

MrGearhead

Member
Joined
Nov 10, 2018
Messages
37
Reaction score
12
Points
8
Location
Illinois
Vehicle Year
𝟚𝟘𝟘𝟞
Make / Model
𝔽𝕠𝕣𝕕
Engine Type
3.0 V6
Engine Size
𝟛.𝟘
Transmission
Automatic
2WD / 4WD
2WD
Then it could be the rear sensor. If it pulled... it would be easy to tell what sensor went bad.

I would look at wheel speed data... or have someone with a tool look.

I guess I should have asked the obvious.... you don't have a wheel locking up... do you?
No lock up. I have a Snap-on Apollo at the shop. I’ll have to take it for a quick ride.
 

Bronco ii Man

Active Member
Joined
Jun 1, 2022
Messages
146
Reaction score
43
Points
28
Age
48
Location
Southport NC
Vehicle Year
85
Make / Model
Ford Bronco ii
Engine Type
2.8 V6
Engine Size
2.8 v6
Transmission
Manual
2WD / 4WD
4WD
Total Lift
0
Total Drop
0
Tire Size
31x10.50-15
Weird no lights, no pulling, and only goes to the floor on hard braking! Got a gremlin somewhere lol!
 

MrGearhead

Member
Joined
Nov 10, 2018
Messages
37
Reaction score
12
Points
8
Location
Illinois
Vehicle Year
𝟚𝟘𝟘𝟞
Make / Model
𝔽𝕠𝕣𝕕
Engine Type
3.0 V6
Engine Size
𝟛.𝟘
Transmission
Automatic
2WD / 4WD
2WD
Weird no lights, no pulling, and only goes to the floor on hard braking! Got a gremlin somewhere lol!
Yep… I hate chasing gremlins now.
I need to get off my ass and finish the project.
565663CD-9FC8-4942-A216-BE3E9F02EAAB.jpeg
 

Ranger850

Banned... except Florida... and here soon
Supporting Member
TRS 20th Anniversary
Joined
Jan 24, 2018
Messages
8,006
Reaction score
4,286
Points
113
Location
Tallahassee Florida
Vehicle Year
2001
Make / Model
Ford
Engine Size
Born with a 3.0, looking for a donor V8
Transmission
Manual
2WD / 4WD
2WD
Total Lift
Stock 2"
Tire Size
Stock
My credo
Doing things wrong, until I get it right.
1654526476857.png

1654526488102.png


Same truck???
 

Sponsored Ad


Sponsored Ad

Top