• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

All about them gauges


cheetolegs

New Member
Joined
Sep 17, 2015
Messages
1
Reaction score
0
Points
0
Vehicle Year
1993
Make / Model
Ford
Transmission
Manual
So I have a 93 Ranger 4.0L 4x4 with a manual transmission.

Problem:
All of the gauges with the exception of the speedometer gauge are dead. The speedometer gauge goes crazy when you accelerate and goes to the correct speed when you let off of the gas.

When it happened:
I knew a guy that needed some cash so he did a lot of work on it for me. He replaced the AC system, the emergency brake cable, and worked on the brakes.

Question:
How do I go about troubleshooting this? Could it actually be a bad cluster or some connection I'm not aware of? I'm thinking something happened when he was working under the dash with the emergency break line but I'm not finding any loose connections.

Thanks in advance!
 

Attachments



Rock Auto 5% Discount Code: F9A1A579ACFAD1: October 1st, 2021

Nitrider73

New Member
Joined
Sep 17, 2015
Messages
8
Reaction score
0
Points
0
Vehicle Year
1988
Make / Model
Ford
Transmission
Automatic
I know an alternators voltage regulator or the diodes inside could go bad and will make sensors and gauges go crazy. your best bet is to find another cluster out of a junk yard and replace it just to see if its nit the cluster itself. I always keep an extra cluster for every vehicle I have just in case.
 


Top